aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-26 03:05:47 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-26 03:05:47 +0000
commita1ca1f13a2611dff091027fe15eba9e35e8b3704 (patch)
tree3473461c384516f143089bca4fc7b8323f43e203 /www/seamonkey2
parent5165f9174afe31d98c123573ec584fcdfdef9e67 (diff)
downloadports-a1ca1f13a2611dff091027fe15eba9e35e8b3704.tar.gz
ports-a1ca1f13a2611dff091027fe15eba9e35e8b3704.zip
Notes
Diffstat (limited to 'www/seamonkey2')
-rw-r--r--www/seamonkey2/Makefile63
-rw-r--r--www/seamonkey2/distinfo4
-rw-r--r--www/seamonkey2/files/patch-build_unix_run-mozilla.sh17
-rw-r--r--www/seamonkey2/files/patch-config_preprocess.pl56
-rw-r--r--www/seamonkey2/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp48
-rw-r--r--www/seamonkey2/files/patch-modules::libpref::src::unix::unix.js14
-rw-r--r--www/seamonkey2/files/patch-qt46
7 files changed, 81 insertions, 167 deletions
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index 3ece92d1b925..fbb93248f66c 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -6,16 +6,13 @@
#
PORTNAME?= mozilla
-PORTVERSION= 1.6.b
-PORTREVISION?= 1
+PORTVERSION= 1.7.a
+PORTREVISION?= 0
PORTEPOCH?= 1
CATEGORIES?= www
-MASTER_SITES= ${MASTER_SITE_MOZILLA} \
- ${MASTER_SITE_LOCAL:S/$/:local/}
-MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.b/b/}/src \
- marcus/:local
-DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.b/b/}${EXTRACT_SUFX} \
- libart_lgpl${EXTRACT_SUFX}:local
+MASTER_SITES= ${MASTER_SITE_MOZILLA}
+MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.a/a/}/src
+DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.a/a/}${EXTRACT_SUFX}
MAINTAINER= gnome@FreeBSD.org
COMMENT= The open source, standards compliant web browser
@@ -30,8 +27,6 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
WRKSRC= ${WRKDIR}/${PORTNAME}
-IGNORE= "Main port has been upgraded to 1.6"
-
MOZILLA?= mozilla-devel
MOZ_SUFX= -devel
@@ -55,10 +50,6 @@ BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
BROKEN= "Calendar requires Composer and Mailnews support."
.endif
-.if defined(WITH_CALENDAR)
-LIB_DEPENDS+= ical.0:${PORTSDIR}/devel/libical
-.endif
-
LATEST_LINK= ${MOZILLA}
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
--exclude */macbuild/*\
@@ -69,6 +60,7 @@ EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_PERL5= yes
+USE_ICONV= yes
USE_GMAKE= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
@@ -92,6 +84,7 @@ CONFIGURE_ARGS= \
--disable-plaintext-editor-only \
--enable-strip \
--enable-svg \
+ --enable-svg-renderer-libart \
--disable-tests \
--disable-xterm-updates \
--enable-xinerama \
@@ -121,7 +114,8 @@ MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},irc
MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},xmlterm
.endif
CONFIGURE_ARGS+= --enable-extensions=${MOZ_EXTENSIONS}
-CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
+CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1 \
+ LOCALBASE=${LOCALBASE}
.if defined(WITH_JAVASCRIPT_DEBUGGER)
CONFIGURE_ARGS+= --enable-jsd \
@@ -132,7 +126,6 @@ CONFIGURE_ARGS+= --disable-jsd \
.endif
.if defined(WITH_CALENDAR)
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+= --enable-calendar
.endif
@@ -156,12 +149,22 @@ PKGCONFIG_FILES=mozilla-gtkmozembed mozilla-js mozilla-xpcom \
mozilla-nspr mozilla-nss mozilla-plugin
# JPI stuff. List paths to Java Plug-ins here in the order to try.
-JPI_LIST=\
+JPI_LIST?=\
${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
${LOCALBASE}/jdk1.4.1/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
${LOCALBASE}/diablo-jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
${LOCALBASE}/jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so
+OPTIONS= XFT "Enable Xft font anti-aliasing" on \
+ CALENDAR "Enable the Calendar module" off \
+ MAILNEWS "Enable Mail and News modules" on \
+ COMPOSER "Enable the HTML Composer module" on \
+ LDAP "Enable LDAP support for Mailnews" on \
+ CHATZILLA "Enable the Chatzilla IRC module" on \
+ XMLTERM "Enable the XMLTerm module" on \
+ JAVASCRIPT_DEBUGGER "Enable the DTD and JavaScript debuggers" off \
+ OPTIMIZED_CFLAGS "Enable -O2 optimizations" off
+
.include <bsd.port.pre.mk>
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
@@ -186,22 +189,12 @@ BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installi
.endif
pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Mozilla has the following tunable option(s):"
- @${ECHO_MSG} " WITHOUT_XFT=yes Disables Xft anti-aliasing support"
- @${ECHO_MSG} " WITH_CALENDAR=yes Enables the Calendar module (requires Mailnews and Composer modules)"
- @${ECHO_MSG} " WITHOUT_MAILNEWS=yes Disables the Mail and News modules"
- @${ECHO_MSG} " WITHOUT_COMPOSER=yes Disables the HTML Composer module"
- @${ECHO_MSG} " WITHOUT_LDAP=yes Disables LDAP support within the Mailnews module"
- @${ECHO_MSG} " WITHOUT_CHATZILLA=yes Disable the Chatzilla IRC module"
- @${ECHO_MSG} " WITHOUT_XMLTERM=yes Disable the XMLTerm module"
- @${ECHO_MSG} " WITH_JAVASCRIPT_DEBUGGER=yes Enable the DTD and JavaScript debuggers"
- @${ECHO_MSG} " WITH_OPTIMIZED_CFLAGS=yes Enable -O2 optimization"
- @${ECHO_MSG} ""
.if defined(WITH_CALENDAR)
+ @${ECHO_MSG} ""
@${ECHO_MSG} "Calendar is still beta software."
@${ECHO_MSG} "Use at your own risk."
@${ECHO_MSG} "http://mozilla.org/projects/calendar/"
+ @${ECHO_MSG} ""
.endif
post-patch:
@@ -212,7 +205,8 @@ post-patch:
${WRKSRC}/config/autoconf.mk.in
@${FIND} ${WRKSRC}/other-licenses/libical -name "*.c" | ${XARGS} \
${REINPLACE_CMD} 's|<malloc.h>|<stdlib.h>|g'
- @${REINPLACE_CMD} -e 's|-lc_r|${PTHREAD_LIBS}|g' \
+ @${REINPLACE_CMD} -e 's|-lc_r|${PTHREAD_LIBS}|g ; \
+ s|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure \
${WRKSRC}/nsprpub/configure
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
@@ -220,6 +214,15 @@ post-patch:
${WRKSRC}/security/coreconf/FreeBSD.mk \
${WRKSRC}/directory/c-sdk/config/FreeBSD.mk \
${WRKSRC}/js/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|libesd\.so\.0|${ESD_LIB}|g' \
+ ${WRKSRC}/widget/src/gtk2/nsSound.cpp
+ @${REINPLACE_CMD} -e '/accessibility.typeaheadfind.enablesound/s/true/false/' \
+ ${WRKSRC}/modules/libpref/src/init/all.js \
+ ${WRKSRC}/calendar/sunbird/app/profile/all.js
+ @${REINPLACE_CMD} -e 's|<iconv.h>|\"${LOCALBASE}/include/iconv.h\"|g' \
+ ${WRKSRC}/configure \
+ ${WRKSRC}/intl/uconv/native/nsNativeUConvService.cpp \
+ ${WRKSRC}/xpcom/io/nsNativeCharsetUtils.cpp
@for pcfile in ${PKGCONFIG_FILES}; do \
${REINPLACE_CMD} -e 's|mozilla-xpcom|mozilla-xpcom${MOZ_SUFX}${PKGNAMESUFFIX}|g ; \
s|mozilla-nspr|mozilla-nspr${MOZ_SUFX}${PKGNAMESUFFIX}|g' \
diff --git a/www/seamonkey2/distinfo b/www/seamonkey2/distinfo
index e1f00f6cab37..de32eb39d73b 100644
--- a/www/seamonkey2/distinfo
+++ b/www/seamonkey2/distinfo
@@ -1,2 +1,2 @@
-MD5 (mozilla-source-1.6b.tar.bz2) = 713c8b4660f09c035940e3d90305fb67
-MD5 (libart_lgpl.tar.bz2) = f332c3c026adc1c2c0ceb3ac5847d5f5
+MD5 (mozilla-source-1.7a.tar.bz2) = 6ae50cc951fc112758d5c5dc6b4c3081
+SIZE (mozilla-source-1.7a.tar.bz2) = 32671397
diff --git a/www/seamonkey2/files/patch-build_unix_run-mozilla.sh b/www/seamonkey2/files/patch-build_unix_run-mozilla.sh
index 96084fd68646..f93248fd107b 100644
--- a/www/seamonkey2/files/patch-build_unix_run-mozilla.sh
+++ b/www/seamonkey2/files/patch-build_unix_run-mozilla.sh
@@ -1,5 +1,7 @@
---- build/unix/run-mozilla.sh.orig Wed Oct 23 00:08:03 2002
-+++ build/unix/run-mozilla.sh Wed Oct 23 00:08:59 2002
+$FreeBSD$
+
+--- build/unix/run-mozilla.sh.orig Mon Dec 15 12:27:28 2003
++++ build/unix/run-mozilla.sh Wed Feb 11 14:24:17 2004
@@ -355,7 +355,7 @@
fi
##
@@ -9,16 +11,7 @@
if [ -n "$LD_LIBRARYN32_PATH" ]
then
LD_LIBRARYN32_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:${MRE_HOME}${LD_LIBRARYN32_PATH+":$LD_LIBRARYN32_PATH"}
-@@ -392,7 +392,7 @@
- export XSUNTRANSPORT XSUNSMESIZE
- fi
- # Font path for Xft
--FONTCONFIG_PATH="/etc/fonts:${MOZILLA_FIVE_HOME}/res/Xft"
-+FONTCONFIG_PATH="%%PREFIX%%/etc/fonts:${MOZILLA_FIVE_HOME}/res/Xft"
- export FONTCONFIG_PATH
-
- if [ "$moz_debug" -eq 1 ]
-@@ -435,6 +435,9 @@
+@@ -442,6 +442,9 @@
#
export MOZILLA_FIVE_HOME LD_LIBRARY_PATH
export SHLIB_PATH LIBPATH LIBRARY_PATH ADDON_PATH DYLD_LIBRARY_PATH
diff --git a/www/seamonkey2/files/patch-config_preprocess.pl b/www/seamonkey2/files/patch-config_preprocess.pl
deleted file mode 100644
index 390f4700dd53..000000000000
--- a/www/seamonkey2/files/patch-config_preprocess.pl
+++ /dev/null
@@ -1,56 +0,0 @@
---- config/preprocessor.pl.orig Fri Oct 24 18:17:32 2003
-+++ config/preprocessor.pl Sun Dec 7 15:17:57 2003
-@@ -76,16 +76,40 @@
- ########################################################################
-
- package main;
--use File::Spec 0.8;
-+use File::Spec;
- use File::Spec::Unix; # on all platforms, because the #include syntax is unix-based
-+use File::Basename;
-+use Cwd;
-+
-+# This code is taken from File::Spec::Unix 0.8.
-+sub rel2abs {
-+ my ($path, $base) = @_;
-+
-+ if ( ! File::Spec->file_name_is_absolute( $path ) ) {
-+ if ( !defined( $base ) || $base eq '' ) {
-+ $base = cwd() ;
-+ }
-+ elsif ( ! File::Spec->file_name_is_absolute( $base ) ) {
-+ $base = rel2abs( $base );
-+ }
-+ else {
-+ $base = File::Spec->canonpath( $base );
-+ }
-+
-+ $path = File::Spec->catdir( $base, $path );
-+ }
-+
-+ return File::Spec->canonpath( $path );
-+}
-+# End code from File::Spec::Unix
-+
-
- sub include {
- my($stack, $filename) = @_;
- my $directory = $stack->{'variables'}->{'DIRECTORY'};
- if ($filename ne '-') {
-- $filename = File::Spec->rel2abs($filename, $directory);
-- my($volume, $path) = File::Spec->splitpath($filename);
-- $directory = File::Spec->catpath($volume, $path, '');
-+ $filename = rel2abs($filename, $directory);
-+ $directory = File::Spec->catdir(dirname($filename));
- }
- local $stack->{'variables'}->{'DIRECTORY'} = $directory;
- local $stack->{'variables'}->{'FILE'} = $filename;
-@@ -395,7 +419,7 @@
- my $stack = shift;
- return if $stack->disabled;
- die "argument expected\n" unless @_;
-- my $filename = File::Spec->catpath(File::Spec::Unix->splitpath(@_));
-+ my $filename = File::Spec->catpath(dirname(@_), basename(@_));
- if ($stack->{'dependencies'}) {
- $stack->visit($filename);
- } else {
diff --git a/www/seamonkey2/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp b/www/seamonkey2/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp
deleted file mode 100644
index 2adcd3412e13..000000000000
--- a/www/seamonkey2/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp
+++ /dev/null
@@ -1,48 +0,0 @@
---- gfx/src/gtk/nsFontMetricsXft.cpp.orig Tue Nov 25 21:44:50 2003
-+++ gfx/src/gtk/nsFontMetricsXft.cpp Sun Dec 7 15:20:48 2003
-@@ -105,6 +105,7 @@
- FcPattern *mPattern;
- FcPattern *mFontName;
- FcCharSet *mCharset;
-+ int mNotXft;
- };
-
- class nsFontXftInfo;
-@@ -1093,7 +1094,7 @@
-
- for (PRInt32 i = 1, end = mLoadedFonts.Count(); i < end; ++i) {
- nsFontXft *font = (nsFontXft *)mLoadedFonts.ElementAt(i);
-- if (font->HasChar(PRUint32(aChar)))
-+ if (font->HasChar(PRUint32(aChar)) && font->GetXftFont())
- return font;
- }
-
-@@ -1960,6 +1961,7 @@
- FcPatternReference(mFontName);
-
- mXftFont = nsnull;
-+ mNotXft = 0;
-
- // set up our charset
- mCharset = nsnull;
-@@ -1986,7 +1988,7 @@
- XftFont *
- nsFontXft::GetXftFont(void)
- {
-- if (!mXftFont) {
-+ if (!mXftFont && !mNotXft) {
- FcPattern *pat = FcFontRenderPrepare(0, mPattern, mFontName);
- if (!pat)
- return nsnull;
-@@ -2005,8 +2007,10 @@
- FcPatternDel(pat, FC_SPACING);
-
- mXftFont = XftFontOpenPattern(GDK_DISPLAY(), pat);
-- if (!mXftFont)
-+ if (!mXftFont) {
- FcPatternDestroy(pat);
-+ mNotXft = 1;
-+ }
- }
-
- return mXftFont;
diff --git a/www/seamonkey2/files/patch-modules::libpref::src::unix::unix.js b/www/seamonkey2/files/patch-modules::libpref::src::unix::unix.js
deleted file mode 100644
index bd39a70bf05d..000000000000
--- a/www/seamonkey2/files/patch-modules::libpref::src::unix::unix.js
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- modules/libpref/src/unix/unix.js 2002/03/14 15:04:20 1.1
-+++ modules/libpref/src/unix/unix.js 2002/03/14 15:04:38
-@@ -227,7 +227,7 @@
-
- // TrueType
- pref("font.FreeType2.enable", false);
--pref("font.freetype2.shared-library", "libfreetype.so.6");
-+pref("font.freetype2.shared-library", "libfreetype.so.9");
- // if libfreetype was built without hinting compiled in
- // it is best to leave hinting off
- pref("font.FreeType2.autohinted", false);
diff --git a/www/seamonkey2/files/patch-qt b/www/seamonkey2/files/patch-qt
index d7e0dd95bbc2..8f1959e47c31 100644
--- a/www/seamonkey2/files/patch-qt
+++ b/www/seamonkey2/files/patch-qt
@@ -1,14 +1,50 @@
---- configure.orig Tue Aug 26 11:56:36 2003
-+++ configure Fri Aug 29 15:42:39 2003
-@@ -11870,9 +11870,9 @@
+--- configure.orig Thu Feb 12 11:11:29 2004
++++ configure Wed Feb 25 17:48:17 2004
+@@ -9259,7 +9259,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-liconv $LIBS"
++LIBS="-L$LOCALBASE/lib -liconv $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 9265 "configure"
+ #include "confdefs.h"
+@@ -9290,7 +9290,7 @@
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+- _ICONV_LIBS="$_ICONV_LIBS -liconv"
++ _ICONV_LIBS="$_ICONV_LIBS -L$LOCALBASE/lib -liconv"
+ else
+ echo "$ac_t""no" 1>&6
+ echo $ac_n "checking for libiconv in -liconv""... $ac_c" 1>&6
+@@ -9300,7 +9300,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-liconv $LIBS"
++LIBS="-L$LOCALBASE/lib -liconv $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 9306 "configure"
+ #include "confdefs.h"
+@@ -9331,7 +9331,7 @@
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+- _ICONV_LIBS="$_ICONV_LIBS -liconv"
++ _ICONV_LIBS="$_ICONV_LIBS -L$LOCALBASE/lib -liconv"
+ else
+ echo "$ac_t""no" 1>&6
+ fi
+@@ -12047,9 +12047,9 @@
-MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help p3p pref transformiix venkman inspector irc universalchardet typeaheadfind webservices spellcheck"
+MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help p3p pref transformiix venkman inspector universalchardet typeaheadfind webservices spellcheck"
--MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT xmlterm datetime finger cview layout-debug"
-+MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT irc xmlterm datetime finger cview layout-debug"
+-MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT xmlterm datetime finger cview layout-debug tasks"
++MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT irc xmlterm datetime finger cview layout-debug tasks"
# Check whether --enable-extensions or --disable-extensions was given.
if test "${enable_extensions+set}" = set; then