aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey2
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-12-21 19:40:44 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-12-21 19:40:44 +0000
commitcd3604440efa805410fd57c1510b28e2539c7b29 (patch)
treee61434256254222071162a9568bf7091f85b0b37 /www/seamonkey2
parentc1e724483a99f3bf014dc795a9b7f8977bf99661 (diff)
downloadports-cd3604440efa805410fd57c1510b28e2539c7b29.tar.gz
ports-cd3604440efa805410fd57c1510b28e2539c7b29.zip
Notes
Diffstat (limited to 'www/seamonkey2')
-rw-r--r--www/seamonkey2/Makefile2
-rw-r--r--www/seamonkey2/files/patch-an11
-rw-r--r--www/seamonkey2/files/patch-mi19
-rw-r--r--www/seamonkey2/files/patch-qt34
4 files changed, 54 insertions, 12 deletions
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index 0d7e8dd3226d..7fc63621219b 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -49,7 +49,7 @@ CONFIGURE_ARGS= \
--with-jpeg=${LOCALBASE} \
--with-png=${LOCALBASE}
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
- CC_ONLY_FLAGS="${FLAGS}" CCC_ONLY_FLAGS="${CXXFLAGS}"
+ CC_ONLY_FLAGS="${CFLAGS}" CCC_ONLY_FLAGS="${CXXFLAGS}"
post-build:
@${SED} -e "s;@PREFIX@;${PREFIX};g" \
diff --git a/www/seamonkey2/files/patch-an b/www/seamonkey2/files/patch-an
new file mode 100644
index 000000000000..2904080e1e35
--- /dev/null
+++ b/www/seamonkey2/files/patch-an
@@ -0,0 +1,11 @@
+--- js/src/Makefile.in.orig Thu Dec 21 01:23:12 2000
++++ js/src/Makefile.in Thu Dec 21 01:23:22 2000
+@@ -218,7 +218,7 @@
+ endif
+
+ ifeq ($(OS_ARCH),FreeBSD)
+-LDFLAGS += -pthread
++LDFLAGS += -pthread -lgcc_r
+ endif
+ ifeq ($(OS_ARCH),IRIX)
+ ifdef USE_N32
diff --git a/www/seamonkey2/files/patch-mi b/www/seamonkey2/files/patch-mi
index 80768e265de9..b9b9c146c953 100644
--- a/www/seamonkey2/files/patch-mi
+++ b/www/seamonkey2/files/patch-mi
@@ -1,13 +1,13 @@
--- nsprpub/config/FreeBSD.mk.orig Wed Oct 20 14:19:53 1999
-+++ nsprpub/config/FreeBSD.mk Thu Feb 3 03:48:20 2000
-@@ -21,14 +21,16 @@
++++ nsprpub/config/FreeBSD.mk Thu Dec 21 01:16:34 2000
+@@ -21,24 +21,26 @@
include $(MOD_DEPTH)/config/UNIX.mk
-CC = gcc
-CCC = g++
RANLIB = ranlib
-+CCC = ${CXX}
++CCC = ${CXX}
+
+# During FreeBSD port build, CFLAGS contains all of the optimizations
+# flags desired...
@@ -20,3 +20,16 @@
CPU_ARCH = x86
endif
CPU_ARCH_TAG = _$(CPU_ARCH)
+
+-OS_CFLAGS = $(DSO_CFLAGS) $(OS_REL_CFLAGS) -ansi -Wall -pipe $(THREAD_FLAG) -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
++OS_CFLAGS = $(DSO_CFLAGS) $(OS_REL_CFLAGS) -ansi -Wall -pipe -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
+
+ ifeq ($(USE_PTHREADS),1)
+ IMPL_STRATEGY = _PTH
+-DEFINES += -D_THREAD_SAFE
+-THREAD_FLAG += -pthread
++DEFINES += -D_THREAD_SAFE -D_REENTRANT
++DSO_LDOPTS += -pthread -lgcc_r
+ else
+ IMPL_STRATEGY = _EMU
+ DEFINES += -D_PR_LOCAL_THREADS_ONLY
diff --git a/www/seamonkey2/files/patch-qt b/www/seamonkey2/files/patch-qt
index b7964a4911ff..361bf6cbdd5d 100644
--- a/www/seamonkey2/files/patch-qt
+++ b/www/seamonkey2/files/patch-qt
@@ -1,21 +1,39 @@
---- configure.orig Thu Apr 13 19:18:25 2000
-+++ configure Thu Apr 20 09:07:57 2000
-@@ -5618,7 +5618,7 @@
+--- configure.orig Sat Sep 30 23:16:14 2000
++++ configure Thu Dec 21 00:49:23 2000
+@@ -5786,7 +5786,7 @@
echo $ac_n "checking for Qt insanity""... $ac_c" 1>&6
- echo "configure:5620: checking for Qt insanity" >&5
+ echo "configure:5788: checking for Qt insanity" >&5
- QT_CFLAGS="-I${QTDIR}/include/qt"
+ QT_CFLAGS="-I${QTDIR}/include/X11/qt"
QT_LIBS="-L/usr/X11R6/lib -L${QTDIR}/lib -lqt -lXext -lX11"
# Check whether --with-static-qt or --without-static-qt was given.
-@@ -7108,6 +7108,9 @@
- case "$target_os" in
+@@ -7702,6 +7702,9 @@
os2*)
LIBS=
-+ ;;
+ ;;
+freebsd*)
+ CPPFLAGS="${CPPFLAGS} ${X_CFLAGS}"
- ;;
++ ;;
esac
for ac_hdr in sys/byteorder.h compat.h getopt.h
+ do
+@@ -8655,8 +8658,6 @@
+ if test $? -eq 0; then
+ if test -z "`egrep -i '(unrecognize|unknown)' conftest.out | grep pthread`" && test -z "`egrep -i '(error|incorrect)' conftest.out`" ; then
+ ac_cv_have_dash_pthread=yes
+- CFLAGS="$CFLAGS -pthread"
+- CXXFLAGS="$CXXFLAGS -pthread"
+ fi
+ fi
+ rm -f conftest*
+@@ -8672,7 +8673,7 @@
+ EOF
+
+ if test "$ac_cv_have_dash_pthread" = "yes"; then
+- _PTHREAD_LDFLAGS=""
++ _PTHREAD_LDFLAGS="-pthread -lgcc_r"
+ else
+ _PTHREAD_LDFLAGS="-lc_r"
+ fi