aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-08-28 19:08:08 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-08-28 19:08:08 +0000
commit4eaecc6a2d9bb64972f7364400b6d0fe6ed891cc (patch)
treed640b7b1e30f0473b66d2691b1e3fde27adfe191 /www/seamonkey
parent0feaee076705efc5fe808641aede6c1b06afa244 (diff)
downloadports-4eaecc6a2d9bb64972f7364400b6d0fe6ed891cc.tar.gz
ports-4eaecc6a2d9bb64972f7364400b6d0fe6ed891cc.zip
Notes
Diffstat (limited to 'www/seamonkey')
-rw-r--r--www/seamonkey/Makefile4
-rw-r--r--www/seamonkey/files/mozilla-devel.desktop.in2
-rw-r--r--www/seamonkey/files/patch-mozilla_widget_src_gtk2_mozdrawingarea.c12
3 files changed, 16 insertions, 2 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 3bc4f5640d76..9e4703bd4c4d 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mozilla
PORTVERSION= 1.8.b1
-PORTREVISION?= 3
+PORTREVISION?= 4
PORTEPOCH?= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -213,6 +213,8 @@ USE_GNOME+= gnomehier
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's/%{idldir}/%idldir%/g' \
+ ${WRKSRC}/build/unix/mozilla-config.in
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/build/unix/run-mozilla.sh
@${REINPLACE_CMD} -e 's|%%MOZILLA%%|${MOZILLA}|g' \
diff --git a/www/seamonkey/files/mozilla-devel.desktop.in b/www/seamonkey/files/mozilla-devel.desktop.in
index 5f05c0464d34..88d7475a54f6 100644
--- a/www/seamonkey/files/mozilla-devel.desktop.in
+++ b/www/seamonkey/files/mozilla-devel.desktop.in
@@ -164,6 +164,6 @@ Exec=mozilla-devel %U
StartupNotify=true
Terminal=false
Type=Application
-Icon=%%PREFIX%%/lib/mozilla/chrome/icons/default/default.xpm
+Icon=%%PREFIX%%/lib/mozilla-devel/chrome/icons/default/default.xpm
Categories=Application;Network;
MimeType=text/html;text/xml;application/xhtml+xml;
diff --git a/www/seamonkey/files/patch-mozilla_widget_src_gtk2_mozdrawingarea.c b/www/seamonkey/files/patch-mozilla_widget_src_gtk2_mozdrawingarea.c
new file mode 100644
index 000000000000..9e58b51864f2
--- /dev/null
+++ b/www/seamonkey/files/patch-mozilla_widget_src_gtk2_mozdrawingarea.c
@@ -0,0 +1,12 @@
+--- widget/src/gtk2/mozdrawingarea.c.orig Tue Apr 30 12:29:00 2002
++++ widget/src/gtk2/mozdrawingarea.c Thu Aug 18 22:27:27 2005
+@@ -168,7 +168,9 @@
+
+ drawingarea = MOZ_DRAWINGAREA(object);
+
++ gdk_window_set_user_data(drawingarea->inner_window, NULL);
+ gdk_window_destroy(drawingarea->inner_window);
++ gdk_window_set_user_data(drawingarea->clip_window, NULL);
+ gdk_window_destroy(drawingarea->clip_window);
+
+ (* parent_class->finalize) (object);