aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-05-23 04:04:53 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-05-23 04:04:53 +0000
commitab146876a894c84256e94c43b6955b2a2ad49313 (patch)
tree572a7cb00f34e1c0b690c1c2c98c5679ce2606a8 /www/seamonkey
parenta4f1fd52f64b460f8a2b8fde50cd444f4b9b625f (diff)
downloadports-ab146876a894c84256e94c43b6955b2a2ad49313.tar.gz
ports-ab146876a894c84256e94c43b6955b2a2ad49313.zip
Notes
Diffstat (limited to 'www/seamonkey')
-rw-r--r--www/seamonkey/Makefile2
-rw-r--r--www/seamonkey/files/patch-addon-search13
2 files changed, 14 insertions, 1 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index e442058e2a34..7346698bd1b2 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -3,7 +3,7 @@
PORTNAME= seamonkey
DISTVERSION= 2.49.3
-PORTREVISION= 3
+PORTREVISION= 4
MOZILLA_VER= 52 # above + 3
CATEGORIES?= www mail news editors irc ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/seamonkey/files/patch-addon-search b/www/seamonkey/files/patch-addon-search
index 1378bf8778e1..4fd8f82f9f5a 100644
--- a/www/seamonkey/files/patch-addon-search
+++ b/www/seamonkey/files/patch-addon-search
@@ -55,3 +55,16 @@ index f70fd8d7e3bd8..81e8cd7764fdf 100644
break;
}
+diff --git toolkit/mozapps/extensions/internal/XPIProvider.jsm toolkit/mozapps/extensions/internal/XPIProvider.jsm
+index f70fd8d7e3bd8..81e8cd7764fdf 100644
+--- mozilla/toolkit/mozapps/extensions/internal/XPIProvider.jsm
++++ mozilla/toolkit/mozapps/extensions/internal/XPIProvider.jsm
+@@ -7186,7 +7186,7 @@ AddonInternal.prototype = {
+ // Something is causing errors in here
+ try {
+ for (let platform of this.targetPlatforms) {
+- if (platform.os == Services.appinfo.OS) {
++ if (platform.os == "Linux") {
+ if (platform.abi) {
+ needsABI = true;
+ if (platform.abi === abi)