aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2004-01-18 07:27:03 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2004-01-18 07:27:03 +0000
commit547e6f8a3d7f68b31c392345c88f4e772521e8f5 (patch)
tree0846ac3629572115e4f567bbf1b94845abffd5d0 /www/seamonkey
parent27f75362fcaf97e6e1762b822d15c470054c7476 (diff)
downloadports-547e6f8a3d7f68b31c392345c88f4e772521e8f5.tar.gz
ports-547e6f8a3d7f68b31c392345c88f4e772521e8f5.zip
Notes
Diffstat (limited to 'www/seamonkey')
-rw-r--r--www/seamonkey/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 6411d9ce18ff..6051de3230f6 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -260,6 +260,11 @@ pre-install:
for pcfile in ${PKGCONFIG_FILES}; do \
${ECHO_CMD} libdata/pkgconfig/$${pcfile}${MOZ_SUFX}${PKGNAMESUFFIX}.pc >> ${PLIST} ; \
done
+ cd ${WRKSRC}/dist/include && ${FIND} -s * -type f -o -type l | \
+ ${SED} -e 's:^:include/mozilla/:' >> ${PLIST} \
+ && ${FIND} -d * -type d | \
+ ${SED} -e 's:^:@dirrm include/mozilla/:' >> ${PLIST}
+ ${ECHO_CMD} @dirrm include/mozilla >> ${PLIST}
do-install:
${MKDIR} ${PREFIX}/lib/${MOZILLA}
@@ -286,6 +291,11 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/build/unix/$${pcfile}.pc \
${PREFIX}/libdata/pkgconfig/$${pcfile}${MOZ_SUFX}${PKGNAMESUFFIX}.pc ; \
done
+ -${RM} -fr ${PREFIX}/include/mozilla
+ ${MKDIR} ${PREFIX}/include/mozilla
+ ${CHMOD} 755 ${PREFIX}/include/mozilla
+ cd ${WRKSRC}/dist/include && ${FIND} . | \
+ cpio -pdm -L -R ${LIBOWN}:${LIBGRP} ${PREFIX}/include/mozilla
post-install:
@${CHMOD} -R u-w ${PREFIX}/lib/${MOZILLA}/components