aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-05-01 05:29:08 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-05-01 05:29:08 +0000
commit3d25b2953ae3bcd0fa44f71157d690a0d67e57a0 (patch)
tree3a53b13f346cc5f079624a2713ae3cad28a9a655 /www/seamonkey
parent8535e2e3cc7f402140f03f89635b654155b7ab01 (diff)
downloadports-3d25b2953ae3bcd0fa44f71157d690a0d67e57a0.tar.gz
ports-3d25b2953ae3bcd0fa44f71157d690a0d67e57a0.zip
Notes
Diffstat (limited to 'www/seamonkey')
-rw-r--r--www/seamonkey/Makefile2
-rw-r--r--www/seamonkey/files/patch-bug126916524
2 files changed, 25 insertions, 1 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index cf96eab9afb7..1d7360dda747 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -4,7 +4,7 @@
PORTNAME= seamonkey
DISTVERSION= 2.39
MOZILLA_VER= 42 # above + 3
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES?= www mail news editors irc ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/www/seamonkey/files/patch-bug1269165 b/www/seamonkey/files/patch-bug1269165
new file mode 100644
index 000000000000..829af431046b
--- /dev/null
+++ b/www/seamonkey/files/patch-bug1269165
@@ -0,0 +1,24 @@
+# getUserMedia fails to enumerate ALSA plugins
+
+--- mozilla/media/webrtc/trunk/webrtc/modules/audio_device/linux/audio_device_alsa_linux.cc.orig 2016-04-22 00:37:17 UTC
++++ mozilla/media/webrtc/trunk/webrtc/modules/audio_device/linux/audio_device_alsa_linux.cc
+@@ -1752,7 +1752,9 @@ int32_t AudioDeviceLinuxALSA::GetDevices
+ // Don't use snd_device_name_hint(-1,..) since there is a access violation
+ // inside this ALSA API with libasound.so.2.0.0.
+ int card = -1;
++#ifdef WEBRTC_LINUX
+ while (!(LATE(snd_card_next)(&card)) && (card >= 0) && keepSearching) {
++#endif
+ void **hints;
+ err = LATE(snd_device_name_hint)(card, "pcm", &hints);
+ if (err != 0)
+@@ -1878,7 +1880,9 @@ int32_t AudioDeviceLinuxALSA::GetDevices
+ LATE(snd_strerror)(err));
+ // Continue and return true anyway, since we did get the whole list.
+ }
++#ifdef WEBRTC_LINUX
+ }
++#endif
+
+ if (FUNC_GET_NUM_OF_DEVICE == function)
+ {