aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2013-08-09 22:47:48 +0000
committerFlorian Smeets <flo@FreeBSD.org>2013-08-09 22:47:48 +0000
commitcec8fe3df83bfcbee785b769f07357cd93e794b9 (patch)
tree000d1456e6ffd2ee37afe3c4e25cc23d514b50fc /www/seamonkey
parent12cdec36f562f9f7494aaa4d98b3329ee0a0dfb5 (diff)
downloadports-cec8fe3df83bfcbee785b769f07357cd93e794b9.tar.gz
ports-cec8fe3df83bfcbee785b769f07357cd93e794b9.zip
Notes
Diffstat (limited to 'www/seamonkey')
-rw-r--r--www/seamonkey/Makefile2
-rw-r--r--www/seamonkey/files/extra-mailnews-patch-bridge-bridge.mk11
-rw-r--r--www/seamonkey/files/extra-patch-configure.in14
-rw-r--r--www/seamonkey/files/patch-bug89730030
4 files changed, 30 insertions, 27 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 62e0bb3b416c..b28cf72ae3ad 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -77,8 +77,6 @@ MOZSRC:= ${WRKSRC}/mozilla
XPI_LIBDIR= ${PREFIX}/lib/xpi
.if ! ${PORT_OPTIONS:MMAILNEWS}
-EXTRA_PATCHES+= ${FILESDIR}/extra-mailnews-patch-bridge-bridge.mk \
- ${FILESDIR}/extra-patch-configure.in
MOZ_OPTIONS+= --disable-ldap --disable-mailnews
.else
# mail and news desired, but not LDAP
diff --git a/www/seamonkey/files/extra-mailnews-patch-bridge-bridge.mk b/www/seamonkey/files/extra-mailnews-patch-bridge-bridge.mk
deleted file mode 100644
index 76cd7b97fdd4..000000000000
--- a/www/seamonkey/files/extra-mailnews-patch-bridge-bridge.mk
+++ /dev/null
@@ -1,11 +0,0 @@
---- bridge/bridge.mk.orig 2012-03-13 06:23:10.000000000 +0100
-+++ bridge/bridge.mk 2012-03-14 12:28:03.000000000 +0100
-@@ -47,8 +47,10 @@
- APP_LIBXUL_DIRS += $(DEPTH)$(SUBDIR)/db/mork
- #endif
-
-+ifdef disabled
- APP_LIBXUL_DIRS += \
- $(DEPTH)$(SUBDIR)/mailnews \
- $(NULL)
-+endif
diff --git a/www/seamonkey/files/extra-patch-configure.in b/www/seamonkey/files/extra-patch-configure.in
deleted file mode 100644
index fd516d09132e..000000000000
--- a/www/seamonkey/files/extra-patch-configure.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- configure.in.orig 2012-03-14 14:18:03.000000000 +0100
-+++ configure.in 2012-03-14 14:18:25.000000000 +0100
-@@ -837,11 +837,6 @@
- AC_PROG_CPP
- AC_PROG_CXXCPP
-
--MAIL_COMPONENT="mail msgsmime import"
--export MAIL_COMPONENT
--MAIL_MODULE="MODULE(nsMailModule) MODULE(nsMsgSMIMEModule) MODULE(nsImportServiceModule)"
--export MAIL_MODULE
--
- if test -n "$_WIN32_MSVC"; then
- SKIP_PATH_CHECKS=1
- SKIP_COMPILER_CHECKS=1
diff --git a/www/seamonkey/files/patch-bug897300 b/www/seamonkey/files/patch-bug897300
new file mode 100644
index 000000000000..316adf643bc9
--- /dev/null
+++ b/www/seamonkey/files/patch-bug897300
@@ -0,0 +1,30 @@
+# HG changeset patch
+# User Randell Jesup <rjesup@jesup.org>
+# Date 1375222105 14400
+# Node ID 64c5cc9bad2e84a9b1d6392b095ad06a75b94a4e
+# Parent 0368f4123c8aeb2209582fb8faf3bcb04acd0e13
+Bug897300: Correct mis-merge for pulse audio on Aurora from bug 886886 r=padenot a=bajaj
+
+diff --git a/media/webrtc/trunk/webrtc/modules/audio_device/linux/audio_device_pulse_linux.h b/media/webrtc/trunk/webrtc/modules/audio_device/linux/audio_device_pulse_linux.h
+--- mozilla/media/webrtc/trunk/webrtc/modules/audio_device/linux/audio_device_pulse_linux.h
++++ mozilla/media/webrtc/trunk/webrtc/modules/audio_device/linux/audio_device_pulse_linux.h
+@@ -305,17 +305,17 @@ private:
+
+ AudioMixerManagerLinuxPulse _mixerManager;
+
+ WebRtc_UWord16 _inputDeviceIndex;
+ WebRtc_UWord16 _outputDeviceIndex;
+ bool _inputDeviceIsSpecified;
+ bool _outputDeviceIsSpecified;
+
+- WebRtc_Word32 sampling_rate_hz;
++ WebRtc_Word32 sample_rate_hz_;
+ WebRtc_UWord8 _recChannels;
+ WebRtc_UWord8 _playChannels;
+
+ AudioDeviceModule::BufferType _playBufType;
+
+ private:
+ bool _initialized;
+ bool _recording;
+