aboutsummaryrefslogtreecommitdiff
path: root/www/selenium
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-15 21:08:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-15 21:08:34 +0000
commit9f23c4c25c59b7a27f613490693f16a799e38463 (patch)
tree08dcab9e94c229ad764f11e03313febf59542927 /www/selenium
parent2b13301a9159f44c8be4c74cd729851c14a857d7 (diff)
downloadports-9f23c4c25c59b7a27f613490693f16a799e38463.tar.gz
ports-9f23c4c25c59b7a27f613490693f16a799e38463.zip
Notes
Diffstat (limited to 'www/selenium')
-rw-r--r--www/selenium/Makefile20
-rw-r--r--www/selenium/distinfo2
-rw-r--r--www/selenium/pkg-descr9
-rw-r--r--www/selenium/pkg-plist259
4 files changed, 290 insertions, 0 deletions
diff --git a/www/selenium/Makefile b/www/selenium/Makefile
new file mode 100644
index 000000000000..ef2dc586fc43
--- /dev/null
+++ b/www/selenium/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: selenium
+# Date created: 28 July 2005
+# Whom: kaworu
+#
+# $FreeBSD$
+#
+
+PORTNAME= selenium
+PORTVERSION= 0.5.0
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
+MASTER_SITE_SUBDIR= ${PORTNAME}/15968
+
+MAINTAINER= kaworu@users.sourceforge.jp
+COMMENT= Selenium is web application test tool!
+
+MAN1= selenium.1
+HAS_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/www/selenium/distinfo b/www/selenium/distinfo
new file mode 100644
index 000000000000..cc6d3ed759cb
--- /dev/null
+++ b/www/selenium/distinfo
@@ -0,0 +1,2 @@
+MD5 (selenium-0.5.0.tar.gz) = dbfa9cfce22049e65cf09185f56b28a2
+SIZE (selenium-0.5.0.tar.gz) = 1926021
diff --git a/www/selenium/pkg-descr b/www/selenium/pkg-descr
new file mode 100644
index 000000000000..dd5fa8840781
--- /dev/null
+++ b/www/selenium/pkg-descr
@@ -0,0 +1,9 @@
+Selenium is a test tool for web applications. Selenium tests run
+directly in a browsers, just as real users do. And they run in Internet
+Explorer, Mozilla and Firefox on Windows, Linux and Macintosh. No other
+test tool covers such a wide array of platforms.
+
+WWW: http://selenium.thoughtworks.com/
+
+- kaworu
+kaworu@users.sourceforge.jp
diff --git a/www/selenium/pkg-plist b/www/selenium/pkg-plist
new file mode 100644
index 000000000000..27a7fb86daf3
--- /dev/null
+++ b/www/selenium/pkg-plist
@@ -0,0 +1,259 @@
+www/data/selenium/devtests/meta/page.html
+www/data/selenium/devtests/TestClickInFrame.html
+www/data/selenium/devtests/TestOpenInFrame.html
+www/data/selenium/devtests/TestOpenInNewWindow.html
+www/data/selenium/devtests/TestOpenMeta.html
+www/data/selenium/devtests/TestSuite.html
+www/data/selenium/dom-images/butmin.gif
+www/data/selenium/dom-images/butplus.gif
+www/data/selenium/dom-styles/default.css
+www/data/selenium/html-xpath/carnation.jpg
+www/data/selenium/html-xpath/example.html
+www/data/selenium/html-xpath/html-xpath-patched.js
+www/data/selenium/html-xpath/html-xpath.js
+www/data/selenium/html-xpath/license.txt
+www/data/selenium/html-xpath/rainbow.jpg
+www/data/selenium/jsmock/mock-tests.html
+www/data/selenium/jsmock/mock.js
+www/data/selenium/jsunit/app/css/jsUnitStyle.css
+www/data/selenium/jsunit/app/css/readme
+www/data/selenium/jsunit/app/emptyPage.html
+www/data/selenium/jsunit/app/jsUnitCore.js
+www/data/selenium/jsunit/app/jsUnitTestManager.js
+www/data/selenium/jsunit/app/jsUnitTestSuite.js
+www/data/selenium/jsunit/app/jsUnitTracer.js
+www/data/selenium/jsunit/app/main-counts-errors.html
+www/data/selenium/jsunit/app/main-counts-failures.html
+www/data/selenium/jsunit/app/main-counts-runs.html
+www/data/selenium/jsunit/app/main-counts.html
+www/data/selenium/jsunit/app/main-data.html
+www/data/selenium/jsunit/app/main-errors.html
+www/data/selenium/jsunit/app/main-frame.html
+www/data/selenium/jsunit/app/main-loader.html
+www/data/selenium/jsunit/app/main-progress.html
+www/data/selenium/jsunit/app/main-results.html
+www/data/selenium/jsunit/app/main-status.html
+www/data/selenium/jsunit/app/testContainer.html
+www/data/selenium/jsunit/app/testContainerController.html
+www/data/selenium/jsunit/app/xbDebug.js
+www/data/selenium/jsunit/css/jsUnitStyle.css
+www/data/selenium/jsunit/images/green.gif
+www/data/selenium/jsunit/images/logo_jsunit.gif
+www/data/selenium/jsunit/images/red.gif
+www/data/selenium/jsunit/intellij/JsUnit.iml
+www/data/selenium/jsunit/intellij/JsUnit.ipr
+www/data/selenium/jsunit/java/bin/jsunit.jar
+www/data/selenium/jsunit/java/lib/javax.servlet.jar
+www/data/selenium/jsunit/java/lib/jdom.jar
+www/data/selenium/jsunit/java/lib/jetty.jar
+www/data/selenium/jsunit/java/lib/junit.jar
+www/data/selenium/jsunit/java/lib/xerces.jar
+www/data/selenium/jsunit/licenses/JDOM_license.txt
+www/data/selenium/jsunit/licenses/Jetty_license.html
+www/data/selenium/jsunit/licenses/MPL-1.1.txt
+www/data/selenium/jsunit/licenses/gpl-2.txt
+www/data/selenium/jsunit/licenses/index.html
+www/data/selenium/jsunit/licenses/lgpl-2.1.txt
+www/data/selenium/jsunit/licenses/mpl-tri-license-c.txt
+www/data/selenium/jsunit/licenses/mpl-tri-license-html.txt
+www/data/selenium/jsunit/tests/data/data.html
+www/data/selenium/jsunit/tests/data/staff.css
+www/data/selenium/jsunit/tests/data/staff.dtd
+www/data/selenium/jsunit/tests/data/staff.xml
+www/data/selenium/jsunit/tests/index.html
+www/data/selenium/jsunit/tests/jsUnitAssertionTests.html
+www/data/selenium/jsunit/tests/jsUnitDeclAssertionTests.html
+www/data/selenium/jsunit/tests/jsUnitDeclFrameworkUtilityTests.html
+www/data/selenium/jsunit/tests/jsUnitDeclOnLoadTests.html
+www/data/selenium/jsunit/tests/jsUnitDeclSetUpTearDownTests.html
+www/data/selenium/jsunit/tests/jsUnitDeclTestFailures.html
+www/data/selenium/jsunit/tests/jsUnitDeclTestLoadData.html
+www/data/selenium/jsunit/tests/jsUnitDeclTestSetUpPages.html
+www/data/selenium/jsunit/tests/jsUnitDeclTestSetUpPagesSuite.html
+www/data/selenium/jsunit/tests/jsUnitDeclTestSuite.html
+www/data/selenium/jsunit/tests/jsUnitDeclUtilityTests.html
+www/data/selenium/jsunit/tests/jsUnitDeclarationTests.html
+www/data/selenium/jsunit/tests/jsUnitFrameworkUtilityTests.html
+www/data/selenium/jsunit/tests/jsUnitOnLoadTests.html
+www/data/selenium/jsunit/tests/jsUnitSetUpTearDownTests.html
+www/data/selenium/jsunit/tests/jsUnitTestFailures.html
+www/data/selenium/jsunit/tests/jsUnitTestLoadData.html
+www/data/selenium/jsunit/tests/jsUnitTestLoadStaff.html
+www/data/selenium/jsunit/tests/jsUnitTestSetUpPages.html
+www/data/selenium/jsunit/tests/jsUnitTestSetUpPagesSuite.html
+www/data/selenium/jsunit/tests/jsUnitTestSuite.html
+www/data/selenium/jsunit/tests/jsUnitUtilityTests.html
+www/data/selenium/jsunit/build.xml
+www/data/selenium/jsunit/changelist.txt
+www/data/selenium/jsunit/jsunit.properties.sample
+www/data/selenium/jsunit/readme.txt
+www/data/selenium/jsunit/testRunner.html
+www/data/selenium/tests/browserbot/alert-handling-tests.html
+www/data/selenium/tests/browserbot/browserbot-tests.html
+www/data/selenium/tests/browserbot/command-factory-tests.html
+www/data/selenium/tests/browserbot/command-handler-tests.html
+www/data/selenium/tests/browserbot/confirm-handling-tests.html
+www/data/selenium/tests/browserbot/error-checking-command-tests.html
+www/data/selenium/tests/browserbot/event-bubble-tests.html
+www/data/selenium/tests/browserbot/glob-tests.html
+www/data/selenium/tests/browserbot/optionlocator-tests.html
+www/data/selenium/tests/browserbot/pagebot-accessor-tests.html
+www/data/selenium/tests/browserbot/pagebot-action-tests.html
+www/data/selenium/tests/browserbot/pagebot-attribute-tests.html
+www/data/selenium/tests/browserbot/pagebot-locator-tests-include.html
+www/data/selenium/tests/browserbot/suite.html
+www/data/selenium/tests/browserbot/pagebot-locator-tests.html
+www/data/selenium/tests/browserbot/pagebot-property-tests.html
+www/data/selenium/tests/browserbot/selenium-api-tests.html
+www/data/selenium/tests/browserbot/selenium-api-tests.html.rej
+www/data/selenium/tests/browserbot/selenium-parameter-tests.html
+www/data/selenium/tests/events/TestButtonEvents.html
+www/data/selenium/tests/events/TestCheckboxEvents.html
+www/data/selenium/tests/events/TestLinkEvents.html
+www/data/selenium/tests/events/TestRadioEvents.html
+www/data/selenium/tests/events/TestSelectEvents.html
+www/data/selenium/tests/events/TestTextEvents.html
+www/data/selenium/tests/events/readme.txt
+www/data/selenium/tests/html/banner.gif
+www/data/selenium/tests/html/test_async_event.html
+www/data/selenium/tests/html/test_click_javascript_page.html
+www/data/selenium/tests/html/test_click_page1.html
+www/data/selenium/tests/html/test_click_page2.html
+www/data/selenium/tests/html/test_confirm.html
+www/data/selenium/tests/html/test_dummy_page.html
+www/data/selenium/tests/html/test_editable.html
+www/data/selenium/tests/html/test_focus_on_blur.html
+www/data/selenium/tests/html/test_form_events.html
+www/data/selenium/tests/html/test_framed_page.html
+www/data/selenium/tests/html/test_just_text.html
+www/data/selenium/tests/html/test_locators.html
+www/data/selenium/tests/html/test_modal_dialog.html
+www/data/selenium/tests/html/test_modal_dialog_dialog.html
+www/data/selenium/tests/html/test_open.html
+www/data/selenium/tests/html/test_reload_onchange_page.html
+www/data/selenium/tests/html/test_select.html
+www/data/selenium/tests/html/test_select_window.html
+www/data/selenium/tests/html/test_select_window_popup.html
+www/data/selenium/tests/html/test_slowloading_page.html
+www/data/selenium/tests/html/test_store_value.html
+www/data/selenium/tests/html/test_type_page1.html
+www/data/selenium/tests/html/test_type_page2.html
+www/data/selenium/tests/html/test_verifications.html
+www/data/selenium/tests/html/test_verify_alert.html
+www/data/selenium/tests/html/test_visibility.html
+www/data/selenium/tests/tableparser/tableparser-tests.html
+www/data/selenium/tests/ErrorCheckingTestSuite.html
+www/data/selenium/tests/GoogleTestSearch.html
+www/data/selenium/tests/GoogleTestSuite.html
+www/data/selenium/tests/JsUnitSuite.html
+www/data/selenium/tests/TestClick.html
+www/data/selenium/tests/TestClickJavascriptHref.html
+www/data/selenium/tests/TestCommandError.html
+www/data/selenium/tests/TestConfirmations.html
+www/data/selenium/tests/TestErrorChecking.html
+www/data/selenium/tests/TestFailingAssert.html
+www/data/selenium/tests/TestFailingVerifications.html
+www/data/selenium/tests/TestFocusOnBlur.html
+www/data/selenium/tests/TestGoBack.html
+www/data/selenium/tests/TestGlobMatching.html
+www/data/selenium/tests/TestImplicitLocators.html
+www/data/selenium/tests/TestJavascriptParameters.html
+www/data/selenium/tests/TestLocators.html
+www/data/selenium/tests/TestModalDialog.html
+www/data/selenium/tests/TestModalDialogDialog.html
+www/data/selenium/tests/TestOpen.html
+www/data/selenium/tests/TestPause.html
+www/data/selenium/tests/TestProxy.html
+www/data/selenium/tests/TestSelect.html
+www/data/selenium/tests/TestSelectWindow.html
+www/data/selenium/tests/TestStore.html
+www/data/selenium/tests/TestSuite-InternetExplorer.html
+www/data/selenium/tests/TestSuite-Konqueror.html
+www/data/selenium/tests/TestSuite-Safari.html
+www/data/selenium/tests/TestSuite.html
+www/data/selenium/tests/TestType.html
+www/data/selenium/tests/TestUserExtensions.html
+www/data/selenium/tests/TestVerifications.html
+www/data/selenium/tests/TestVerifyAlerts.html
+www/data/selenium/tests/TestVerifyAlertsFailures.html
+www/data/selenium/tests/TestVerifyConfirmationFailures.html
+www/data/selenium/tests/TestVerifyEditable.html
+www/data/selenium/tests/TestVerifyEditableFailures.html
+www/data/selenium/tests/TestVisibility.html
+www/data/selenium/tests/TestVisibilityFailures.html
+www/data/selenium/tests/TestWait.html
+www/data/selenium/tests/TestWaitFor.html
+www/data/selenium/tests/TestWaitInPopupWindow.html
+www/data/selenium/tests/TestXPathLocators.html
+www/data/selenium/tests/readme.txt
+www/data/selenium/tests/tinyWebServer.py
+www/data/selenium/SeleneseRunner.html
+www/data/selenium/TestRunner-splash.html
+www/data/selenium/TestRunner.hta
+www/data/selenium/TestRunner.html
+www/data/selenium/domviewer.html
+www/data/selenium/htmlutils.js
+www/data/selenium/index.html
+www/data/selenium/selenium-api.js
+www/data/selenium/selenium-browserbot.js
+www/data/selenium/selenium-commandhandlers.js
+www/data/selenium/selenium-domviewer.js
+www/data/selenium/selenium-executionloop.js
+www/data/selenium/selenium.css
+www/data/selenium/selenium-fitrunner.js
+www/data/selenium/selenium-logging.js
+www/data/selenium/selenium-logo.png
+www/data/selenium/selenium-tableparser.js
+www/data/selenium/user-extensions.js.sample
+www/data/selenium/version.txt
+www/data/selenium/xmlextras.js
+www/data/selenium/xpath.js
+www/data/selenium/doc/images/Adjacent.png
+www/data/selenium/doc/images/Embedded.png
+www/data/selenium/doc/images/SmallAdjacent.png
+www/data/selenium/doc/images/SmallEmbedded.png
+www/data/selenium/doc/images/SmallStandalone.png
+www/data/selenium/doc/images/Standalone.png
+www/data/selenium/doc/images/localhostAut.png
+www/data/selenium/doc/images/localhostDriver.png
+www/data/selenium/doc/images/localhostSelenium.png
+www/data/selenium/doc/images/stockmeister.png
+www/data/selenium/doc/images/tested-with-selenium.png
+www/data/selenium/doc/FAQ.html
+www/data/selenium/doc/contact.html
+www/data/selenium/doc/developingdrivers.html
+www/data/selenium/doc/driven.html
+www/data/selenium/doc/home-page.html
+www/data/selenium/doc/index.html
+www/data/selenium/doc/jsrmi.html
+www/data/selenium/doc/release-notes.html
+www/data/selenium/doc/seleniumReference.html
+www/data/selenium/doc/testrunner.html
+www/data/selenium/doc/usage.html
+@dirrm www/data/selenium/doc/images
+@dirrm www/data/selenium/doc
+@dirrm www/data/selenium/tests/tableparser
+@dirrm www/data/selenium/tests/html
+@dirrm www/data/selenium/tests/events
+@dirrm www/data/selenium/tests/browserbot
+@dirrm www/data/selenium/tests
+@dirrm www/data/selenium/jsunit/tests/data
+@dirrm www/data/selenium/jsunit/tests
+@dirrm www/data/selenium/jsunit/licenses
+@dirrm www/data/selenium/jsunit/java/src
+@dirrm www/data/selenium/jsunit/java/lib
+@dirrm www/data/selenium/jsunit/java/bin
+@dirrm www/data/selenium/jsunit/java
+@dirrm www/data/selenium/jsunit/intellij
+@dirrm www/data/selenium/jsunit/images
+@dirrm www/data/selenium/jsunit/css
+@dirrm www/data/selenium/jsunit/app/css
+@dirrm www/data/selenium/jsunit/app
+@dirrm www/data/selenium/jsunit
+@dirrm www/data/selenium/jsmock
+@dirrm www/data/selenium/html-xpath
+@dirrm www/data/selenium/dom-styles
+@dirrm www/data/selenium/dom-images
+@dirrm www/data/selenium/devtests/meta
+@dirrm www/data/selenium/devtests
+@dirrm www/data/selenium