aboutsummaryrefslogtreecommitdiff
path: root/www/serendipity/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2005-12-14 17:09:40 +0000
committerAaron Dalton <aaron@FreeBSD.org>2005-12-14 17:09:40 +0000
commit8d65d13b1437c491763ca3d46f80fd72d33d8f5a (patch)
treec96d817a9b0db1ccd38649e737cc4467def90f46 /www/serendipity/Makefile
parentfc676b7e9eaf6e73ff3f74084f8e4c8f56eab102 (diff)
downloadports-8d65d13b1437c491763ca3d46f80fd72d33d8f5a.tar.gz
ports-8d65d13b1437c491763ca3d46f80fd72d33d8f5a.zip
Notes
Diffstat (limited to 'www/serendipity/Makefile')
-rw-r--r--www/serendipity/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/www/serendipity/Makefile b/www/serendipity/Makefile
new file mode 100644
index 000000000000..b1e5b79ea5ef
--- /dev/null
+++ b/www/serendipity/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: serendipity
+# Date created: 2005-DEC-13
+# Whom: babak@farrokhi.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= serendipity
+PORTVERSION= 0.9.1
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= php-blog
+
+MAINTAINER= babak@farrokhi.net
+COMMENT= PHP based weblog software
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= YES
+SERENDIPITY?= www/${PORTNAME}
+PLIST_SUB+= SERENDIPITY=${SERENDIPITY}
+USE_PHP= session pcre gd openssl mbstring iconv zlib
+SUB_LIST+= SERENDIPITY=${SERENDIPITY}
+SUB_FILES= pkg-message
+
+OPTIONS= MYSQL "Use MySQL backend" on \
+ PGSQL "Use PostgreSQL backend" off \
+ SQLITE "Use SQLite backend (PHP5)" off \
+ MAGICK "Use ImageMagick Library" on
+
+PORT_DBDIR?= /var/db/ports
+LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
+OPTIONSFILE?= ${PORT_DBDIR}/${LATEST_LINK}/options
+
+.if exists(${OPTIONSFILE})
+.include "${OPTIONSFILE}"
+.endif
+
+.if !defined(WITHOUT_MYSQL)
+USE_PHP+= mysql
+. endif
+
+.if defined(WITH_PGSQL)
+USE_PHP+= pgsql
+.endif
+
+.if defined(WITH_SQLITE)
+USE_PHP+= sqlite
+.endif
+
+.if !defined(WITHOUT_MAGICK)
+RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
+.endif
+
+do-install:
+ @-${MKDIR} ${PREFIX}/${SERENDIPITY}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${SERENDIPITY}
+ @(cd ${WRKSRC} && ${CP} -R * ${PREFIX}/${SERENDIPITY}/ )
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>