aboutsummaryrefslogtreecommitdiff
path: root/www/shellinabox
diff options
context:
space:
mode:
authorEd Schouten <ed@FreeBSD.org>2010-08-16 00:04:03 +0000
committerEd Schouten <ed@FreeBSD.org>2010-08-16 00:04:03 +0000
commit1b31d1c15e6bb73651d2acc3aec6aaf249307ad9 (patch)
tree294e8272ec93e6dbfab8634ac2237349ee3743aa /www/shellinabox
parentb4fd4cce65d4ca2cfe3e17f8b073cbd0044f896e (diff)
Notes
Diffstat (limited to 'www/shellinabox')
-rw-r--r--www/shellinabox/Makefile2
-rw-r--r--www/shellinabox/files/shellinaboxd.in11
2 files changed, 10 insertions, 3 deletions
diff --git a/www/shellinabox/Makefile b/www/shellinabox/Makefile
index ba78f432c6b4..f5a6db13f937 100644
--- a/www/shellinabox/Makefile
+++ b/www/shellinabox/Makefile
@@ -7,7 +7,7 @@
PORTNAME= shellinabox
PORTVERSION= 2.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTNAME= ${PORTNAME}-${PORTVERSION}
diff --git a/www/shellinabox/files/shellinaboxd.in b/www/shellinabox/files/shellinaboxd.in
index 8208a2c9e3c1..1614064fad23 100644
--- a/www/shellinabox/files/shellinaboxd.in
+++ b/www/shellinabox/files/shellinaboxd.in
@@ -18,6 +18,8 @@
# shellinaboxd_pidfile="/var/run/shellinabox.pid"
# shellinaboxd_port="4200"
# shellinaboxd_certdir="%%PREFIX%%/etc/shellinabox"
+# shellinaboxd_certfile=""
+# Example: shellinaboxd_certfile="/your/cert.pem"
# shellinaboxd_flags=""
shellinaboxd_setfib() {
@@ -49,8 +51,13 @@ shellinaboxd_certdir=${shellinaboxd_certdir:-"%%PREFIX%%/etc/shellinabox"}
pidfile=${shellinaboxd_pidfile:-"/var/run/shellinaboxd.pid"}
-required_dirs="${shellinaboxd_certdir}"
+command_args="--group=shellinabox --user=shellinabox --port=${shellinaboxd_port} --background=${pidfile}"
-command_args="--group=shellinabox --user=shellinabox --port=${shellinaboxd_port} --cert=${shellinaboxd_certdir} --background=${pidfile}"
+if [ "${shellinaboxd_certfile}" = "" ]; then
+ required_dirs="${shellinaboxd_certdir}"
+ command_args="$command_args --cert=${shellinaboxd_certdir}"
+else
+ command_args="$command_args --cert-fd=3 3< ${shellinaboxd_certfile}"
+fi
run_rc_command "$1"