aboutsummaryrefslogtreecommitdiff
path: root/www/sit
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-07 16:53:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-07 16:53:45 +0000
commitb7df0651651ef059fd4db24d7b77113e72ad6c15 (patch)
treee492c56fa7379da1ca224d6c3b1e9a31bdf1f7d9 /www/sit
parentf391ca611e4a642fc3b0e7df30f4a60b63f60b71 (diff)
downloadports-b7df0651651ef059fd4db24d7b77113e72ad6c15.tar.gz
ports-b7df0651651ef059fd4db24d7b77113e72ad6c15.zip
Notes
Diffstat (limited to 'www/sit')
-rw-r--r--www/sit/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/www/sit/Makefile b/www/sit/Makefile
index 0baf4dc625c4..c21fbc1bc049 100644
--- a/www/sit/Makefile
+++ b/www/sit/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sit
-# Date created: Wed Oct 7, 2010
-# Whom: Carsten Jensen <carsten@sitracker.org>
-#
+# Created by: Carsten Jensen <carsten@sitracker.org>
# $FreeBSD$
-#
PORTNAME= sit
PORTVERSION= 3.67
@@ -24,21 +20,22 @@ WRKSRC= ${WRKDIR}/sit-${PORTVERSION}
SUB_FILES= pkg-message
-OPTIONS= IMAP "If you want email to work" on \
- MBSTRING "If you want to use the inbound email feature" on \
- LDAP "If you want to use LDAP auth" off
+OPTIONS_DEFINE= IMAP MBSTRING LDAP
+OPTIONS_DEFAULT= IMAP MBSTRING
+IMAP_DESC= Email Support
+MBSTRING_DESC= Inbound email feature
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_IMAP)
+.if ${PORT_OPTIONS:MIMAP}
USE_PHP+= imap
.endif
-.if defined(WITH_MBSTRING)
+.if ${PORT_OPTIONS:MMBSTRING}
USE_PHP+= mbstring
.endif
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_PHP+= ldap
.endif
@@ -56,4 +53,4 @@ post-install:
${CP} -p ${WWWDIR}/config.inc.php ${WWWDIR}/config.inc.php.bak ; \
fi
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>