aboutsummaryrefslogtreecommitdiff
path: root/www/sitecopy/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2010-08-01 19:32:14 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2010-08-01 19:32:14 +0000
commit8cf19558898f4fc09b2e131459d330560a82e91b (patch)
treeab9a51de316f3067fe2ac271bf0006cb0244ee35 /www/sitecopy/Makefile
parent6af93d50fca89210b9ca5d4824bc3aa76fe99e19 (diff)
Notes
Diffstat (limited to 'www/sitecopy/Makefile')
-rw-r--r--www/sitecopy/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/www/sitecopy/Makefile b/www/sitecopy/Makefile
index 08cc3899ef80..e3d36bd26bf0 100644
--- a/www/sitecopy/Makefile
+++ b/www/sitecopy/Makefile
@@ -14,18 +14,27 @@ MASTER_SITES= http://www.manyfish.co.uk/${PORTNAME}/ \
MASTER_SITE_SUBDIR= distfiles
MAINTAINER= olgeni@FreeBSD.org
-COMMENT= Maintains remote websites, uses FTP or WebDAV to sync up with local copy
+COMMENT= Maintains remote websites, uses FTP or WebDAV to sync up w/ local copy
LIB_DEPENDS= neon.27:${PORTSDIR}/www/neon29
GNU_CONFIGURE= yes
CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lintl"
+ LIBS="${LIBS}"
+LIBS= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-neon --with-libxml2
-USE_GETTEXT= yes
USE_GNOME= libxml2
USE_GMAKE= yes
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+LIBS+= -lintl
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
.ifndef WITHOUT_SSL
USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-ssl