aboutsummaryrefslogtreecommitdiff
path: root/www/smarty/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-08-10 16:01:10 +0000
committerPatrick Li <pat@FreeBSD.org>2002-08-10 16:01:10 +0000
commitf473717b4c20c256394a4d711ba305a0efd491c9 (patch)
tree2c7aabff22f452207056e8b811f1936264246d2f /www/smarty/Makefile
parent8dce0050c6e57a81567d787f56d8921d7663650d (diff)
downloadports-f473717b4c20c256394a4d711ba305a0efd491c9.tar.gz
ports-f473717b4c20c256394a4d711ba305a0efd491c9.zip
Notes
Diffstat (limited to 'www/smarty/Makefile')
-rw-r--r--www/smarty/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/www/smarty/Makefile b/www/smarty/Makefile
index d67a328d679f..5f6c6b70cd0b 100644
--- a/www/smarty/Makefile
+++ b/www/smarty/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= smarty
-PORTVERSION= 2.2.0
+PORTVERSION= 2.3.0
CATEGORIES= www
MASTER_SITES= http://smarty.php.net/distributions/ \
http://smarty.php.net/distributions/manual/en/:manual
@@ -28,6 +28,8 @@ MSG_SRC=${FILESDIR}/pkg-message
MSG_SUB= DATADIR=${DATADIR} LOCALBASE=${LOCALBASE}
+CPIO?= /usr/bin/cpio
+
do-install:
@${MKDIR} ${DATADIR}
.for f in Config_File.class.php Smarty.class.php Smarty_Compiler.class.php debug.tpl
@@ -41,7 +43,7 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
.endfor
@${MKDIR} ${DOCSDIR}/manual
- @${INSTALL_DATA} ${WRKDIR}/manual/* ${DOCSDIR}/manual
+ @cd ${WRKDIR}/manual && ${FIND} . | ${CPIO} --quiet -dumpR ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}/manual
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/index.php ${EXAMPLESDIR}
.for f in configs templates templates_c cache