aboutsummaryrefslogtreecommitdiff
path: root/www/smarty3
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2012-09-28 17:22:32 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2012-09-28 17:22:32 +0000
commitd30008c3a372b1278915e9a27c2952826e6cc3d7 (patch)
tree6e359e515ec88e6c6d0102318bbcd9b96474706f /www/smarty3
parent23f2ac58349bff6c7d464075f088306a435b8d6d (diff)
downloadports-d30008c3a372b1278915e9a27c2952826e6cc3d7.tar.gz
ports-d30008c3a372b1278915e9a27c2952826e6cc3d7.zip
Notes
Diffstat (limited to 'www/smarty3')
-rw-r--r--www/smarty3/Makefile35
-rw-r--r--www/smarty3/distinfo2
-rw-r--r--www/smarty3/files/pkg-message.in4
-rw-r--r--www/smarty3/pkg-descr11
-rw-r--r--www/smarty3/pkg-plist123
5 files changed, 175 insertions, 0 deletions
diff --git a/www/smarty3/Makefile b/www/smarty3/Makefile
new file mode 100644
index 000000000000..99982808f155
--- /dev/null
+++ b/www/smarty3/Makefile
@@ -0,0 +1,35 @@
+# Created by: Michael Fausten <ports@michael-fausten.de>
+# $FreeBSD$
+
+PORTNAME= smarty3
+PORTVERSION= 3.1.12
+CATEGORIES= www
+MASTER_SITES= http://www.smarty.net/files/
+DISTNAME= Smarty-${PORTVERSION}
+
+MAINTAINER= ports@michael-fausten.de
+COMMENT= The PHP compiling template engine
+
+WRKSRC= ${WRKDIR}/Smarty-${PORTVERSION}
+
+NO_BUILD= yes
+USE_PHP= pcre
+WANT_PHP_WEB= yes
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+
+do-install:
+ @${MKDIR} ${DATADIR}
+.for f in Smarty.class.php SmartyBC.class.php debug.tpl
+ @${INSTALL_DATA} ${WRKSRC}/libs/$f ${DATADIR}
+.endfor
+ @${MKDIR} ${DATADIR}/plugins
+ @${INSTALL_DATA} ${WRKSRC}/libs/plugins/* ${DATADIR}/plugins
+ @${MKDIR} ${DATADIR}/sysplugins
+ @${INSTALL_DATA} ${WRKSRC}/libs/sysplugins/* ${DATADIR}/sysplugins
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/smarty3/distinfo b/www/smarty3/distinfo
new file mode 100644
index 000000000000..9257bbb753a5
--- /dev/null
+++ b/www/smarty3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Smarty-3.1.12.tar.gz) = af6a944823ce0ad24792f2adf19d651890dce276469be940a63452b024400c36
+SIZE (Smarty-3.1.12.tar.gz) = 203062
diff --git a/www/smarty3/files/pkg-message.in b/www/smarty3/files/pkg-message.in
new file mode 100644
index 000000000000..b9d8ebd9a029
--- /dev/null
+++ b/www/smarty3/files/pkg-message.in
@@ -0,0 +1,4 @@
+You need to adjust php's include_path to contain `%%DATADIR%%'!
+For example, insert
+ include_path = ".:%%DATADIR%%"
+into `%%LOCALBASE%%/etc/php.ini'.
diff --git a/www/smarty3/pkg-descr b/www/smarty3/pkg-descr
new file mode 100644
index 000000000000..b582ce4ed4d6
--- /dev/null
+++ b/www/smarty3/pkg-descr
@@ -0,0 +1,11 @@
+Smarty is a template engine for PHP. Many other template engines for PHP
+provide basic variable substitution and dynamic block functionality.
+Smarty takes a step further to be a "smart" template engine, adding
+features such as configuration files, template functions, and variable
+modifiers, and making all of this functionality as easy as possible to
+use for both programmers and template designers. Smarty also converts
+the templates into PHP scripts, eliminating the need to parse the
+templates on every invocation. This makes Smarty extremely scalable and
+managable for large application needs.
+
+WWW: http://www.smarty.net/
diff --git a/www/smarty3/pkg-plist b/www/smarty3/pkg-plist
new file mode 100644
index 000000000000..7f93a491360f
--- /dev/null
+++ b/www/smarty3/pkg-plist
@@ -0,0 +1,123 @@
+%%DATADIR%%/Smarty.class.php
+%%DATADIR%%/SmartyBC.class.php
+%%DATADIR%%/debug.tpl
+%%DATADIR%%/plugins/block.textformat.php
+%%DATADIR%%/plugins/function.counter.php
+%%DATADIR%%/plugins/function.cycle.php
+%%DATADIR%%/plugins/function.fetch.php
+%%DATADIR%%/plugins/function.html_checkboxes.php
+%%DATADIR%%/plugins/function.html_image.php
+%%DATADIR%%/plugins/function.html_options.php
+%%DATADIR%%/plugins/function.html_radios.php
+%%DATADIR%%/plugins/function.html_select_date.php
+%%DATADIR%%/plugins/function.html_select_time.php
+%%DATADIR%%/plugins/function.html_table.php
+%%DATADIR%%/plugins/function.mailto.php
+%%DATADIR%%/plugins/function.math.php
+%%DATADIR%%/plugins/modifier.capitalize.php
+%%DATADIR%%/plugins/modifier.date_format.php
+%%DATADIR%%/plugins/modifier.debug_print_var.php
+%%DATADIR%%/plugins/modifier.escape.php
+%%DATADIR%%/plugins/modifier.regex_replace.php
+%%DATADIR%%/plugins/modifier.replace.php
+%%DATADIR%%/plugins/modifier.spacify.php
+%%DATADIR%%/plugins/modifier.truncate.php
+%%DATADIR%%/plugins/modifiercompiler.cat.php
+%%DATADIR%%/plugins/modifiercompiler.count_characters.php
+%%DATADIR%%/plugins/modifiercompiler.count_paragraphs.php
+%%DATADIR%%/plugins/modifiercompiler.count_sentences.php
+%%DATADIR%%/plugins/modifiercompiler.count_words.php
+%%DATADIR%%/plugins/modifiercompiler.default.php
+%%DATADIR%%/plugins/modifiercompiler.escape.php
+%%DATADIR%%/plugins/modifiercompiler.from_charset.php
+%%DATADIR%%/plugins/modifiercompiler.indent.php
+%%DATADIR%%/plugins/modifiercompiler.lower.php
+%%DATADIR%%/plugins/modifiercompiler.noprint.php
+%%DATADIR%%/plugins/modifiercompiler.string_format.php
+%%DATADIR%%/plugins/modifiercompiler.strip.php
+%%DATADIR%%/plugins/modifiercompiler.strip_tags.php
+%%DATADIR%%/plugins/modifiercompiler.to_charset.php
+%%DATADIR%%/plugins/modifiercompiler.unescape.php
+%%DATADIR%%/plugins/modifiercompiler.upper.php
+%%DATADIR%%/plugins/modifiercompiler.wordwrap.php
+%%DATADIR%%/plugins/outputfilter.trimwhitespace.php
+%%DATADIR%%/plugins/shared.escape_special_chars.php
+%%DATADIR%%/plugins/shared.literal_compiler_param.php
+%%DATADIR%%/plugins/shared.make_timestamp.php
+%%DATADIR%%/plugins/shared.mb_str_replace.php
+%%DATADIR%%/plugins/shared.mb_unicode.php
+%%DATADIR%%/plugins/shared.mb_wordwrap.php
+%%DATADIR%%/plugins/variablefilter.htmlspecialchars.php
+%%DATADIR%%/sysplugins/smarty_cacheresource.php
+%%DATADIR%%/sysplugins/smarty_cacheresource_custom.php
+%%DATADIR%%/sysplugins/smarty_cacheresource_keyvaluestore.php
+%%DATADIR%%/sysplugins/smarty_config_source.php
+%%DATADIR%%/sysplugins/smarty_internal_cacheresource_file.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_append.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_assign.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_block.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_break.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_call.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_capture.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_config_load.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_continue.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_debug.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_eval.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_extends.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_for.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_foreach.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_function.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_if.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_include.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_include_php.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_insert.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_ldelim.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_nocache.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_block_plugin.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_function_plugin.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_modifier.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_object_block_function.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_object_function.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_print_expression.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_registered_block.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_registered_function.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_private_special_variable.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_rdelim.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_section.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_setfilter.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_while.php
+%%DATADIR%%/sysplugins/smarty_internal_compilebase.php
+%%DATADIR%%/sysplugins/smarty_internal_config.php
+%%DATADIR%%/sysplugins/smarty_internal_config_file_compiler.php
+%%DATADIR%%/sysplugins/smarty_internal_configfilelexer.php
+%%DATADIR%%/sysplugins/smarty_internal_configfileparser.php
+%%DATADIR%%/sysplugins/smarty_internal_data.php
+%%DATADIR%%/sysplugins/smarty_internal_debug.php
+%%DATADIR%%/sysplugins/smarty_internal_filter_handler.php
+%%DATADIR%%/sysplugins/smarty_internal_function_call_handler.php
+%%DATADIR%%/sysplugins/smarty_internal_get_include_path.php
+%%DATADIR%%/sysplugins/smarty_internal_nocache_insert.php
+%%DATADIR%%/sysplugins/smarty_internal_parsetree.php
+%%DATADIR%%/sysplugins/smarty_internal_resource_eval.php
+%%DATADIR%%/sysplugins/smarty_internal_resource_extends.php
+%%DATADIR%%/sysplugins/smarty_internal_resource_file.php
+%%DATADIR%%/sysplugins/smarty_internal_resource_php.php
+%%DATADIR%%/sysplugins/smarty_internal_resource_registered.php
+%%DATADIR%%/sysplugins/smarty_internal_resource_stream.php
+%%DATADIR%%/sysplugins/smarty_internal_resource_string.php
+%%DATADIR%%/sysplugins/smarty_internal_smartytemplatecompiler.php
+%%DATADIR%%/sysplugins/smarty_internal_template.php
+%%DATADIR%%/sysplugins/smarty_internal_templatebase.php
+%%DATADIR%%/sysplugins/smarty_internal_templatecompilerbase.php
+%%DATADIR%%/sysplugins/smarty_internal_templatelexer.php
+%%DATADIR%%/sysplugins/smarty_internal_templateparser.php
+%%DATADIR%%/sysplugins/smarty_internal_utility.php
+%%DATADIR%%/sysplugins/smarty_internal_write_file.php
+%%DATADIR%%/sysplugins/smarty_resource.php
+%%DATADIR%%/sysplugins/smarty_resource_custom.php
+%%DATADIR%%/sysplugins/smarty_resource_recompiled.php
+%%DATADIR%%/sysplugins/smarty_resource_uncompiled.php
+%%DATADIR%%/sysplugins/smarty_security.php
+@dirrm %%DATADIR%%/sysplugins
+@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%