aboutsummaryrefslogtreecommitdiff
path: root/www/smarty
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-08-10 16:01:10 +0000
committerPatrick Li <pat@FreeBSD.org>2002-08-10 16:01:10 +0000
commitf473717b4c20c256394a4d711ba305a0efd491c9 (patch)
tree2c7aabff22f452207056e8b811f1936264246d2f /www/smarty
parent8dce0050c6e57a81567d787f56d8921d7663650d (diff)
downloadports-f473717b4c20c256394a4d711ba305a0efd491c9.tar.gz
ports-f473717b4c20c256394a4d711ba305a0efd491c9.zip
Notes
Diffstat (limited to 'www/smarty')
-rw-r--r--www/smarty/Makefile6
-rw-r--r--www/smarty/distinfo4
-rw-r--r--www/smarty/pkg-plist72
3 files changed, 51 insertions, 31 deletions
diff --git a/www/smarty/Makefile b/www/smarty/Makefile
index d67a328d679f..5f6c6b70cd0b 100644
--- a/www/smarty/Makefile
+++ b/www/smarty/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= smarty
-PORTVERSION= 2.2.0
+PORTVERSION= 2.3.0
CATEGORIES= www
MASTER_SITES= http://smarty.php.net/distributions/ \
http://smarty.php.net/distributions/manual/en/:manual
@@ -28,6 +28,8 @@ MSG_SRC=${FILESDIR}/pkg-message
MSG_SUB= DATADIR=${DATADIR} LOCALBASE=${LOCALBASE}
+CPIO?= /usr/bin/cpio
+
do-install:
@${MKDIR} ${DATADIR}
.for f in Config_File.class.php Smarty.class.php Smarty_Compiler.class.php debug.tpl
@@ -41,7 +43,7 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
.endfor
@${MKDIR} ${DOCSDIR}/manual
- @${INSTALL_DATA} ${WRKDIR}/manual/* ${DOCSDIR}/manual
+ @cd ${WRKDIR}/manual && ${FIND} . | ${CPIO} --quiet -dumpR ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}/manual
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/index.php ${EXAMPLESDIR}
.for f in configs templates templates_c cache
diff --git a/www/smarty/distinfo b/www/smarty/distinfo
index bfab1f465394..141a843aed36 100644
--- a/www/smarty/distinfo
+++ b/www/smarty/distinfo
@@ -1,2 +1,2 @@
-MD5 (Smarty-2.2.0.tar.gz) = 610758764319e52e4184ce2c0e3e2e35
-MD5 (Smarty-2.2.0-docs.tar.gz) = 5f56ae1f361ea56143b67f26a35626b9
+MD5 (Smarty-2.3.0.tar.gz) = 1d5e0d4c1678a8223f07cf977a747b97
+MD5 (Smarty-2.3.0-docs.tar.gz) = 542f1eb9d13d1f2b5af6f68109476b8d
diff --git a/www/smarty/pkg-plist b/www/smarty/pkg-plist
index 4ddb5d945105..1f7077120808 100644
--- a/www/smarty/pkg-plist
+++ b/www/smarty/pkg-plist
@@ -8,6 +8,8 @@
%%PORTDOCS%%share/doc/smarty/manual/advanced.features.html
%%PORTDOCS%%share/doc/smarty/manual/advanced.features.outputfilters.html
%%PORTDOCS%%share/doc/smarty/manual/advanced.features.postfilters.html
+%%PORTDOCS%%share/doc/smarty/manual/api.append.by.ref.html
+%%PORTDOCS%%share/doc/smarty/manual/api.assign.by.ref.html
%%PORTDOCS%%share/doc/smarty/manual/api.assign.html
%%PORTDOCS%%share/doc/smarty/manual/api.clear.all.assign.html
%%PORTDOCS%%share/doc/smarty/manual/api.clear.all.cache.html
@@ -46,7 +48,6 @@
%%PORTDOCS%%share/doc/smarty/manual/caching.multiple.caches.html
%%PORTDOCS%%share/doc/smarty/manual/chapter.debugging.console.html
%%PORTDOCS%%share/doc/smarty/manual/config.files.html
-%%PORTDOCS%%share/doc/smarty/manual/date.format.html
%%PORTDOCS%%share/doc/smarty/manual/default.template.handler.function.html
%%PORTDOCS%%share/doc/smarty/manual/getting.started.html
%%PORTDOCS%%share/doc/smarty/manual/index.html
@@ -61,6 +62,7 @@
%%PORTDOCS%%share/doc/smarty/manual/language.function.config.load.html
%%PORTDOCS%%share/doc/smarty/manual/language.function.counter.html
%%PORTDOCS%%share/doc/smarty/manual/language.function.cycle.html
+%%PORTDOCS%%share/doc/smarty/manual/language.function.debug.html
%%PORTDOCS%%share/doc/smarty/manual/language.function.eval.html
%%PORTDOCS%%share/doc/smarty/manual/language.function.fetch.html
%%PORTDOCS%%share/doc/smarty/manual/language.function.foreach.html
@@ -79,6 +81,23 @@
%%PORTDOCS%%share/doc/smarty/manual/language.function.popup.init.html
%%PORTDOCS%%share/doc/smarty/manual/language.function.section.html
%%PORTDOCS%%share/doc/smarty/manual/language.function.strip.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.count.characters.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.count.paragraphs.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.count.sentences.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.count.words.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.date.format.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.default.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.escape.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.indent.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.lower.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.regex.replace.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.replace.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.spacify.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.string.format.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.strip.tags.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.truncate.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.upper.html
+%%PORTDOCS%%share/doc/smarty/manual/language.modifier.wordwrap.html
%%PORTDOCS%%share/doc/smarty/manual/language.modifiers.html
%%PORTDOCS%%share/doc/smarty/manual/language.syntax.attributes.html
%%PORTDOCS%%share/doc/smarty/manual/language.syntax.functions.html
@@ -105,10 +124,32 @@
%%PORTDOCS%%share/doc/smarty/manual/plugins.writing.html
%%PORTDOCS%%share/doc/smarty/manual/preface.html
%%PORTDOCS%%share/doc/smarty/manual/resources.html
+%%PORTDOCS%%share/doc/smarty/manual/section.property.first.html
+%%PORTDOCS%%share/doc/smarty/manual/section.property.index.html
+%%PORTDOCS%%share/doc/smarty/manual/section.property.index.next.html
+%%PORTDOCS%%share/doc/smarty/manual/section.property.index.prev.html
+%%PORTDOCS%%share/doc/smarty/manual/section.property.iteration.html
+%%PORTDOCS%%share/doc/smarty/manual/section.property.last.html
+%%PORTDOCS%%share/doc/smarty/manual/section.property.loop.html
+%%PORTDOCS%%share/doc/smarty/manual/section.property.rownum.html
+%%PORTDOCS%%share/doc/smarty/manual/section.property.show.html
+%%PORTDOCS%%share/doc/smarty/manual/section.property.total.html
%%PORTDOCS%%share/doc/smarty/manual/section.template.cache.handler.func.html
%%PORTDOCS%%share/doc/smarty/manual/smarty.constants.html
%%PORTDOCS%%share/doc/smarty/manual/smarty.for.designers.html
%%PORTDOCS%%share/doc/smarty/manual/smarty.for.programmers.html
+%%PORTDOCS%%share/doc/smarty/manual/stylesheet-images/caution.gif
+%%PORTDOCS%%share/doc/smarty/manual/stylesheet-images/home.gif
+%%PORTDOCS%%share/doc/smarty/manual/stylesheet-images/important.gif
+%%PORTDOCS%%share/doc/smarty/manual/stylesheet-images/next.gif
+%%PORTDOCS%%share/doc/smarty/manual/stylesheet-images/note.gif
+%%PORTDOCS%%share/doc/smarty/manual/stylesheet-images/prev.gif
+%%PORTDOCS%%share/doc/smarty/manual/stylesheet-images/tip.gif
+%%PORTDOCS%%share/doc/smarty/manual/stylesheet-images/toc-blank.gif
+%%PORTDOCS%%share/doc/smarty/manual/stylesheet-images/toc-minus.gif
+%%PORTDOCS%%share/doc/smarty/manual/stylesheet-images/toc-plus.gif
+%%PORTDOCS%%share/doc/smarty/manual/stylesheet-images/up.gif
+%%PORTDOCS%%share/doc/smarty/manual/stylesheet-images/warning.gif
%%PORTDOCS%%share/doc/smarty/manual/template.resources.html
%%PORTDOCS%%share/doc/smarty/manual/templates.from.any.dir.html
%%PORTDOCS%%share/doc/smarty/manual/templates.from.elsewhere.html
@@ -135,6 +176,7 @@
%%PORTDOCS%%share/doc/smarty/manual/variable.debug.tpl.html
%%PORTDOCS%%share/doc/smarty/manual/variable.debugging.ctrl.html
%%PORTDOCS%%share/doc/smarty/manual/variable.debugging.html
+%%PORTDOCS%%share/doc/smarty/manual/variable.default.modifiers.html
%%PORTDOCS%%share/doc/smarty/manual/variable.default.template.handler.func.html
%%PORTDOCS%%share/doc/smarty/manual/variable.force.compile.html
%%PORTDOCS%%share/doc/smarty/manual/variable.global.assign.html
@@ -152,32 +194,6 @@
%%PORTDOCS%%share/doc/smarty/manual/variable.undefined.html
%%PORTDOCS%%share/doc/smarty/manual/variable.use.sub.dirs.html
%%PORTDOCS%%share/doc/smarty/manual/what.is.smarty.html
-%%PORTDOCS%%share/doc/smarty/manual/x1066.html
-%%PORTDOCS%%share/doc/smarty/manual/x1075.html
-%%PORTDOCS%%share/doc/smarty/manual/x1081.html
-%%PORTDOCS%%share/doc/smarty/manual/x1087.html
-%%PORTDOCS%%share/doc/smarty/manual/x1094.html
-%%PORTDOCS%%share/doc/smarty/manual/x1100.html
-%%PORTDOCS%%share/doc/smarty/manual/x1106.html
-%%PORTDOCS%%share/doc/smarty/manual/x1112.html
-%%PORTDOCS%%share/doc/smarty/manual/x1118.html
-%%PORTDOCS%%share/doc/smarty/manual/x1126.html
-%%PORTDOCS%%share/doc/smarty/manual/x270.html
-%%PORTDOCS%%share/doc/smarty/manual/x276.html
-%%PORTDOCS%%share/doc/smarty/manual/x282.html
-%%PORTDOCS%%share/doc/smarty/manual/x288.html
-%%PORTDOCS%%share/doc/smarty/manual/x330.html
-%%PORTDOCS%%share/doc/smarty/manual/x358.html
-%%PORTDOCS%%share/doc/smarty/manual/x388.html
-%%PORTDOCS%%share/doc/smarty/manual/x421.html
-%%PORTDOCS%%share/doc/smarty/manual/x427.html
-%%PORTDOCS%%share/doc/smarty/manual/x462.html
-%%PORTDOCS%%share/doc/smarty/manual/x497.html
-%%PORTDOCS%%share/doc/smarty/manual/x525.html
-%%PORTDOCS%%share/doc/smarty/manual/x553.html
-%%PORTDOCS%%share/doc/smarty/manual/x559.html
-%%PORTDOCS%%share/doc/smarty/manual/x598.html
-%%PORTDOCS%%share/doc/smarty/manual/x604.html
%%PORTDOCS%%share/examples/smarty/configs/test.conf
%%PORTDOCS%%share/examples/smarty/index.php
%%PORTDOCS%%share/examples/smarty/templates/footer.tpl
@@ -191,6 +207,7 @@ share/smarty/plugins/function.assign.php
share/smarty/plugins/function.assign_debug_info.php
share/smarty/plugins/function.counter.php
share/smarty/plugins/function.cycle.php
+share/smarty/plugins/function.debug.php
share/smarty/plugins/function.eval.php
share/smarty/plugins/function.fetch.php
share/smarty/plugins/function.html_options.php
@@ -226,5 +243,6 @@ share/smarty/plugins/shared.make_timestamp.php
%%PORTDOCS%%@dirrm share/examples/smarty/configs
%%PORTDOCS%%@dirrm share/examples/smarty/cache
%%PORTDOCS%%@dirrm share/examples/smarty
+%%PORTDOCS%%@dirrm share/doc/smarty/manual/stylesheet-images
%%PORTDOCS%%@dirrm share/doc/smarty/manual
%%PORTDOCS%%@dirrm share/doc/smarty