aboutsummaryrefslogtreecommitdiff
path: root/www/snownews
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2005-04-06 07:10:00 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2005-04-06 07:10:00 +0000
commit907633217b72ad2f494d5bf2445dd2812f627932 (patch)
tree79f04ef047a9ec77a1a1236427adab21909f90f0 /www/snownews
parent0beb95e46dba004098b16209b1591cd3ae8202ca (diff)
downloadports-907633217b72ad2f494d5bf2445dd2812f627932.tar.gz
ports-907633217b72ad2f494d5bf2445dd2812f627932.zip
Notes
Diffstat (limited to 'www/snownews')
-rw-r--r--www/snownews/Makefile20
-rw-r--r--www/snownews/files/patch-platform_settings7
2 files changed, 20 insertions, 7 deletions
diff --git a/www/snownews/Makefile b/www/snownews/Makefile
index ec70636075e9..7ca532082f15 100644
--- a/www/snownews/Makefile
+++ b/www/snownews/Makefile
@@ -8,6 +8,7 @@
PORTNAME= snownews
PORTVERSION= 1.5.6.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://kiza.kcore.de/software/snownews/download/
@@ -18,12 +19,31 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= libxml2
USE_REINPLACE= yes
+HAS_CONFIGURE= yes
+
+.if defined(CHARSET)
+CONFIGURE_ARGS= --charset=${CHARSET}
+.if ${CHARSET} == "UTF-8"
+post-configure:
+ @${REINPLACE_CMD} -e 's|ncursesw|ncurses|g' ${WRKSRC}/platform_settings
+.endif
+.endif
MAN1= snownews.1
MANLANG= "" de nl fr it ru_RU.KOI8-R
+pre-everything::
+ @${ECHO_MSG} " "
+ @${ECHO_MSG} " You can set up CHARSET variable for your localization."
+ @${ECHO_MSG} " Example: make CHARSET=ISO-8859-2"
+ @${ECHO_MSG} " Default is ISO-8859-1."
+ @${ECHO_MSG} " "
+
post-patch:
@${REINPLACE_CMD} -e 's|CFLAGS=|CFLAGS+=|g' ${WRKSRC}/platform_settings
@${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/Makefile
+pre-build:
+ @${REINPLACE_CMD} -e 's|^PREFIX|#PREFIX|' ${WRKSRC}/platform_settings
+
.include <bsd.port.mk>
diff --git a/www/snownews/files/patch-platform_settings b/www/snownews/files/patch-platform_settings
deleted file mode 100644
index 91d69137b0bc..000000000000
--- a/www/snownews/files/patch-platform_settings
+++ /dev/null
@@ -1,7 +0,0 @@
---- platform_settings.orig Thu Dec 9 19:29:08 2004
-+++ platform_settings Wed Jan 26 14:37:44 2005
-@@ -1,3 +1,3 @@
--PREFIX= /usr/local
-+#PREFIX= /usr/local
- CFLAGS= -Wall -Wno-format-y2k -O2 -DLOCALEPATH="\"$(LOCALEPATH)\"" -DOS=\"$(shell uname)\" `xml2-config --cflags` $(EXTRA_CFLAGS) -DSTATIC_CONST_ICONV -I/usr/local/include
- LDFLAGS= -lncurses `xml2-config --libs` $(EXTRA_LDFLAGS) -lintl -liconv