aboutsummaryrefslogtreecommitdiff
path: root/www/squid/Makefile
diff options
context:
space:
mode:
authorSimon L. B. Nielsen <simon@FreeBSD.org>2005-01-12 22:37:29 +0000
committerSimon L. B. Nielsen <simon@FreeBSD.org>2005-01-12 22:37:29 +0000
commit8b446059f52e4d1d549db6bd571b7ef1c6b358f3 (patch)
treeebc9065d87137d840f3b0ffef33f5668caa1f3fc /www/squid/Makefile
parentc3c79898e9aaaa52f7c63a45c4e431c88b97a7a9 (diff)
downloadports-8b446059f52e4d1d549db6bd571b7ef1c6b358f3.tar.gz
ports-8b446059f52e4d1d549db6bd571b7ef1c6b358f3.zip
Notes
Diffstat (limited to 'www/squid/Makefile')
-rw-r--r--www/squid/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 6e8f2fb54dcb..a961d9dd5d62 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -74,7 +74,7 @@
PORTNAME= squid
PORTVERSION= 2.5.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -95,7 +95,11 @@ PATCHFILES= squid-2.5.STABLE7-half_closed_POST.patch \
squid-2.5.STABLE7-dothost.patch \
squid-2.5.STABLE7-httpd_accel_vport.patch \
squid-2.5.STABLE7-cachemgr_vmobjects.patch \
- squid-2.5.STABLE7-empty_acls.patch
+ squid-2.5.STABLE7-empty_acls.patch \
+ squid-2.5.STABLE7-close_other.patch \
+ squid-2.5.STABLE7-fakeauth_auth.patch \
+ squid-2.5.STABLE7-gopher_html_parsing.patch \
+ squid-2.5.STABLE7-wccp_denial_of_service.patch
PATCH_DIST_STRIP= -p1
MAINTAINER= tmseck@netcologne.de
@@ -169,7 +173,7 @@ error_files= ERR_ACCESS_DENIED ERR_CACHE_ACCESS_DENIED \
libexec= cachemgr.cgi digest_pw_auth diskd dnsserver ip_user_check \
squid_ldap_auth squid_ldap_group msnt_auth ncsa_auth ntlm_auth \
pam_auth pinger smb_auth smb_auth.sh squid_unix_group \
- unlinkd wb_auth wb_group wb_ntlmauth wbinfo_group.pl yp_auth
+ unlinkd wb_auth wb_group wb_ntlmauth wbinfo_group.pl
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
--datadir=${PREFIX}/etc/squid \
@@ -181,7 +185,7 @@ CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
# Authentication methods and modules:
-basic_auth= NCSA PAM YP MSNT SMB winbind
+basic_auth= NCSA PAM MSNT SMB winbind
external_acl= ip_user unix_group wbinfo_group winbind_group
MAN8+= pam_auth.8 squid_unix_group.8
.if defined(WITH_SQUID_LDAP_AUTH)
@@ -192,6 +196,10 @@ MAN8+= squid_ldap_auth.8 squid_ldap_group.8
basic_auth+= LDAP
external_acl+= ldap_group
.endif
+.if !defined(NO_NIS)
+basic_auth+= YP
+libexec+= yp_auth
+.endif
CONFIGURE_ARGS+= --enable-auth="basic ntlm digest" \
--enable-basic-auth-helpers="${basic_auth}" \
--enable-digest-auth-helpers="password" \