aboutsummaryrefslogtreecommitdiff
path: root/www/squid25
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-01 14:12:37 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-01 14:12:37 +0000
commit5f969ee8e08405b74c96350a36eeaf390a0356e3 (patch)
treef0daec78dad921a00b3029eed588831716f82ebe /www/squid25
parent3a290d68a81bc1cf682004f5984e199bf5dd4fb6 (diff)
downloadports-5f969ee8e08405b74c96350a36eeaf390a0356e3.tar.gz
ports-5f969ee8e08405b74c96350a36eeaf390a0356e3.zip
Notes
Diffstat (limited to 'www/squid25')
-rw-r--r--www/squid25/Makefile13
-rw-r--r--www/squid25/distinfo8
-rw-r--r--www/squid25/pkg-install9
3 files changed, 26 insertions, 4 deletions
diff --git a/www/squid25/Makefile b/www/squid25/Makefile
index 2bf807a8e303..45eb961ba064 100644
--- a/www/squid25/Makefile
+++ b/www/squid25/Makefile
@@ -29,6 +29,7 @@
PORTNAME= squid
PORTVERSION= 2.5.5
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -42,7 +43,11 @@ DIST_SUBDIR= squid2.5
PATCH_SITES= http://www.squid-cache.org/Versions/v2/2.5/bugs/
PATCHFILES= squid-2.5.STABLE5-ntlm_assert.patch \
- squid-2.5.STABLE5-ldap.patch
+ squid-2.5.STABLE5-ldap.patch \
+ squid-2.5.STABLE5-helper_warning.patch \
+ squid-2.5.STABLE5-vary.patch \
+ squid-2.5.STABLE5-deny_info.patch \
+ squid-2.5.STABLE5-CONNECT_timeout.patch
PATCH_DIST_STRIP= -p1
MAINTAINER= tmseck@netcologne.de
@@ -163,7 +168,7 @@ CONFIGURE_ARGS+= --enable-cache-digests
.if defined(WITHOUT_SQUID_WCCP)
CONFIGURE_ARGS+= --disable-wccp
.endif
-.if defined(WITH_SQUID_UNDERSCORES)
+.if !defined(WITHOUT_SQUID_UNDERSCORES)
CONFIGURE_ARGS+= --enable-underscores
.endif
.if defined(WITHOUT_SQUID_CHECK_HOSTNAME)
@@ -188,7 +193,7 @@ CONFIGURE_ARGS+= --enable-arp-acl
# on 5.[0-2] systems instead, go on, I will integrate your patch.
CONFIGURE_ARGS+= --enable-pf-transparent
.else
-.error WITH_SQUID_PF only works on systems where pf is part of the base system.
+IGNORE= WITH_SQUID_PF only works on systems where pf is part of the base system.
.endif
.endif
.if defined(WITH_SQUID_FOLLOW_XFF)
@@ -306,7 +311,7 @@ changeuser:
${ECHO_CMD} "this target!"
exit 1
.endif
- @if [ `id -u` -ne 0 ]; \
+ @if [ `${ID} -u` -ne 0 ]; \
then ${ECHO_CMD} "Sorry, you must be root to use this target."; exit 1; fi; \
current_uid=`id -u ${SQUID_UID}`; \
current_gid=`pw groupshow ${SQUID_GID}|cut -f 3 -d :`; \
diff --git a/www/squid25/distinfo b/www/squid25/distinfo
index 4fd6ad221560..ccb086c6897f 100644
--- a/www/squid25/distinfo
+++ b/www/squid25/distinfo
@@ -4,3 +4,11 @@ MD5 (squid2.5/squid-2.5.STABLE5-ntlm_assert.patch) = 1bb2a8455a1e988c52b2ca3cf3f
SIZE (squid2.5/squid-2.5.STABLE5-ntlm_assert.patch) = 545
MD5 (squid2.5/squid-2.5.STABLE5-ldap.patch) = 81bdcaf96390eab1655fd8d65cf607ed
SIZE (squid2.5/squid-2.5.STABLE5-ldap.patch) = 6245
+MD5 (squid2.5/squid-2.5.STABLE5-helper_warning.patch) = f384daa03a07a4c99e84c922d9860524
+SIZE (squid2.5/squid-2.5.STABLE5-helper_warning.patch) = 3302
+MD5 (squid2.5/squid-2.5.STABLE5-vary.patch) = fd5f98f7eb8673df7e496ee72a6474b8
+SIZE (squid2.5/squid-2.5.STABLE5-vary.patch) = 626
+MD5 (squid2.5/squid-2.5.STABLE5-deny_info.patch) = bf73b60d02964ad9e410565389e73b06
+SIZE (squid2.5/squid-2.5.STABLE5-deny_info.patch) = 1282
+MD5 (squid2.5/squid-2.5.STABLE5-CONNECT_timeout.patch) = b6aa700c75a061dc9658d8dc198a9183
+SIZE (squid2.5/squid-2.5.STABLE5-CONNECT_timeout.patch) = 2531
diff --git a/www/squid25/pkg-install b/www/squid25/pkg-install
index 35a034c778ce..e22d6b02f09f 100644
--- a/www/squid25/pkg-install
+++ b/www/squid25/pkg-install
@@ -148,6 +148,15 @@ POST-INSTALL)
echo " Please check your squid.conf and update it if necessary."
tput me
echo ""
+ if [ -f /etc/rc.subr ]; then
+ echo " Please note that ${PKG_PREFIX}/etc/rc.d/squid.sh"
+ echo " will not start squid automatically on this system."
+ echo " You need to set squid_enable=yes in either"
+ echo " /etc/rc.conf, /etc/rc.conf.local or /etc/rc.conf.d/squid"
+ echo " See ${PKG_PREFIX}/etc/rc.d/squid.sh for more"
+ echo " configuration options."
+ echo ""
+ fi
;;
*)
exit 64