aboutsummaryrefslogtreecommitdiff
path: root/www/squid25
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-14 18:33:12 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-14 18:33:12 +0000
commit3868dabf56549499afd40c1894cfcf5a898f4af5 (patch)
treef6cf3a4bc4e470de398bc903c62cab72e2596fce /www/squid25
parent9a71e5216302eb3864eacf14c0195bbcb0701de1 (diff)
downloadports-3868dabf56549499afd40c1894cfcf5a898f4af5.tar.gz
ports-3868dabf56549499afd40c1894cfcf5a898f4af5.zip
Notes
Diffstat (limited to 'www/squid25')
-rw-r--r--www/squid25/Makefile99
-rw-r--r--www/squid25/distinfo56
2 files changed, 42 insertions, 113 deletions
diff --git a/www/squid25/Makefile b/www/squid25/Makefile
index a168b219b975..da0c2d9d421d 100644
--- a/www/squid25/Makefile
+++ b/www/squid25/Makefile
@@ -25,11 +25,43 @@
# If you define SQUID_LANGUAGES, select which language should be the default
# (default: English)
# SQUID_CONFIGURE_ARGS
-# Additional configuration options, see below for a list
+# Additional configuration options.
+# To enable them, use an assignment like
+# SQUID_CONFIGURE_ARGS="--enable-dlmalloc --enable-truncate"
+# Below most of the additional configuration options are listed,
+# please see the configure script in the squid source distribution for a
+# complete list. Note that you probably do not need to worry about them.
+#
+# --enable-dlmalloc
+# Compile and use the malloc package from Doug Lea
+# --enable-gnuregex
+# Compile and use the supplied GNUregex routines instead of BSD regex.
+# --enable-xmalloc-statistics
+# Show malloc statistics in status page
+# --enable-time-hack
+# Optimize time updates to one per second rather than calling gettimeofday()
+# --enable-cachemgr-hostname=some.hostname
+# Set an explicit hostname in cachemgr.cgi
+# --enable-truncate
+# Use truncate() rather than unlink()
+# --disable-unlinkd
+# Do not use "unlinkd"
+# --with-aufs-threads=N_THREADS
+# Tune the number of worker threads for the aufs object
+# --with-coss-membuf-size
+# COSS membuf size (default: 1048576 bytes)
+#
+# This option does not work on FreeBSD at the moment:
+#
+# --enable-ipf-transparent
+# Enable Transparent Proxy support for IP-Filter systems (incl 3.0)
+# (IPFilter headers are not currently installed to the base system,
+# PRs ports/60700 and misc/44148 describe the problem; see
+# http://www.squid-cache.org/Doc/FAQ/FAQ-17.html for information
+# about how to do transparent proxying with ipfw)
PORTNAME= squid
-PORTVERSION= 2.5.5
-PORTREVISION= 12
+PORTVERSION= 2.5.6
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -38,35 +70,11 @@ MASTER_SITES= \
ftp://ftp.leo.org/pub/comp/general/infosys/www/servers/squid/%SUBDIR%/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/www/squid/&,}
MASTER_SITE_SUBDIR= squid-2/STABLE
-DISTNAME= squid-2.5.STABLE5
+DISTNAME= squid-2.5.STABLE6
DIST_SUBDIR= squid2.5
PATCH_SITES= http://www.squid-cache.org/Versions/v2/2.5/bugs/
-PATCHFILES= squid-2.5.STABLE5-ntlm_assert.patch \
- squid-2.5.STABLE5-ldap.patch \
- squid-2.5.STABLE5-helper_warning.patch \
- squid-2.5.STABLE5-vary.patch \
- squid-2.5.STABLE5-deny_info.patch \
- squid-2.5.STABLE5-CONNECT_timeout.patch \
- squid-2.5.STABLE5-cache_swap_log.patch \
- squid-2.5.STABLE5-ntlm_warning.patch \
- squid-2.5.STABLE5-rfc1035NameUnpack.patch \
- squid-2.5.STABLE5-digest_blank.patch \
- squid-2.5.STABLE5-post_assert.patch \
- squid-2.5.STABLE5-digest_ERR.patch \
- squid-2.5.STABLE5-turkish_ERR_DNS_FAIL.patch \
- squid-2.5.STABLE5-vary_negatively.patch \
- squid-2.5.STABLE5-range_offset_limit.patch \
- squid-2.5.STABLE5-large_cache_mem.patch \
- squid-2.5.STABLE5-least-load.patch \
- squid-2.5.STABLE5-cacheCurrentUnlinkRequests.patch \
- squid-2.5.STABLE5-debug_client_ip.patch \
- squid-2.5.STABLE5-ftp_html_doctype.patch \
- squid-2.5.STABLE5-dns_localhost.patch \
- squid-2.5.STABLE5-msnt_auth_doc.patch \
- squid-2.5.STABLE5-CONNECT_log_size.patch \
- squid-2.5.STABLE5-proxy_abuse.patch \
- squid-2.5.STABLE5-ntlm_auth_overflow.patch
+PATCHFILES= squid-2.5.STABLE6.ufs_no_valid_dir.patch
PATCH_DIST_STRIP= -p1
MAINTAINER= tmseck@netcologne.de
@@ -246,38 +254,7 @@ SQUID_DEFAULT_LANG?= English
CONFIGURE_ARGS+= --enable-err-languages="${SQUID_LANGUAGES}" \
--enable-default-err-language=${SQUID_DEFAULT_LANG}
-# Other not so common configure options you can set via SQUID_CONFIGURE_ARGS:
-# Please see the configure script in the squid source distribution for a
-# complete list.
-#
-# --enable-dlmalloc
-# Compile and use the malloc package from Doug Lea
-# --enable-gnuregex
-# Compile and use the supplied GNUregex routines instead of BSD regex.
-# --enable-xmalloc-statistics
-# Show malloc statistics in status page
-# --enable-time-hack
-# Optimize time updates to one per second rather than calling gettimeofday()
-# --enable-cachemgr-hostname=some.hostname
-# Set an explicit hostname in cachemgr.cgi
-# --enable-truncate
-# Use truncate() rather than unlink()
-# --disable-unlinkd
-# Do not use "unlinkd"
-# --with-aufs-threads=N_THREADS
-# Tune the number of worker threads for the aufs object
-# --with-coss-membuf-size
-# COSS membuf size (default: 1048576 bytes)
-#
-# This option does not yet work on FreeBSD:
-#
-# --enable-ipf-transparent
-# Enable Transparent Proxy support for IP-Filter systems (incl 3.0)
-# (IPFilter headers are not currently installed to the base system,
-# PRs ports/60700 and misc/44148 describe the problem; see
-# http://www.squid-cache.org/Doc/FAQ/FAQ-17.html for information
-# about how to do transparent proxying with ipfw)
-
+# Finally, add additional user specified configuration options:
CONFIGURE_ARGS+= ${SQUID_CONFIGURE_ARGS}
CONFIGURE_ENV+= CFLAGS="${CFLAGS}" \
diff --git a/www/squid25/distinfo b/www/squid25/distinfo
index 9f798808315e..334ce8158938 100644
--- a/www/squid25/distinfo
+++ b/www/squid25/distinfo
@@ -1,52 +1,4 @@
-MD5 (squid2.5/squid-2.5.STABLE5.tar.bz2) = 45ed1b1cd492e3f529085d09c3ffc1b8
-SIZE (squid2.5/squid-2.5.STABLE5.tar.bz2) = 1044932
-MD5 (squid2.5/squid-2.5.STABLE5-ntlm_assert.patch) = 1bb2a8455a1e988c52b2ca3cf3fe0867
-SIZE (squid2.5/squid-2.5.STABLE5-ntlm_assert.patch) = 545
-MD5 (squid2.5/squid-2.5.STABLE5-ldap.patch) = 81bdcaf96390eab1655fd8d65cf607ed
-SIZE (squid2.5/squid-2.5.STABLE5-ldap.patch) = 6245
-MD5 (squid2.5/squid-2.5.STABLE5-helper_warning.patch) = f384daa03a07a4c99e84c922d9860524
-SIZE (squid2.5/squid-2.5.STABLE5-helper_warning.patch) = 3302
-MD5 (squid2.5/squid-2.5.STABLE5-vary.patch) = fd5f98f7eb8673df7e496ee72a6474b8
-SIZE (squid2.5/squid-2.5.STABLE5-vary.patch) = 626
-MD5 (squid2.5/squid-2.5.STABLE5-deny_info.patch) = bf73b60d02964ad9e410565389e73b06
-SIZE (squid2.5/squid-2.5.STABLE5-deny_info.patch) = 1282
-MD5 (squid2.5/squid-2.5.STABLE5-CONNECT_timeout.patch) = b6aa700c75a061dc9658d8dc198a9183
-SIZE (squid2.5/squid-2.5.STABLE5-CONNECT_timeout.patch) = 2531
-MD5 (squid2.5/squid-2.5.STABLE5-cache_swap_log.patch) = 8009bc493487a98b5f3deb01add66734
-SIZE (squid2.5/squid-2.5.STABLE5-cache_swap_log.patch) = 1245
-MD5 (squid2.5/squid-2.5.STABLE5-ntlm_warning.patch) = 57ec2b3e27dcff757412d6d0a6d3c778
-SIZE (squid2.5/squid-2.5.STABLE5-ntlm_warning.patch) = 900
-MD5 (squid2.5/squid-2.5.STABLE5-rfc1035NameUnpack.patch) = e3640442452f77762df5b20380aeb334
-SIZE (squid2.5/squid-2.5.STABLE5-rfc1035NameUnpack.patch) = 685
-MD5 (squid2.5/squid-2.5.STABLE5-digest_blank.patch) = 9eec94b95e52f26aece4568af4a2e5ae
-SIZE (squid2.5/squid-2.5.STABLE5-digest_blank.patch) = 4598
-MD5 (squid2.5/squid-2.5.STABLE5-post_assert.patch) = 154d3540d53ab3c377554a6756019e10
-SIZE (squid2.5/squid-2.5.STABLE5-post_assert.patch) = 2953
-MD5 (squid2.5/squid-2.5.STABLE5-digest_ERR.patch) = 96b4396117f5bcda2ba29401ef15af32
-SIZE (squid2.5/squid-2.5.STABLE5-digest_ERR.patch) = 1015
-MD5 (squid2.5/squid-2.5.STABLE5-turkish_ERR_DNS_FAIL.patch) = f4e806deca44898019d3ac65cb9ba823
-SIZE (squid2.5/squid-2.5.STABLE5-turkish_ERR_DNS_FAIL.patch) = 641
-MD5 (squid2.5/squid-2.5.STABLE5-vary_negatively.patch) = c442094681847b0db3b10d78aedc9b40
-SIZE (squid2.5/squid-2.5.STABLE5-vary_negatively.patch) = 2308
-MD5 (squid2.5/squid-2.5.STABLE5-range_offset_limit.patch) = 6a0fe31f8a80c0f515c92d766d824fd2
-SIZE (squid2.5/squid-2.5.STABLE5-range_offset_limit.patch) = 565
-MD5 (squid2.5/squid-2.5.STABLE5-large_cache_mem.patch) = 3307814d1bacb3f9d541fdbe6b31a7ff
-SIZE (squid2.5/squid-2.5.STABLE5-large_cache_mem.patch) = 1848
-MD5 (squid2.5/squid-2.5.STABLE5-least-load.patch) = ae82a0a580f854ed99edb6f8dffa3d16
-SIZE (squid2.5/squid-2.5.STABLE5-least-load.patch) = 2638
-MD5 (squid2.5/squid-2.5.STABLE5-cacheCurrentUnlinkRequests.patch) = f2ee3fbea33cabdd8388898e06490c8c
-SIZE (squid2.5/squid-2.5.STABLE5-cacheCurrentUnlinkRequests.patch) = 1449
-MD5 (squid2.5/squid-2.5.STABLE5-debug_client_ip.patch) = 46ac1ff54916a2c08dc040f484641a0a
-SIZE (squid2.5/squid-2.5.STABLE5-debug_client_ip.patch) = 2104
-MD5 (squid2.5/squid-2.5.STABLE5-ftp_html_doctype.patch) = 81ec48eda92c1b6522d21a9585c94be7
-SIZE (squid2.5/squid-2.5.STABLE5-ftp_html_doctype.patch) = 1266
-MD5 (squid2.5/squid-2.5.STABLE5-dns_localhost.patch) = cee1c1417185696f5ab9c94fba49ffde
-SIZE (squid2.5/squid-2.5.STABLE5-dns_localhost.patch) = 1408
-MD5 (squid2.5/squid-2.5.STABLE5-msnt_auth_doc.patch) = 6031dda00c8e963e7f9ca17b369006bd
-SIZE (squid2.5/squid-2.5.STABLE5-msnt_auth_doc.patch) = 16644
-MD5 (squid2.5/squid-2.5.STABLE5-CONNECT_log_size.patch) = 9bc3c39ca19ae2a4922d4a0e11bb4238
-SIZE (squid2.5/squid-2.5.STABLE5-CONNECT_log_size.patch) = 2011
-MD5 (squid2.5/squid-2.5.STABLE5-proxy_abuse.patch) = 8b169a288a0491a760f4d04c4f5eab21
-SIZE (squid2.5/squid-2.5.STABLE5-proxy_abuse.patch) = 761
-MD5 (squid2.5/squid-2.5.STABLE5-ntlm_auth_overflow.patch) = 30c7c5e2ba03655dbde9d3e65409baed
-SIZE (squid2.5/squid-2.5.STABLE5-ntlm_auth_overflow.patch) = 3198
+MD5 (squid2.5/squid-2.5.STABLE6.tar.bz2) = 7fd964ac27b43b613d6b981cc702a29e
+SIZE (squid2.5/squid-2.5.STABLE6.tar.bz2) = 1047199
+MD5 (squid2.5/squid-2.5.STABLE6.ufs_no_valid_dir.patch) = 26a4ab522a2469f805f746bcdbe0109c
+SIZE (squid2.5/squid-2.5.STABLE6.ufs_no_valid_dir.patch) = 566