aboutsummaryrefslogtreecommitdiff
path: root/www/squid30
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-04-05 00:01:19 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-04-05 00:01:19 +0000
commitfd719bb314e3649c94577b3e701f1c6ebb49b788 (patch)
tree2e406dfdd574018783ae3f3aaf6ee7943850af17 /www/squid30
parent6a349c04c44d53991a17a38400e7b3c0a221f94a (diff)
downloadports-fd719bb314e3649c94577b3e701f1c6ebb49b788.tar.gz
ports-fd719bb314e3649c94577b3e701f1c6ebb49b788.zip
Notes
Diffstat (limited to 'www/squid30')
-rw-r--r--www/squid30/Makefile5
-rw-r--r--www/squid30/distinfo6
-rw-r--r--www/squid30/files/patch-bug-220650
-rw-r--r--www/squid30/files/patch-configure21
4 files changed, 5 insertions, 77 deletions
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index 460581cfa390..37559130b6e2 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -62,8 +62,7 @@
# requests.
PORTNAME= squid
-PORTVERSION= 3.0.2
-PORTREVISION= 1
+PORTVERSION= 3.0.4
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
ftp://mirrors.24-7-solutions.net/pub/squid/%SUBDIR%/ \
@@ -82,7 +81,7 @@ MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
http://www1.jp.squid-cache.org/Versions/v3/3.0/ \
http://www2.tw.squid-cache.org/Versions/v3/3.0/
MASTER_SITE_SUBDIR= squid-3/STABLE
-DISTNAME= squid-3.0.STABLE2
+DISTNAME= squid-3.0.STABLE4
DIST_SUBDIR= squid3.0
PATCH_SITES= http://www.squid-cache.org/%SUBDIR%/ \
diff --git a/www/squid30/distinfo b/www/squid30/distinfo
index 5d8a98f0eab0..86b233b63b32 100644
--- a/www/squid30/distinfo
+++ b/www/squid30/distinfo
@@ -1,3 +1,3 @@
-MD5 (squid3.0/squid-3.0.STABLE2.tar.bz2) = 33c89b22aaf27d12b818b5f120aa0322
-SHA256 (squid3.0/squid-3.0.STABLE2.tar.bz2) = eabace0fd4f61a49389d1dffb20705b4a22ba8d65e281e6c5fff47c1aeef2ed1
-SIZE (squid3.0/squid-3.0.STABLE2.tar.bz2) = 1822143
+MD5 (squid3.0/squid-3.0.STABLE4.tar.bz2) = 50ea09d59b8a37b34d0ea38acb1eef43
+SHA256 (squid3.0/squid-3.0.STABLE4.tar.bz2) = b838dd87a6a6c9c1fda24f29f991b84f16a0ee3a1cf18705c61dde405a09b7ca
+SIZE (squid3.0/squid-3.0.STABLE4.tar.bz2) = 1818054
diff --git a/www/squid30/files/patch-bug-2206 b/www/squid30/files/patch-bug-2206
deleted file mode 100644
index c6ab20f58013..000000000000
--- a/www/squid30/files/patch-bug-2206
+++ /dev/null
@@ -1,50 +0,0 @@
-Temporary patch for Squid bug 2206 ("no proxy Authenticate header in 407
-response") as fetched from Squid bugzilla 2008-03-26.
-
-See <http://www.squid-cache.org/bugs/show_bug_cgi?id=2206> for further
-information.
-=== modified file 'src/HttpHeader.cc'
---- src/HttpHeader.cc 2008-02-27 12:59:29 +0000
-+++ src/HttpHeader.cc 2008-03-12 20:53:15 +0000
-@@ -1806,5 +1806,7 @@
- }
- if (headers_deleted)
- refreshMask();
-+
-+ delById(HDR_CONNECTION);
- }
- }
-
-=== modified file 'src/HttpHeader.h'
---- src/HttpHeader.h 2008-02-27 12:59:29 +0000
-+++ src/HttpHeader.h 2008-03-12 20:53:56 +0000
-@@ -247,15 +247,13 @@
- int hasListMember(http_hdr_type id, const char *member, const char separator) const;
- int hasByNameListMember(const char *name, const char *member, const char separator) const;
- void removeHopByHopEntries();
-+ void removeConnectionHeaderEntries();
- /* protected, do not use these, use interface functions instead */
- Vector<HttpHeaderEntry *> entries; /* parsed fields in raw format */
- HttpHeaderMask mask; /* bit set <=> entry present */
- http_hdr_owner_type owner; /* request or reply */
- int len; /* length when packed, not counting terminating '\0' */
-
--protected:
-- void removeConnectionHeaderEntries();
--
- private:
- HttpHeaderEntry *findLastEntry(http_hdr_type id) const;
- // Make it non-copyable. Our destructor is a bit nasty...
-
-=== modified file 'src/client_side_reply.cc'
---- src/client_side_reply.cc 2008-02-27 12:59:29 +0000
-+++ src/client_side_reply.cc 2008-03-12 20:54:37 +0000
-@@ -1214,7 +1214,7 @@
- if (is_hit)
- hdr->delById(HDR_SET_COOKIE);
-
-- reply->header.removeHopByHopEntries();
-+ reply->header.removeConnectionHeaderEntries();
-
- // if (request->range)
- // clientBuildRangeHeader(http, reply);
diff --git a/www/squid30/files/patch-configure b/www/squid30/files/patch-configure
deleted file mode 100644
index 062409040677..000000000000
--- a/www/squid30/files/patch-configure
+++ /dev/null
@@ -1,21 +0,0 @@
-Patch for Squid bug #2203:
-
-LDFLAGS gets unset when --with-filedescriptors=n is added to
-SQUID_CONFIGURE_ARGS.
-
---- configure.orig 2008-03-26 21:16:54.000000000 +0100
-+++ configure 2008-03-26 21:18:40.000000000 +0100
-@@ -43819,12 +43819,12 @@
-
- { echo "$as_me:$LINENO: checking Maximum number of filedescriptors we can open" >&5
- echo $ECHO_N "checking Maximum number of filedescriptors we can open... $ECHO_C" >&6; }
-+TLDFLAGS="$LDFLAGS"
- if test -n "$squid_filedescriptors_num" ; then
- SQUID_MAXFD=$squid_filedescriptors_num
- { echo "$as_me:$LINENO: result: $SQUID_MAXFD (user-forced)" >&5
- echo "${ECHO_T}$SQUID_MAXFD (user-forced)" >&6; }
- else
-- TLDFLAGS="$LDFLAGS"
- case $host in
- i386-unknown-freebsd*)
- if echo "$LDFLAGS" | grep -q pthread; then