aboutsummaryrefslogtreecommitdiff
path: root/www/squid31/Makefile
diff options
context:
space:
mode:
authorAdrian Chadd <adrian@FreeBSD.org>2001-03-27 12:28:47 +0000
committerAdrian Chadd <adrian@FreeBSD.org>2001-03-27 12:28:47 +0000
commit88dd211266913d0df8c20d25df96c11041e4f94c (patch)
treeedff426bdf7c55288de3d1aa4ac38e64c1c2c382 /www/squid31/Makefile
parentaba319a01e6dcfb3fd15e9d20f6f1b1eb40b519e (diff)
PR: 26059
Update the squid-2.4 port to actually _be_ squid-2.4 . Phew. This port builds, installs, packages, pkg_delete's cleanly. I'm going to run it through some more linting and tidying up before I'm completely done with it. Differences from squid22/squid23 : * install-pinger isn't built. I'll tackle this later, possibly by creating a squid user/group. I don't like having suid binaries installed, even more so when 99% of the users of this port won't even enable ICMP pinging. * I've enabled the lru and heap replacement policies. LRU is used by default, the beauty here is that the user can choose one or the other without needing a recompile. * I've enabled ufs (sync), diskd (async) and null (no caching, only proxying). This again lets users choose what they want without needing a recompile. The default is still a 100mb cache in /usr/local/squid/cache/ running ufs. I would change it to diskd but if the user hasn't tweaked their sysV shm/msg parameters sufficiently they'll just be puzzled when squid gives mysterious sysV errors (and if they load it up enough to have UFS become an issue, they'd be better off reading the squid FAQ anyhow..)
Notes
Notes: svn path=/head/; revision=40434
Diffstat (limited to 'www/squid31/Makefile')
-rw-r--r--www/squid31/Makefile28
1 files changed, 13 insertions, 15 deletions
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 0421718cc61a..911bca9dc3d8 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -6,33 +6,30 @@
#
PORTNAME= squid
-PORTVERSION= 2.3
+PORTVERSION= 2.4
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/squid-2/STABLE/ \
ftp://www.unimelb.edu.au/pub/cwis/servers/unix/squid/squid-2/STABLE/ \
ftp://sunsite.auc.dk/pub/infosystems/squid/squid-2/STABLE/ \
ftp://ftp.net.lut.ac.uk/squid/squid-2/STABLE/
-DISTNAME= squid-2.3.STABLE4
+DISTNAME= squid-2.4.STABLE1
EXTRACT_SUFX= -src.tar.gz
-PATCH_SITES= http://www.squid-cache.org/Versions/v2/2.3/bugs/
-PATCHFILES= squid-2.3.stable4-ftp_icon_not_found.patch \
- squid-2.3.stable4-internal_dns_rcode_table_formatting.patch \
- squid-2.3.stable4-ipfw_configure.patch \
- squid-2.3.stable4-invalid_ip_acl_entry.patch \
- squid-2.3.stable4-accel_only_access.patch \
- squid-2.3.stable4-html_quoting.patch \
- squid-2.3.stable4-carp-assertion.patch
+PATCH_SITES= http://www.squid-cache.org/Versions/v2/2.4/bugs/
+PATCHFILES=
MAINTAINER= adrian@freebsd.org
-DIST_SUBDIR= squid2.3
+DIST_SUBDIR= squid2.4
PATCH_DIST_STRIP= -p0
GNU_CONFIGURE= yes
# Follow the apache port's lead...
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
- --localstatedir=${PREFIX}/squid
+ --localstatedir=${PREFIX}/squid \
+ --enable-storeio="ufs diskd null" \
+ --enable-removal-policies="lru heap" \
+
STRIP= # won't install scripts correctly otherwise.
MAKEFILE= makefile
@@ -49,8 +46,6 @@ MAKEFILE= makefile
#CONFIGURE_ARGS+= --enable-xmalloc-statistics
# - Enable CARP support
#CONFIGURE_ARGS+= --enable-carp
-# - Use ASYNC disk I/O (Requires real threads, apparently runs on 3.0 libc_r)
-#CONFIGURE_ARGS+= --enable-async-io
# - Enable ICMP pinging for heirarchy stats and selection
#CONFIGURE_ARGS+= --enable-icmp
# - Enable delay pools to limit bandwidth usage
@@ -101,7 +96,10 @@ post-extract:
@${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
post-install:
- cd ${WRKSRC}/src; make install-pinger
+# I don't think many people use the pinger nowadays, and if you
+# do you'll want squid in its own group so as to restrict access
+# to it.
+# cd ${WRKSRC}/src; make install-pinger
.for file in client squid
if [ -f ${PREFIX}/sbin/${file} ] ; then \
strip ${PREFIX}/sbin/${file} ; \