aboutsummaryrefslogtreecommitdiff
path: root/www/squid31
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-18 18:55:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-18 18:55:45 +0000
commit300aa08dd8e31cce3c6a11bb35d51a0dfb4ae7c9 (patch)
treef4f6f6e0f753f3f728077ea84088f71720c001b8 /www/squid31
parentd7f7d9966b467877c9b45e294519dac7b57e5487 (diff)
downloadports-300aa08dd8e31cce3c6a11bb35d51a0dfb4ae7c9.tar.gz
ports-300aa08dd8e31cce3c6a11bb35d51a0dfb4ae7c9.zip
Notes
Diffstat (limited to 'www/squid31')
-rw-r--r--www/squid31/Makefile37
-rw-r--r--www/squid31/distinfo9
-rw-r--r--www/squid31/files/patch-errors__Armenian71
-rw-r--r--www/squid31/files/patch-secfix-2007-2143
-rw-r--r--www/squid31/files/pkg-message.in3
-rw-r--r--www/squid31/pkg-descr4
6 files changed, 15 insertions, 252 deletions
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 1499bed85c4b..419933d8250c 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -62,8 +62,7 @@
# requests.
PORTNAME= squid
-PORTVERSION= 3.0.r1.${PATCHSET_DATE}
-PORTREVISION= 1
+PORTVERSION= 3.0.1
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
ftp://mirrors.24-7-solutions.net/pub/squid/%SUBDIR%/ \
@@ -81,8 +80,8 @@ MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
http://www1.uk.squid-cache.org/Versions/v3/3.0/ \
http://www1.jp.squid-cache.org/Versions/v3/3.0/ \
http://www2.tw.squid-cache.org/Versions/v3/3.0/
-MASTER_SITE_SUBDIR= squid-3/DEVEL
-DISTNAME= squid-3.0.RC1
+MASTER_SITE_SUBDIR= squid-3/STABLE
+DISTNAME= squid-3.0.STABLE1
DIST_SUBDIR= squid3.0
PATCH_SITES= http://www.squid-cache.org/%SUBDIR%/ \
@@ -95,27 +94,18 @@ PATCH_SITES= http://www.squid-cache.org/%SUBDIR%/ \
http://www1.jp.squid-cache.org/%SUBDIR%/ \
http://www1.tw.squid-cache.org/%SUBDIR%/
PATCH_SITE_SUBDIR= Versions/v3/3.0/changesets
-# Inspired by editors/vim:
-# (I know that portlint is not happy with this, but putting this code at any
-# other location makes it even unhappier.)
-PATCHSET_DATE= 20071001
-FIRST_PATCHSET= 11149
-LAST_PATCHSET= 11149
-IGNORE_PATCHSETS=
-PATCHFILES!= jot -w "%d.patch" - ${FIRST_PATCHSET} ${LAST_PATCHSET} 1
-.for ps in ${IGNORE_PATCHSETS}
-PATCHFILES:= ${PATCHFILES:N${ps}\.patch}
-.endfor
+PATCHFILES=
PATCH_DIST_STRIP= -p1
-MAINTAINER= tmseck@netcologne.de
-COMMENT= HTTP Caching Proxy (development version)
+MAINTAINER= tmseck@web.de
+COMMENT= HTTP Caching Proxy
LATEST_LINK= squid30
CONFLICTS= squid-2.[0-9].*
GNU_CONFIGURE= yes
-# disable autotools bootstrapping for now, RC1 does not currently require it:
+# disable autotools bootstrapping for now, 3.0.STABLE does not currently
+# require it:
#USE_AUTOTOOLS= autoconf:261 automake:19 libtool:15
USE_BZIP2= yes
USE_PERL5= yes
@@ -124,7 +114,7 @@ USE_RC_SUBR= squid
SQUID_UID?= squid
SQUID_GID?= squid
-MAN8= cachemgr.cgi.8 squid.8
+MAN8= cachemgr.cgi.8 squid.8 squid_radius_auth.8
docs= QUICKSTART README RELEASENOTES.html doc/debug-sections.txt
PORTDOCS= ${docs:T}
PORTEXAMPLES= *
@@ -189,8 +179,8 @@ error_files= ERR_ACCESS_DENIED ERR_CACHE_ACCESS_DENIED \
libexec= cachemgr.cgi digest_pw_auth diskd ip_user_check \
msnt_auth ncsa_auth ntlm_auth pam_auth smb_auth \
- smb_auth.sh squid_db_auth squid_session squid_unix_group \
- wbinfo_group.pl
+ smb_auth.sh squid_db_auth squid_radius_auth squid_session \
+ squid_unix_group wbinfo_group.pl
.if !defined(SQUID_CONFIGURE_ARGS) || ${SQUID_CONFIGURE_ARGS:M*--disable-unlinkd*} == ""
libexec+= unlinkd
.endif
@@ -213,7 +203,7 @@ CONFIGURE_ARGS= --with-default-user=${SQUID_UID} \
# Authentication methods and modules:
-basic_auth= DB NCSA PAM MSNT SMB
+basic_auth= DB NCSA PAM MSNT SMB squid_radius_auth
digest_auth= password
external_acl= ip_user session unix_group wbinfo_group
MAN8+= ncsa_auth.8 pam_auth.8 squid_db_auth.8 squid_session.8 \
@@ -411,9 +401,6 @@ PLIST_FILES+= ${error_files:S,^,etc/squid/errors/${d}/,}
PLIST_DIRS+= etc/squid/errors etc/squid squid/logs squid/cache squid
post-patch:
-# add this version's datestamp so that Squid identifies itself as patched-up:
- @${REINPLACE_CMD} -e 's|3.0.RC1|&+PatchSets-${PATCHSET_DATE}|' \
- ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/src/cf.data.pre
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
diff --git a/www/squid31/distinfo b/www/squid31/distinfo
index addcf2f7afeb..bd86c915317e 100644
--- a/www/squid31/distinfo
+++ b/www/squid31/distinfo
@@ -1,6 +1,3 @@
-MD5 (squid3.0/squid-3.0.RC1.tar.bz2) = d4c53f92514db85322dc8a799a3b2e83
-SHA256 (squid3.0/squid-3.0.RC1.tar.bz2) = cf261e445b5037f049e1b0e7cf41fd4dcc02b438ee7af764290adb5e188bcda3
-SIZE (squid3.0/squid-3.0.RC1.tar.bz2) = 1813556
-MD5 (squid3.0/11149.patch) = a4226636df193cb5419ec6fb63afd2d4
-SHA256 (squid3.0/11149.patch) = 30c8d21b96cc51d2c701ddd53e560bc4a0d5feae0b90bd8ff1d7c9f28a728a89
-SIZE (squid3.0/11149.patch) = 1954
+MD5 (squid3.0/squid-3.0.STABLE1.tar.bz2) = ec7458b00a68341854d91e7f6ece56ba
+SHA256 (squid3.0/squid-3.0.STABLE1.tar.bz2) = 3ebf3e22998b608afcfc10f29991722b5df5636217df6498902302dd05f4ab6c
+SIZE (squid3.0/squid-3.0.STABLE1.tar.bz2) = 1816804
diff --git a/www/squid31/files/patch-errors__Armenian b/www/squid31/files/patch-errors__Armenian
deleted file mode 100644
index a420206f669e..000000000000
--- a/www/squid31/files/patch-errors__Armenian
+++ /dev/null
@@ -1,71 +0,0 @@
-Add copies of the respective English language documents to the errors/Armenian
-directory. This allows the port to install the complete set of Armenian
-language documents. This patch has been submitted as Squid bug #2094 and will
-hopefully be added to mainline Squid in the next release.
---- errors/Armenian/ERR_ESI Thu Jan 1 01:00:00 1970
-+++ errors/Armenian/ERR_ESI Wed Oct 3 17:07:05 2007
-@@ -0,0 +1,28 @@
-+<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
-+<HTML><HEAD>
-+<TITLE>ERROR: The requested URL could not be retrieved</TITLE>
-+<STYLE type="text/css"><!--BODY{background-color:#ffffff;font-family:verdana,sans-serif}PRE{font-family:sans-serif}--></STYLE>
-+</HEAD><BODY>
-+<H2>The requested URL could not be retrieved</H2>
-+<HR noshade size="1px">
-+<P>
-+While trying to retrieve the URL:
-+<A HREF="%U">%U</A>
-+<P>
-+The following error was encountered:
-+<BLOCKQUOTE>
-+ESI Processing failed.
-+</BLOCKQUOTE>
-+
-+<P>
-+The ESI processor returned:
-+<BLOCKQUOTE>
-+%Z
-+</BLOCKQUOTE>
-+
-+<P>
-+This means that:
-+<PRE>
-+ The surrogate was not able to process the ESI template. Please report this error to the webmaster.
-+</PRE>
-+<P>Your webmaster is <A HREF="mailto:%w">%w</A>.
---- errors/Armenian/ERR_ICAP_FAILURE Thu Jan 1 01:00:00 1970
-+++ errors/Armenian/ERR_ICAP_FAILURE Wed Oct 3 17:07:05 2007
-@@ -0,0 +1,33 @@
-+<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
-+<HTML><HEAD>
-+<TITLE>ERROR: The requested URL could not be retrieved</TITLE>
-+<STYLE type="text/css"><!--BODY{background-color:#ffffff; font-family:verdana,sans-serif}--></STYLE>
-+</HEAD><BODY>
-+<H1>ERROR</H1>
-+<H2>The requested URL could not be retrieved</H2>
-+<HR noshade size="1px">
-+<P>
-+While trying to retrieve the URL:
-+<A HREF="%U">%U</A>
-+<P>
-+The following error was encountered:
-+<UL>
-+<LI>
-+<STRONG>
-+ICAP protocol error.
-+</STRONG>
-+</UL>
-+
-+<P>
-+The system returned:
-+<PRE><I> %E</I></PRE>
-+
-+<P>
-+This means that:
-+Some aspect of the ICAP communication failed. Possible problems:
-+<UL>
-+<LI>ICAP server is not reachable.
-+<LI>Illegal response from ICAP server.
-+</UL>
-+</P>
-+
diff --git a/www/squid31/files/patch-secfix-2007-2 b/www/squid31/files/patch-secfix-2007-2
deleted file mode 100644
index 8b190c3d249e..000000000000
--- a/www/squid31/files/patch-secfix-2007-2
+++ /dev/null
@@ -1,143 +0,0 @@
-Patch for the remote denial of service vulnerability as documented in
-Squid advisory 2007_2 (http://www.squid-cache.org/Advisories/SQUID-2007_2.txt):
-
-This is a slightly revised version of the original PatchSet 11211, with
-one hunk removed and path informations stripped in order to make it
-apply to otherwise unpatched 3.0.RC1 sources.
-
-Created: 2007-12-04 by Thomas-Martin Seck <tmseck@netcologne.de> for the
-FreeBSD port of Squid 3.0.
-
----------------------
-PatchSet 11211
-Date: 2007/11/26 13:09:54
-Author: hno
-Branch: HEAD
-Tag: (none)
-Log:
-pack header entries on cache updates
-
-Members:
- include/Array.h:1.24->1.25
- src/HttpHeader.cc:1.137->1.138
- src/HttpHeader.h:1.23->1.24
- src/HttpReply.cc:1.96->1.97
-
-Index: squid3/include/Array.h
-===================================================================
-RCS file: /cvsroot/squid/squid3/include/Array.h,v
-retrieving revision 1.24
-retrieving revision 1.25
-diff -u -r1.24 -r1.25
---- include/Array.h 21 Nov 2005 22:43:41 -0000 1.24
-+++ include/Array.h 26 Nov 2007 13:09:54 -0000 1.25
-@@ -1,5 +1,5 @@
- /*
-- * $Id: Array.h,v 1.24 2005/11/21 22:43:41 wessels Exp $
-+ * $Id: Array.h,v 1.25 2007/11/26 13:09:54 hno Exp $
- *
- * AUTHOR: Alex Rousskov
- *
-@@ -98,6 +98,7 @@
- E &back();
- E pop_back();
- E shift(); // aka pop_front
-+ void prune(E);
- void preAppend(int app_count);
- bool empty() const;
- size_t size() const;
-@@ -243,6 +244,22 @@
- return items[size() - 1];
- }
-
-+template<class E>
-+void
-+Vector<E>::prune(E item)
-+{
-+ unsigned int n = 0;
-+ for (unsigned int i = 0; i < count; i++) {
-+ if (items[i] != item) {
-+ if (i != n)
-+ items[n] = items[i];
-+ n++;
-+ }
-+ }
-+
-+ count = n;
-+}
-+
- /* if you are going to append a known and large number of items, call this first */
- template<class E>
- void
-Index: squid3/src/HttpHeader.cc
-===================================================================
-RCS file: /cvsroot/squid/squid3/src/HttpHeader.cc,v
-retrieving revision 1.137
-retrieving revision 1.138
-diff -u -r1.137 -r1.138
---- src/HttpHeader.cc 26 Nov 2007 12:31:37 -0000 1.137
-+++ src/HttpHeader.cc 26 Nov 2007 13:09:55 -0000 1.138
-@@ -787,6 +787,15 @@
- }
-
- /*
-+ * Compacts the header storage
-+ */
-+void
-+HttpHeader::compact()
-+{
-+ entries.prune(NULL);
-+}
-+
-+/*
- * Refreshes the header mask. Required after delAt() calls.
- */
- void
-Index: squid3/src/HttpHeader.h
-===================================================================
-RCS file: /cvsroot/squid/squid3/src/HttpHeader.h,v
-retrieving revision 1.23
-retrieving revision 1.24
-diff -u -r1.23 -r1.24
---- src/HttpHeader.h 13 Aug 2007 17:20:51 -0000 1.23
-+++ src/HttpHeader.h 26 Nov 2007 13:09:55 -0000 1.24
-@@ -1,6 +1,6 @@
-
- /*
-- * $Id: HttpHeader.h,v 1.23 2007/08/13 17:20:51 hno Exp $
-+ * $Id: HttpHeader.h,v 1.24 2007/11/26 13:09:55 hno Exp $
- *
- *
- * SQUID Web Proxy Cache http://www.squid-cache.org/
-@@ -202,6 +202,7 @@
- void clean();
- void append(const HttpHeader * src);
- void update (HttpHeader const *fresh, HttpHeaderMask const *denied_mask);
-+ void compact();
- int reset();
- int parse(const char *header_start, const char *header_end);
- void packInto(Packer * p) const;
-Index: squid3/src/HttpReply.cc
-===================================================================
-RCS file: /cvsroot/squid/squid3/src/HttpReply.cc,v
-retrieving revision 1.96
-retrieving revision 1.97
-diff -u -r1.96 -r1.97
---- src/HttpReply.cc 13 Aug 2007 17:20:51 -0000 1.96
-+++ src/HttpReply.cc 26 Nov 2007 13:09:55 -0000 1.97
-@@ -1,6 +1,6 @@
-
- /*
-- * $Id: HttpReply.cc,v 1.96 2007/08/13 17:20:51 hno Exp $
-+ * $Id: HttpReply.cc,v 1.97 2007/11/26 13:09:55 hno Exp $
- *
- * DEBUG: section 58 HTTP Reply (Response)
- * AUTHOR: Alex Rousskov
-@@ -312,6 +312,7 @@
- header.update(&freshRep->header,
- (const HttpHeaderMask *) &Denied304HeadersMask);
-
-+ header.compact();
- /* init cache */
- hdrCacheInit();
- }
diff --git a/www/squid31/files/pkg-message.in b/www/squid31/files/pkg-message.in
index 6182fdea0f63..8a17b2772a7f 100644
--- a/www/squid31/files/pkg-message.in
+++ b/www/squid31/files/pkg-message.in
@@ -30,6 +30,3 @@
Additionally, you should check your configuration by calling
'squid -f /path/to/squid.conf -k parse' before starting Squid.
- Keep in mind that this version of Squid is a development version and
- is probably noticeably slower and less stable than Squid 2.
-
diff --git a/www/squid31/pkg-descr b/www/squid31/pkg-descr
index 7e1a96e85534..0cd02912d960 100644
--- a/www/squid31/pkg-descr
+++ b/www/squid31/pkg-descr
@@ -7,8 +7,4 @@ Squid supports SSL, extensive access controls, and full request logging.
By using the lightweight Internet Cache Protocol, Squid caches can be
arranged in a hierarchy or mesh for additional bandwidth savings.
-This version of Squid is a pre-release snapshot of the upcoming Squid 3.
-It is primarily meant for pre-release testing and should not yet be put
-into production use.
-
WWW: http://www.squid-cache.org/