aboutsummaryrefslogtreecommitdiff
path: root/www/squid31
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-24 20:28:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-24 20:28:32 +0000
commit9dbbcb3f029d25a6c1245293b251941d7b73a24c (patch)
tree2ddac583ea91b093e76b5ea2c001bceff21489e8 /www/squid31
parent96c05ee45f23260ba494dc50174c824206e91d21 (diff)
downloadports-9dbbcb3f029d25a6c1245293b251941d7b73a24c.tar.gz
ports-9dbbcb3f029d25a6c1245293b251941d7b73a24c.zip
Notes
Diffstat (limited to 'www/squid31')
-rw-r--r--www/squid31/Makefile36
-rw-r--r--www/squid31/distinfo78
-rw-r--r--www/squid31/files/patch-src-cf.data.pre15
-rw-r--r--www/squid31/files/squid.in6
4 files changed, 114 insertions, 21 deletions
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 74cdb79a75b9..bd946746422b 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -92,14 +92,14 @@ PATCH_SITE_SUBDIR= Versions/v3/3.0/changesets
# Inspired by editors/vim:
# (I know that portlint is not happy with this, but putting this code at any
# other location makes it even unhappier.)
-PATCHSET_DATE= 20070529
+PATCHSET_DATE= 20070623
FIRST_PATCHSET= 10789
-LAST_PATCHSET= 10834
+LAST_PATCHSET= 10865
IGNORE_PATCHSETS= 10792 10793 10794 10795 10796 10798 10799 10803 10807 \
- 10810 10814 10819
+ 10810 10814 10819 10835 10842 10847 10862 10864
PATCHFILES!= jot -w "%d.patch" - ${FIRST_PATCHSET} ${LAST_PATCHSET} 1
-.for cs in ${IGNORE_PATCHSETS}
-PATCHFILES:= ${PATCHFILES:N${cs}\.patch}
+.for ps in ${IGNORE_PATCHSETS}
+PATCHFILES:= ${PATCHFILES:N${ps}\.patch}
.endfor
PATCH_DIST_STRIP= -p1
@@ -121,6 +121,7 @@ SQUID_GID?= squid
MAN8= cachemgr.cgi.8 squid.8
docs= QUICKSTART README RELEASENOTES.html doc/debug-sections.txt
PORTDOCS= ${docs:T}
+PORTEXAMPLES= *
SUB_FILES+= pkg-deinstall pkg-install pkg-message
SUB_LIST+= SQUID_UID=${SQUID_UID} SQUID_GID=${SQUID_GID}
@@ -149,7 +150,7 @@ OPTIONS= SQUID_LDAP_AUTH "Install LDAP authentication helpers" off \
SQUID_ESI "Enable ESI support (experimental)" off \
SQUID_AUFS "Enable the aufs storage scheme" off \
SQUID_COSS "Enable the COSS storage scheme" off \
- SQUID_KQUEUE "Use kqueue(2) instead of poll(2)" on \
+ SQUID_KQUEUE "Use kqueue(2) (experimental)" on \
SQUID_LARGEFILE "Support log and cache files >2GB" off \
SQUID_STACKTRACES "Create backtraces on fatal errors" off \
SQUID_DEBUG "Enable debugging options" off
@@ -180,7 +181,7 @@ error_files= ERR_ACCESS_DENIED ERR_CACHE_ACCESS_DENIED \
ERR_SHUTTING_DOWN ERR_SOCKET_FAILURE ERR_TOO_BIG ERR_UNSUP_REQ \
ERR_URN_RESOLVE ERR_WRITE_ERROR ERR_ZERO_SIZE_OBJECT
-libexec= cachemgr.cgi digest_pw_auth diskd ip_user_check \
+libexec= cachemgr.cgi db_auth.pl digest_pw_auth diskd ip_user_check \
msnt_auth ncsa_auth ntlm_auth \
pam_auth smb_auth smb_auth.sh squid_session squid_unix_group \
wbinfo_group.pl
@@ -205,7 +206,7 @@ CONFIGURE_ARGS= --bindir=${PREFIX}/sbin \
# Authentication methods and modules:
-basic_auth= NCSA PAM MSNT SMB
+basic_auth= DB NCSA PAM MSNT SMB
digest_auth= password
external_acl= ip_user session unix_group wbinfo_group
MAN8+= pam_auth.8 squid_session.8 squid_unix_group.8
@@ -346,8 +347,9 @@ CONFIGURE_ARGS+= --enable-esi
LIB_DEPENDS+= xml2:${PORTSDIR}/textproc/libxml2
.endif
.if defined(WITHOUT_SQUID_KQUEUE)
-# XXX: Squid3 -- unlike Squid2 -- does not automatically enable kqueue(2) at
-# this time so this is a no-op for now:
+# Squid-3's kqueue support is still marked as experimental, so it is not yet
+# enabled automatically as in Squid-2. We are explicit about disabling it,
+# nonetheless:
CONFIGURE_ARGS+= --disable-kqueue
.else
CONFIGURE_ARGS+= --enable-kqueue
@@ -357,15 +359,14 @@ CONFIGURE_ARGS+= --with-large-files
.endif
.if defined(WITH_SQUID_STACKTRACES)
CONFIGURE_ARGS+= --enable-stacktraces
-CFLAGS+= -g
-STRIP= ""
+CFLAGS+= -g
+STRIP=
.endif
.if defined(WITH_SQUID_DEBUG) || defined(WITH_DEBUG)
# TODO: are there other useful options that can/should be set to help
# the developers in debugging failures?
CONFIGURE_ARGS+= --disable-optimizations
-CFLAGS+= -g
-STRIP= ""
+WITH_DEBUG?= yes
.endif
# Languages:
#
@@ -400,7 +401,7 @@ PLIST_FILES+= ${error_files:S,^,etc/squid/errors/${d}/,}
PLIST_DIRS+= etc/squid/errors etc/squid squid/logs squid/cache squid
pre-patch:
-# special handling for ChangeSet 10817 that relies on metadata information
+# special handling for PatchSet 10817 that relies on metadata information
# supplied by a non applicable earlier patch; can be removed when the port
# is updated to a post-pre6 tarball:
@${REINPLACE_CMD} -e 's|v 1.453 2007/05/09 22:14:24 wessels|v 1.454 2007/05/13 10:57:41 hno|' \
@@ -411,7 +412,6 @@ post-patch:
# add this version's datestamp so that Squid identifies itself as patched-up:
@${REINPLACE_CMD} -e 's|3.0.PRE6|&+PatchSets-${PATCHSET_DATE}|' \
${WRKSRC}/configure.in
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|%%SQUID_UID%%|${SQUID_UID}|g' \
-e 's|%%SQUID_GID%%|${SQUID_GID}|g' \
-e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/src/cf.data.pre
@@ -429,10 +429,12 @@ pre-su-install:
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
-# Create cachemgr.conf.default manually since squid-3's install routine
+# Create cachemgr.conf.default manually since Squid-3's install routine
# unfortunately fails to do so (as it did in the old 2.5 days...):
${INSTALL_DATA} ${WRKSRC}/tools/cachemgr.conf \
${PREFIX}/etc/squid/cachemgr.conf.default
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/helpers/basic_auth/DB/passwd.sql ${EXAMPLESDIR}
.if defined(WITH_SQUID_PINGER)
${CHMOD} 4510 ${PREFIX}/libexec/squid/pinger; \
${CHGRP} ${SQUID_GID} ${PREFIX}/libexec/squid/pinger
diff --git a/www/squid31/distinfo b/www/squid31/distinfo
index e42a1f6cda3a..794d601ad59b 100644
--- a/www/squid31/distinfo
+++ b/www/squid31/distinfo
@@ -103,3 +103,81 @@ SIZE (squid3.0/10833.patch) = 6761
MD5 (squid3.0/10834.patch) = ff5c484e43e3d1c52d0ebb5d2cfb88f5
SHA256 (squid3.0/10834.patch) = 422db18eefe0f65f67191ecf14cd3ff8732da56149ac087f50a4470f78a1fce4
SIZE (squid3.0/10834.patch) = 235371
+MD5 (squid3.0/10836.patch) = fe487c42e4af8eaff1ac03ee04423c59
+SHA256 (squid3.0/10836.patch) = d5d3d115ffcbdf286506f7f0fcd6fff83297dc2ebea152f26de78306561b2a78
+SIZE (squid3.0/10836.patch) = 1345
+MD5 (squid3.0/10837.patch) = 032bce55fb09bcafee33a1c0b6214548
+SHA256 (squid3.0/10837.patch) = b8507ad105fe88659c1e6996a8f4723b905b893bf5c45f882e8c7d853ea2d7cb
+SIZE (squid3.0/10837.patch) = 26380
+MD5 (squid3.0/10838.patch) = 74214a7b15612d92d286b3fffa9a07ca
+SHA256 (squid3.0/10838.patch) = 785637b460f760c071505332240086623b034210164261899da13f63edbf8e4a
+SIZE (squid3.0/10838.patch) = 12288
+MD5 (squid3.0/10839.patch) = 08315200e037969512320b081b9bfae5
+SHA256 (squid3.0/10839.patch) = e626c7f6de437123db0f15fc8e1d00525d98435c7dfdcc5e76a0c66968c8b4a6
+SIZE (squid3.0/10839.patch) = 1075
+MD5 (squid3.0/10840.patch) = 7e1519d8211076ecb750f9fdecb35a40
+SHA256 (squid3.0/10840.patch) = 3b473062be4a7c4b75d92e7700c5f4c0aee19779d0cc757147c6238baa8e94df
+SIZE (squid3.0/10840.patch) = 1573
+MD5 (squid3.0/10841.patch) = 0d1eefd047d01e71180d71da08a7613b
+SHA256 (squid3.0/10841.patch) = af4664965865aa4de16a9d17f8ed253a576e52376aed26a1dfc77bedceef5591
+SIZE (squid3.0/10841.patch) = 5602
+MD5 (squid3.0/10843.patch) = 541faf0e0da0d096fb21078a610e9c19
+SHA256 (squid3.0/10843.patch) = 828741d29bc90b10eefc45348a446f8b3c5907a0e73b3fba891fe39313bb2bd1
+SIZE (squid3.0/10843.patch) = 1124
+MD5 (squid3.0/10844.patch) = 5c6a131e7d8ec1189900bc5dcf310d0e
+SHA256 (squid3.0/10844.patch) = 7af29cbad7f06092a16d6353e148b74bf4bd3299836f02d4452b811eeeed2946
+SIZE (squid3.0/10844.patch) = 5939
+MD5 (squid3.0/10845.patch) = 0d33aa300edc65fc928efa7285af4d9e
+SHA256 (squid3.0/10845.patch) = ba17e486602598500c9d71ae735c88bc358979b2b7b2aae3525e3413e333859b
+SIZE (squid3.0/10845.patch) = 5576
+MD5 (squid3.0/10846.patch) = 430aac93b9b5c55e9303d14e2ee526a2
+SHA256 (squid3.0/10846.patch) = 3f4d58bb14ae35df3251a88f4bee9ec5b22e61cf297bcfd247626a4bdd98f2d4
+SIZE (squid3.0/10846.patch) = 1200
+MD5 (squid3.0/10848.patch) = b174826341ce82d9943c2d1d47097f45
+SHA256 (squid3.0/10848.patch) = 777eae566843141c0419a9e9ebd54293f26cfd6f784b253f26323265985d79a9
+SIZE (squid3.0/10848.patch) = 5969
+MD5 (squid3.0/10849.patch) = 5e124e2fb799f41448ca0c01f64c5881
+SHA256 (squid3.0/10849.patch) = d2c0c854188a1a2770399d3148e82604bd43db7cd161af28d95adc28e1ab9077
+SIZE (squid3.0/10849.patch) = 2979
+MD5 (squid3.0/10850.patch) = ad526c71720022a092dba3a080631ae0
+SHA256 (squid3.0/10850.patch) = 216fc243a7b0e067328de61458001454c7f8cbc6e121886cabe001b4ed8e10d8
+SIZE (squid3.0/10850.patch) = 2908
+MD5 (squid3.0/10851.patch) = 9a9aa6920e4d13c4add02db508826d16
+SHA256 (squid3.0/10851.patch) = a8c00fa83a52ad365e09aebd45f5da90e3d04fd0ce7c866a1cdf0ca10f960077
+SIZE (squid3.0/10851.patch) = 1061
+MD5 (squid3.0/10852.patch) = 4c1886d2c1ea43465e1bfec8f3a26493
+SHA256 (squid3.0/10852.patch) = ca326d4da21b86dac1988fe6c54042e1fca6c22b5c7a927c3ca80564f35fa576
+SIZE (squid3.0/10852.patch) = 5530
+MD5 (squid3.0/10853.patch) = a2b774f2b040cf494548f8a4aaae5548
+SHA256 (squid3.0/10853.patch) = 54e3f491dbed76811873abfde14782f043cb2d5e29d9fe7ad4f2a83a63ae2838
+SIZE (squid3.0/10853.patch) = 1279
+MD5 (squid3.0/10854.patch) = f362d6cead3577ad9002876adb855204
+SHA256 (squid3.0/10854.patch) = d6b16e049b2fd333b1365ec7704114e92fc1cea2256b515f4977253f4e5ae7e0
+SIZE (squid3.0/10854.patch) = 1174
+MD5 (squid3.0/10855.patch) = 80d3d8b2cfd9186da758dcf542430bfe
+SHA256 (squid3.0/10855.patch) = f9ddfb59efdaf34a5a1952ce54c0db7516bb291cc68dd453904398022330efb9
+SIZE (squid3.0/10855.patch) = 1201
+MD5 (squid3.0/10856.patch) = ba3f49c2c18e54a1aaa02054922e7146
+SHA256 (squid3.0/10856.patch) = 98b830b1bdcf1cf874c0f25c749a803dee1d7205acb127b26758ab1967426783
+SIZE (squid3.0/10856.patch) = 4953
+MD5 (squid3.0/10857.patch) = a41c7dddbf979fda444d67aa7feec264
+SHA256 (squid3.0/10857.patch) = 6bb2cef93fe4b1a8b6e157ace00c55b9b00943e30baaa247e7be80d60107da3a
+SIZE (squid3.0/10857.patch) = 5344
+MD5 (squid3.0/10858.patch) = 99c73ebf1feec4214dc28bdfde6c32bb
+SHA256 (squid3.0/10858.patch) = 7c87c3c94d3ab2cdda301311d001d8d963e0603a96a38bf9cf80a257a53e9ace
+SIZE (squid3.0/10858.patch) = 12497
+MD5 (squid3.0/10859.patch) = ac486bbf95679ebac1312b4ed05dca09
+SHA256 (squid3.0/10859.patch) = c4b44f58f518c42de10486d5fd93f175840ea94a910f33cbe7e5bae51dbfb15f
+SIZE (squid3.0/10859.patch) = 7648
+MD5 (squid3.0/10860.patch) = 1e35cadbe1782e3dde075ee037f19346
+SHA256 (squid3.0/10860.patch) = dfdd77a030d7108037dc2f6047031a3b0c4bb9275055e5a91de3f4b4758d5cf2
+SIZE (squid3.0/10860.patch) = 1741
+MD5 (squid3.0/10861.patch) = f50c5c0bd85f9c736e22f806f5ee80d0
+SHA256 (squid3.0/10861.patch) = fcca4e89dc7dd491e8559bf269171577f199df3676efd81edee9ba96fbdb70e9
+SIZE (squid3.0/10861.patch) = 1522
+MD5 (squid3.0/10863.patch) = 4a1774a937bcaf303cd61cb896b07015
+SHA256 (squid3.0/10863.patch) = 17ab47053ade5f20622f282b05eddc2eafb57a5e357332b1984a5b353a2c46ac
+SIZE (squid3.0/10863.patch) = 398
+MD5 (squid3.0/10865.patch) = 809045dd8d8e505e5763aa0114e31743
+SHA256 (squid3.0/10865.patch) = aa5b874484011c807c61f06bba9e75943d8c689fbe7d4623a3684a848e1adf5a
+SIZE (squid3.0/10865.patch) = 2519
diff --git a/www/squid31/files/patch-src-cf.data.pre b/www/squid31/files/patch-src-cf.data.pre
index 056a513db825..f13df792fa56 100644
--- a/www/squid31/files/patch-src-cf.data.pre
+++ b/www/squid31/files/patch-src-cf.data.pre
@@ -1,5 +1,16 @@
---- src/cf.data.pre.orig Tue Apr 17 00:10:49 2007
-+++ src/cf.data.pre Thu May 17 15:13:37 2007
+--- src/cf.data.pre.orig Sun Jun 24 13:42:25 2007
++++ src/cf.data.pre Sun Jun 24 13:59:32 2007
+@@ -1417,6 +1417,10 @@
+ LOC: Config.pidFilename
+ DOC_START
+ A filename to write the process-id to. To disable, enter "none".
++
++ Note: If you change this setting, you need to set squid_pidfile
++ in /etc/rc.conf to reflect the new value. Please see
++ %%PREFIX%%/etc/rc.d/squid for details.
+ DOC_END
+
+
@@ -3047,12 +3062,12 @@
NAME: cache_effective_user
diff --git a/www/squid31/files/squid.in b/www/squid31/files/squid.in
index b173aaa2bc7f..bd9483908ae6 100644
--- a/www/squid31/files/squid.in
+++ b/www/squid31/files/squid.in
@@ -9,7 +9,7 @@
# Note:
# Set "squid_enable=yes" in either /etc/rc.conf, /etc/rc.conf.local or
# /etc/rc.conf.d/squid to make this script actually do something. There
-# you can also set squid_chdir, squid_user, and squid_flags.
+# you can also set squid_chdir, squid_pidfile, squid_user, and squid_flags.
#
# Please see squid(8), rc.conf(5) and rc(8) for further details.
#
@@ -37,12 +37,14 @@ stop_cmd="squid_stop"
load_rc_config ${name}
-squid_chdir=${squid_chdir:-%%PREFIX%%/squid/logs}
+squid_chdir=${squid_chdir:-"%%PREFIX%%/squid/logs"}
squid_enable=${squid_enable:-"NO"}
squid_flags=${squid_flags-"-D"}
+squid_pidfile=${squid_pidfile:-"%%PREFIX%%/squid/logs/squid.pid"}
squid_user=${squid_user:-%%SQUID_UID%%}
default_config=%%PREFIX%%/etc/squid/squid.conf
+pidfile=${squid_pidfile}
required_dirs=${squid_chdir}
# squid(8) will not start if ${default_config} is not present so try