aboutsummaryrefslogtreecommitdiff
path: root/www/squid
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2010-02-01 20:25:56 +0000
committerXin LI <delphij@FreeBSD.org>2010-02-01 20:25:56 +0000
commit3f1f30c23cda585563454fb498ac259e17574cae (patch)
tree38469f4408c33b32ddddfd1d7d7c94397644d922 /www/squid
parentfb1abdada31c5af07bdb7fb90f018e9199a4c85f (diff)
Notes
Diffstat (limited to 'www/squid')
-rw-r--r--www/squid/Makefile2
-rw-r--r--www/squid/files/patch-squid-advisory-2010:138
2 files changed, 39 insertions, 1 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index aa9627dd1564..c65ca4a41021 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -76,7 +76,7 @@
PORTNAME= squid
PORTVERSION= 2.7.${SQUID_STABLE_VER}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
ftp://mirrors.24-7-solutions.net/pub/squid/%SUBDIR%/ \
diff --git a/www/squid/files/patch-squid-advisory-2010:1 b/www/squid/files/patch-squid-advisory-2010:1
new file mode 100644
index 000000000000..5cb07b7d9b49
--- /dev/null
+++ b/www/squid/files/patch-squid-advisory-2010:1
@@ -0,0 +1,38 @@
+FreeBSD-Patch for Squid-Advisory 2010:1, prepared by Thomas-Martin Seck,
+<tmseck@web.de>, 2010-02-01.
+
+Removed one directory level and the first hunk with CVS meta-information
+from the original patch. The original patch can be downloaded from:
+http://www.squid-cache.org/Versions/v2/HEAD/changesets/12597.patch
+
+---------------------
+PatchSet 12597
+Date: 2010/01/15 11:40:30
+Author: amosjeffries
+Branch: HEAD
+Tag: (none)
+Log:
+Handle DNS header-only packets as invalid.
+
+Members:
+ lib/rfc1035.c:1.30->1.31
+
+Index: lib/rfc1035.c
+===================================================================
+RCS file: /cvsroot/squid/squid/lib/rfc1035.c,v
+retrieving revision 1.30
+retrieving revision 1.31
+diff -u -r1.30 -r1.31
+--- lib/rfc1035.c 15 Jun 2008 03:49:55 -0000 1.30
++++ lib/rfc1035.c 15 Jan 2010 11:40:30 -0000 1.31
+@@ -286,7 +286,9 @@
+ size_t len;
+ assert(ns > 0);
+ do {
+- assert((*off) < sz);
++ if ((*off) >= sz) {
++ return 1;
++ }
+ c = *(buf + (*off));
+ if (c > 191) {
+ /* blasted compression */