aboutsummaryrefslogtreecommitdiff
path: root/www/squid
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2004-02-02 15:28:16 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2004-02-02 15:28:16 +0000
commitf7a539c509370bcdb35ae22c811fb4818ea73697 (patch)
tree26864585702f98154de190bb516534522d2a59b6 /www/squid
parenta4c7f173ac571ad9d9f119dc5d9e9c81d205d394 (diff)
downloadports-f7a539c509370bcdb35ae22c811fb4818ea73697.tar.gz
ports-f7a539c509370bcdb35ae22c811fb4818ea73697.zip
Notes
Diffstat (limited to 'www/squid')
-rw-r--r--www/squid/Makefile155
-rw-r--r--www/squid/distinfo39
-rw-r--r--www/squid/pkg-deinstall7
-rw-r--r--www/squid/pkg-plist55
4 files changed, 140 insertions, 116 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 09977535ec08..78aacde3fc22 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -4,12 +4,7 @@
#
# $FreeBSD$
#
-# Tunables:
-# WITH_SQUID_PINGER
-# install the external icmp helper program (`pinger') for hierarchy stats and
-# selection
-# WITH_SQUID_LDAP_AUTH
-# install external modules for authentication against LDAP servers
+# Tunables not (yet) configurable via 'make config':
# SQUID_{U,G}ID
# Which user/group squid should run as (default: squid/squid).
# The user and group will be created if they do not already exist.
@@ -28,7 +23,7 @@
PORTNAME= squid
PORTVERSION= 2.5.4
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -92,7 +87,29 @@ SQUID_UID?= squid
SQUID_GID?= squid
MAN8= squid.8
-DOCS= QUICKSTART README RELEASENOTES.html doc/debug-sections.txt
+docs= QUICKSTART README RELEASENOTES.html doc/debug-sections.txt
+.if !defined(NOPORTDOCS)
+PORTDOCS= ${docs:T}
+.endif
+
+OPTIONS= SQUID_LDAP_AUTH "Install LDAP authentication helpers" off \
+ SQUID_DELAY_POOLS "Enable delay pools" off \
+ SQUID_SNMP "Enable SNMP support" off \
+ SQUID_CARP "Enable CARP support" off \
+ SQUID_SSL "Enable SSL support for reverse proxies" off \
+ SQUID_PINGER "Install the icmp helper" off \
+ SQUID_DNS_HELPER "Use the old 'dnsserver' helper" off \
+ SQUID_HTCP "Enable HTCP support" off \
+ SQUID_VIA_DB "Enable forward/via database" off \
+ SQUID_CACHE_DIGESTS "Enable cache digests" off \
+ SQUID_WCCP "Enable Web Cache Coordination Protocol" on \
+ SQUID_STRICT_HTTP "Be strictly HTTP compliant" off \
+ SQUID_IDENT "Enable ident (RFC 931) lookups" on \
+ SQUID_USERAGENT_LOG "Enable User-Agent-header logging" off
+
+PLIST_FILES= etc/rc.d/squid.sh etc/squid/mib.txt etc/squid/mime.conf.default \
+ etc/squid/msntauth.conf.default etc/squid/squid.conf.default \
+ sbin/RunAccel sbin/RunCache sbin/squidclient sbin/squid
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
--datadir=${PREFIX}/etc/squid \
@@ -102,9 +119,7 @@ CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
--enable-removal-policies="lru heap" \
--enable-underscores
-.if defined(WITH_SQUID_PINGER)
-CONFIGURE_ARGS+= --enable-icmp
-.endif
+.include <bsd.port.pre.mk>
# Authentication methods and modules:
@@ -125,6 +140,48 @@ CONFIGURE_ARGS+= --enable-auth="basic ntlm digest" \
--enable-external-acl-helpers="${external_acl}" \
--enable-ntlm-auth-helpers="SMB winbind"
+# Options set via 'make config':
+
+.if defined(WITH_SQUID_DELAY_POOLS)
+CONFIGURE_ARGS+= --enable-delay-pools
+.endif
+.if defined(WITH_SQUID_SNMP)
+CONFIGURE_ARGS+= --enable-snmp
+.endif
+.if defined(WITH_SQUID_CARP)
+CONFIGURE_ARGS+= --enable-carp
+.endif
+.if defined(WITH_SQUID_SSL)
+CONFIGURE_ARGS+= --enable-ssl
+.endif
+.if defined(WITH_SQUID_PINGER)
+CONFIGURE_ARGS+= --enable-icmp
+.endif
+.if defined(WITH_SQUID_DNS_HELPER)
+CONFIGURE_ARGS+= --disable-internal-dns
+.endif
+.if defined(WITH_SQUID_HTCP)
+CONFIGURE_ARGS+= --enable-htcp
+.endif
+.if defined(WITH_SQUID_VIA_DB)
+CONFIGURE_ARGS+= --enable-forw-via-db
+.endif
+.if defined(WITH_SQUID_CACHE_DIGESTS)
+CONFIGURE_ARGS+= --enable-cache-digests
+.endif
+.if defined(WITHOUT_SQUID_WCCP)
+CONFIGURE_ARGS+= --disable-wccp
+.endif
+.if defined(WITH_SQUID_STRICT_HTTP)
+CONFIGURE_ARGS+= --disable-http-violations
+.endif
+.if defined(WITHOUT_SQUID_IDENT)
+CONFIGURE_ARGS+= --disable-ident-lookups
+.endif
+.if defined(WITH_SQUID_USERAGENT_LOG)
+CONFIGURE_ARGS+= --enable-useragent-log
+.endif
+
# Languages:
#
# If you do not define SQUID_LANGUAGES yourself, all available language files
@@ -139,7 +196,7 @@ SQUID_DEFAULT_LANG?= English
CONFIGURE_ARGS+= --enable-err-languages="${SQUID_LANGUAGES}" \
--enable-default-err-language=${SQUID_DEFAULT_LANG}
-# Other configure options you might want to set using SQUID_CONFIGURE_ARGS:
+# Other not so common configure options you can set via SQUID_CONFIGURE_ARGS:
# Please see the configure script in the squid source distribution for a
# complete list.
#
@@ -149,43 +206,10 @@ CONFIGURE_ARGS+= --enable-err-languages="${SQUID_LANGUAGES}" \
# Compile and use the supplied GNUregex routines instead of BSD regex.
# --enable-xmalloc-statistics
# Show malloc statistics in status page
-# --enable-carp
-# Enable CARP support
-# --enable-delay-pools
-# Enable delay pools to limit bandwidth usage
-# --enable-useragent-log
-# Enable logging of the User-Agent header
-# --disable-wccp
-# Disable Web Cache Coordination Protocol
-# --enable-snmp
-# Turn on SNMP server support
-# --enable-ssl
-# Turn on SSL server support for reverse proxies
# --enable-time-hack
# Optimize time updates to one per second rather than calling gettimeofday()
# --enable-cachemgr-hostname=some.hostname
# Set an explicit hostname in cachemgr.cgi
-# --enable-arp-acl
-# Enable ACL based on ethernet address (eg: for machines with dynamic DHCP
-# assigned IP addresses)
-# --enable-htcp
-# Enable HTCP protocol
-# --enable-forw-via-db
-# Enable Forw/Via database
-# --enable-cache-digests
-# Use Cache Digests - see http://www.squid-cache.org/Doc/FAQ/FAQ-16.html
-# --disable-http-violations
-# Strict HTTP compliance
-# --enable-ipf-transparent
-# Enable Transparent Proxy support for IP-Filter systems (incl 3.0)
-# (Note: this is currently broken due to ipf headers not being installed to
-# the base system, see PRs ports/60700 and misc/44148 for details)
-# Note: see http://www.squid-cache.org/Doc/FAQ/FAQ-17.html for information
-# about how to do transparent proxying with ipfw(8).
-# --disable-ident-lookups
-# Compile out code that does optional Ident (RFC931) lookups
-# --disable-internal-dns
-# Install the old external "dnsserver" binary
# --enable-truncate
# Use truncate() rather than unlink()
# --disable-hostname-checks
@@ -198,6 +222,18 @@ CONFIGURE_ARGS+= --enable-err-languages="${SQUID_LANGUAGES}" \
# Do not use "unlinkd"
# --enable-stacktraces
# Enable automatic call backtrace on fatal errors
+#
+# These options do not yet work on FreeBSD:
+#
+# --enable-arp-acl
+# Enable ACL based on ethernet address (eg: for machines with dynamic DHCP
+# assigned IP addresses)
+# --enable-ipf-transparent
+# Enable Transparent Proxy support for IP-Filter systems (incl 3.0)
+# (IPFilter headers are not currently installed to the base system,
+# PRs ports/60700 and misc/44148 describe the problem; see
+# http://www.squid-cache.org/Doc/FAQ/FAQ-17.html for information
+# about how to do transparent proxying with ipfw)
CONFIGURE_ARGS+= ${SQUID_CONFIGURE_ARGS}
@@ -229,29 +265,28 @@ post-install:
${INSTALL_SCRIPT} ${WRKDIR}/squid.sh ${PREFIX}/etc/rc.d
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${docs} ${DOCSDIR}
.endif
-.if exists(${PREFIX}/etc/squid/errors/Lithuanian)
# Work around the fact that the errorpages.patch creates files in
# an "Attic" subdir:
+.if exists(${PREFIX}/etc/squid/errors/Lithuanian)
@${FIND} ${WRKSRC}/errors/Lithuanian/Attic -type f \
-exec ${INSTALL_DATA} {} ${PREFIX}/etc/squid/errors/Lithuanian/ \;
.endif
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-# Generate parts of pkg-plist on the fly:
- @cd ${PREFIX} && ${FIND} libexec/squid -type f -o -type l | sort \
- >${WRKDIR}/plist.dynamic
- @${ECHO_CMD} "@dirrm libexec/squid" >>${WRKDIR}/plist.dynamic
-# Only register what we should have installed, there may be local additions
-# present:
+# Create package list:
+ @cd ${PREFIX} && ${FIND} libexec/squid -type f -o -type l | ${SORT} \
+ >>${TMPPLIST}
+ @${ECHO_CMD} "@dirrm libexec/squid" >>${TMPPLIST}
+ @cd ${PREFIX} && ${FIND} etc/squid/icons -type f -o -type l | ${SORT} \
+ >>${TMPPLIST}
+ @${ECHO_CMD} "@dirrm etc/squid/icons" >>${TMPPLIST}
.for d in ${SQUID_LANGUAGES}
- @cd ${PREFIX} && ${FIND} etc/squid/errors/${d} -type f | sort \
- >>${WRKDIR}/plist.dynamic
- @${ECHO_CMD} "@dirrm etc/squid/errors/${d}" >>${WRKDIR}/plist.dynamic
+ @cd ${PREFIX} && ${FIND} etc/squid/errors/${d} -type f | ${SORT} \
+ >>${TMPPLIST}
+ @${ECHO_CMD} "@dirrm etc/squid/errors/${d}" >>${TMPPLIST}
.endfor
- @${REINPLACE_CMD} -e \
- '/@comment Start of dynamically generated plist/r${WRKDIR}/plist.dynamic' \
- ${TMPPLIST}
+ @${ECHO_CMD} "@dirrm etc/squid/errors" >>${TMPPLIST}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/squid/distinfo b/www/squid/distinfo
index 65281d4cab47..928dbafc99c2 100644
--- a/www/squid/distinfo
+++ b/www/squid/distinfo
@@ -1,37 +1,74 @@
MD5 (squid2.5/squid-2.5.STABLE4.tar.bz2) = 9894a1fe855b0cccdc14fbf014060990
+SIZE (squid2.5/squid-2.5.STABLE4.tar.bz2) = 1036704
MD5 (squid2.5/squid-2.5.STABLE4-reconfigure_message.patch) = a746143deab8b609730660916a297618
+SIZE (squid2.5/squid-2.5.STABLE4-reconfigure_message.patch) = 760
MD5 (squid2.5/squid-2.5.STABLE4-digest_auth_pwchange.patch) = e5020f5b87a92c4d9621ce25403d691b
+SIZE (squid2.5/squid-2.5.STABLE4-digest_auth_pwchange.patch) = 2694
MD5 (squid2.5/squid-2.5.STABLE4-redirect_login_space.patch) = 2374ed6dae7ef57c009e2428284d6b65
+SIZE (squid2.5/squid-2.5.STABLE4-redirect_login_space.patch) = 619
MD5 (squid2.5/squid-2.5.STABLE4-fqdnnegcache.patch) = ae1b7cce41ca403ebd7115d4506b0c25
+SIZE (squid2.5/squid-2.5.STABLE4-fqdnnegcache.patch) = 701
MD5 (squid2.5/pam_auth-2.2.patch) = 3037a67d8f4b85cd7d51cb2dd5b4e8b8
+SIZE (squid2.5/pam_auth-2.2.patch) = 4878
MD5 (squid2.5/squid-2.5.STABLE4_auth_param_doc.patch) = 3b35c424db58c71c541563cd5ae39d15
+SIZE (squid2.5/squid-2.5.STABLE4_auth_param_doc.patch) = 9068
MD5 (squid2.5/squid-2.5.STABLE4-errorpages.patch) = cd2afde3f233df8ab8015e045f304ee7
+SIZE (squid2.5/squid-2.5.STABLE4-errorpages.patch) = 49938
MD5 (squid2.5/squid-2.5.STABLE4-error_load_text.patch) = 3935a3005d125f55cd78b228eba20647
+SIZE (squid2.5/squid-2.5.STABLE4-error_load_text.patch) = 571
MD5 (squid2.5/squid-2.5.STABLE4-xpi_mime.patch) = 1143fb9244690a24450c3c9ce6105da4
+SIZE (squid2.5/squid-2.5.STABLE4-xpi_mime.patch) = 601
MD5 (squid2.5/squid-2.5.STABLE4-size_overflow.patch) = 7cd2d6b1ebbd86aa143fa5a57156d6ce
+SIZE (squid2.5/squid-2.5.STABLE4-size_overflow.patch) = 438
MD5 (squid2.5/squid-2.5.STABLE4-extacl_auth_loop.patch) = de06bbc89f5408b7ab83733d894d4fe7
+SIZE (squid2.5/squid-2.5.STABLE4-extacl_auth_loop.patch) = 756
MD5 (squid2.5/squid-2.5.STABLE4-squid_ldap_group.patch) = a5d0a8730aacf129401aabdfa61d60f7
+SIZE (squid2.5/squid-2.5.STABLE4-squid_ldap_group.patch) = 30490
MD5 (squid2.5/squid-2.5.STABLE4-positive_dns_ttl.patch) = 7fca4475d86acc7db242c261b08751d7
+SIZE (squid2.5/squid-2.5.STABLE4-positive_dns_ttl.patch) = 3409
MD5 (squid2.5/squid-2.5.STABLE4-gopherhtml.patch) = 2c6c50a4a8f4d0d0017ab7c15bacfe26
+SIZE (squid2.5/squid-2.5.STABLE4-gopherhtml.patch) = 3382
MD5 (squid2.5/squid-2.5.STABLE4-netroute.patch) = f83e66712f37f34a04571b31be6c2db8
+SIZE (squid2.5/squid-2.5.STABLE4-netroute.patch) = 592
MD5 (squid2.5/squid-2.5.STABLE4-synflood.patch) = b92e7a56e87374ebf2eb50e044f07f6d
+SIZE (squid2.5/squid-2.5.STABLE4-synflood.patch) = 12861
MD5 (squid2.5/squid-2.5.STABLE4-fqdn.patch) = dbf2c020e3c3c52ae540d96a724fac87
+SIZE (squid2.5/squid-2.5.STABLE4-fqdn.patch) = 713
MD5 (squid2.5/squid-2.5.STABLE4-connect_cleanup.patch) = ee0398f51a22ab2c82048c8935d6d11c
+SIZE (squid2.5/squid-2.5.STABLE4-connect_cleanup.patch) = 32516
MD5 (squid2.5/squid-2.5.STABLE4-pconn_post.patch) = 4a5b7ab04fe8b73906db441448534bbb
+SIZE (squid2.5/squid-2.5.STABLE4-pconn_post.patch) = 1231
MD5 (squid2.5/squid-2.5.STABLE4-ftp_put.patch) = d3b69c8e79c96c13005d6dbeb72e5c76
+SIZE (squid2.5/squid-2.5.STABLE4-ftp_put.patch) = 584
MD5 (squid2.5/squid-2.5.STABLE4-pconn-load.patch) = a432f9eff9e0963b7338e41a91230d95
+SIZE (squid2.5/squid-2.5.STABLE4-pconn-load.patch) = 2397
MD5 (squid2.5/squid-2.5.STABLE4-icon_urls.patch) = cf28143216b1364e56e820dddbb66dfc
+SIZE (squid2.5/squid-2.5.STABLE4-icon_urls.patch) = 2399
MD5 (squid2.5/squid-2.5.STABLE4-redirector_access.patch) = 9c534a3d58fe0e3545cd4ed9af92a0e8
+SIZE (squid2.5/squid-2.5.STABLE4-redirector_access.patch) = 3498
MD5 (squid2.5/squid-2.5.STABLE4-pconn-lifo.patch) = f41051c248764749d9d9ca5704925da7
+SIZE (squid2.5/squid-2.5.STABLE4-pconn-lifo.patch) = 1350
MD5 (squid2.5/squid-2.5.STABLE4-cache_peer_maxconn.patch) = efd99c5e2f526c08cb52d9af948c7b25
+SIZE (squid2.5/squid-2.5.STABLE4-cache_peer_maxconn.patch) = 3603
MD5 (squid2.5/squid-2.5.STABLE4-pid_filename_none.patch) = 808bafa144b22c3cf6900759b30f39e6
+SIZE (squid2.5/squid-2.5.STABLE4-pid_filename_none.patch) = 508
MD5 (squid2.5/squid-2.5.STABLE4-dns_namelength.patch) = 290da300d02124be3971282d5b0a799d
+SIZE (squid2.5/squid-2.5.STABLE4-dns_namelength.patch) = 603
MD5 (squid2.5/squid-2.5.STABLE4-urllogin_acl.patch) = 5ad09d7d4bf105e699cfeb647a4836a3
+SIZE (squid2.5/squid-2.5.STABLE4-urllogin_acl.patch) = 3064
MD5 (squid2.5/squid-2.5.STABLE4-russian.patch) = 5a4357bd56134fc6578c435314c1a835
+SIZE (squid2.5/squid-2.5.STABLE4-russian.patch) = 20731
MD5 (squid2.5/squid-2.5.STABLE4-redirlog.patch) = 8a2cc15f2bde6fa263a9e40aae807f82
+SIZE (squid2.5/squid-2.5.STABLE4-redirlog.patch) = 762
MD5 (squid2.5/squid-2.5.STABLE4-pinger.patch) = 0902849d051873aaf5f54584d0536bb5
+SIZE (squid2.5/squid-2.5.STABLE4-pinger.patch) = 738
MD5 (squid2.5/squid-2.5.STABLE4-partial_reload.patch) = 6d8fa663f46ffc2272b7d18a0b6eea34
+SIZE (squid2.5/squid-2.5.STABLE4-partial_reload.patch) = 751
MD5 (squid2.5/squid-2.5.STABLE4-ldap_tls.patch) = dcd6b4ec46e252833a54c4bfd155c284
+SIZE (squid2.5/squid-2.5.STABLE4-ldap_tls.patch) = 1853
MD5 (squid2.5/squid-2.5.STABLE4-ldap_group_bufsize.patch) = e42207a45232ca739a64f2ac3901263c
-MD5 (squid2.5/squid-2.5.STABLE4-http_workarounds.patch) = 8f878211b6df9045ff3fb10a6e14fc36
+SIZE (squid2.5/squid-2.5.STABLE4-ldap_group_bufsize.patch) = 762
+MD5 (squid2.5/squid-2.5.STABLE4-http_workarounds.patch) = 77d1a43dffa7aa97eb39b9178689e8df
+SIZE (squid2.5/squid-2.5.STABLE4-http_workarounds.patch) = 12322
MD5 (squid2.5/squid-2.5.STABLE4-empty_proxy_auth.patch) = ff55a2c7a718868ad245fd6de07018c9
+SIZE (squid2.5/squid-2.5.STABLE4-empty_proxy_auth.patch) = 2719
diff --git a/www/squid/pkg-deinstall b/www/squid/pkg-deinstall
index 3a95b4f50e0d..7de2277d4352 100644
--- a/www/squid/pkg-deinstall
+++ b/www/squid/pkg-deinstall
@@ -8,8 +8,15 @@ pkgname=$1
case $2 in
DEINSTALL)
+ cd ${PKG_PREFIX}/etc/squid || exit 1
+ for f in squid.conf mime.conf msntauth.conf; do
+ cmp -s -z ${f} ${f}.default && rm ${f}
+ done
;;
POST-DEINSTALL)
+ rmdir ${PKG_PREFIX}/etc/squid 2>/dev/null
+ rmdir ${PKG_PREFIX}/squid/cache 2>/dev/null
+ rmdir -p ${PKG_PREFIX}/squid/logs 2>/dev/null
echo "===> post-deinstallation information for ${pkgname}"
echo ""
echo " Please note that ${pkgname} was not completely removed"
diff --git a/www/squid/pkg-plist b/www/squid/pkg-plist
deleted file mode 100644
index f04c2fc92436..000000000000
--- a/www/squid/pkg-plist
+++ /dev/null
@@ -1,55 +0,0 @@
-@comment $FreeBSD$
-etc/rc.d/squid.sh
-etc/squid/mib.txt
-@unexec if cmp -s %D/etc/squid/mime.conf %D/etc/squid/mime.conf.default; then rm -f %D/etc/squid/mime.conf; fi
-etc/squid/mime.conf.default
-@unexec if cmp -s %D/etc/squid/msntauth.conf %D/etc/squid/msntauth.conf.default; then rm -f %D/etc/squid/msntauth.conf; fi
-etc/squid/msntauth.conf.default
-@unexec if cmp -s %D/etc/squid/squid.conf %D/etc/squid/squid.conf.default; then rm -f %D/etc/squid/squid.conf; fi
-etc/squid/squid.conf.default
-etc/squid/icons/anthony-binhex.gif
-etc/squid/icons/anthony-bomb.gif
-etc/squid/icons/anthony-box.gif
-etc/squid/icons/anthony-box2.gif
-etc/squid/icons/anthony-c.gif
-etc/squid/icons/anthony-compressed.gif
-etc/squid/icons/anthony-dir.gif
-etc/squid/icons/anthony-dirup.gif
-etc/squid/icons/anthony-dvi.gif
-etc/squid/icons/anthony-f.gif
-etc/squid/icons/anthony-image.gif
-etc/squid/icons/anthony-image2.gif
-etc/squid/icons/anthony-layout.gif
-etc/squid/icons/anthony-link.gif
-etc/squid/icons/anthony-movie.gif
-etc/squid/icons/anthony-pdf.gif
-etc/squid/icons/anthony-portal.gif
-etc/squid/icons/anthony-ps.gif
-etc/squid/icons/anthony-quill.gif
-etc/squid/icons/anthony-script.gif
-etc/squid/icons/anthony-sound.gif
-etc/squid/icons/anthony-tar.gif
-etc/squid/icons/anthony-tex.gif
-etc/squid/icons/anthony-text.gif
-etc/squid/icons/anthony-unknown.gif
-etc/squid/icons/anthony-xbm.gif
-etc/squid/icons/anthony-xpm.gif
-sbin/RunAccel
-sbin/RunCache
-sbin/squidclient
-sbin/squid
-%%PORTDOCS%%%%DOCSDIR%%/QUICKSTART
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/RELEASENOTES.html
-%%PORTDOCS%%%%DOCSDIR%%/debug-sections.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@comment Start of dynamically generated plist
-@comment End of dynamically generated plist
-@comment These directories are maybe not empty at deinstallation time.
-@comment Since we try to preserve the data in there for updates anyway, be quiet.
-@unexec rmdir %D/etc/squid/icons 2>/dev/null || true
-@unexec rmdir %D/etc/squid/errors 2>/dev/null || true
-@unexec rmdir %D/etc/squid 2>/dev/null || true
-@unexec rmdir %D/squid/logs 2>/dev/null || true
-@unexec rmdir %D/squid/cache 2>/dev/null || true
-@unexec rmdir %D/squid 2>/dev/null || true