aboutsummaryrefslogtreecommitdiff
path: root/www/squid
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-31 22:20:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-31 22:20:42 +0000
commit92531c1b9e19748331bd9a0cbc116e2e6cdbadd6 (patch)
tree1e76cb8ce774e1450aac8c670c3095c89ad8c493 /www/squid
parentfd1a1ba16500bda2419bb0f643fe77ee3dcd9d30 (diff)
Notes
Diffstat (limited to 'www/squid')
-rw-r--r--www/squid/Makefile1
-rw-r--r--www/squid/files/patch-squid_kerb_auth22
2 files changed, 23 insertions, 0 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 7b83aab36862..cb99077a6395 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -76,6 +76,7 @@
PORTNAME= squid
PORTVERSION= 2.7.${SQUID_STABLE_VER}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
ftp://mirrors.24-7-solutions.net/pub/squid/%SUBDIR%/ \
diff --git a/www/squid/files/patch-squid_kerb_auth b/www/squid/files/patch-squid_kerb_auth
index 6b9a57b8caf3..2dd3353b6e05 100644
--- a/www/squid/files/patch-squid_kerb_auth
+++ b/www/squid/files/patch-squid_kerb_auth
@@ -557,3 +557,25 @@ ports framework where Heimdal is part of the base system.
#define gss_nt_service_name GSS_C_NT_HOSTBASED_SERVICE
#else
#include <gssapi/gssapi.h>
+--- helpers/negotiate_auth/squid_kerb_auth/spnegohelp/derparse.c.orig 2007-05-15 01:36:32.000000000 +0200
++++ helpers/negotiate_auth/squid_kerb_auth/spnegohelp/derparse.c 2009-03-28 17:21:54.000000000 +0100
+@@ -22,12 +22,19 @@
+ //
+ /////////////////////////////////////////////////////////////
+
++#include "config.h"
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <memory.h>
+ #include "spnego.h"
+ #include "derparse.h"
+
++#ifdef WORDS_BIGENDIAN
++#undef __LITTLE_ENDIAN__
++#else
++#define __LITTLE_ENDIAN__ 1
++#endif
++
+ //
+ // The GSS Mechanism OID enumeration values (SPNEGO_MECH_OID) control which offset in
+ // the array below, that a mechanism can be found.