aboutsummaryrefslogtreecommitdiff
path: root/www/squidguard
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-10-17 18:10:17 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-10-17 18:10:17 +0000
commit24054fc9d012a3b49e7097f65504572b26084b30 (patch)
treef756434ff30095383773fa3a3a71728eb167d861 /www/squidguard
parent3a4b73bc2bd9b54050acfa8c9cd76210fa70209c (diff)
downloadports-24054fc9d012a3b49e7097f65504572b26084b30.tar.gz
ports-24054fc9d012a3b49e7097f65504572b26084b30.zip
Notes
Diffstat (limited to 'www/squidguard')
-rw-r--r--www/squidguard/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/www/squidguard/Makefile b/www/squidguard/Makefile
index 71b7a7306967..a944085eda69 100644
--- a/www/squidguard/Makefile
+++ b/www/squidguard/Makefile
@@ -19,13 +19,13 @@ COMMENT= A fast redirector for squid
LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
RUN_DEPENDS= ${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid
-USE_SIZE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --with-db-inc=${LOCALBASE}/include/db3 \
--with-db-lib=${LOCALBASE}/lib \
--with-sg-config=${PREFIX}/etc/squid/${PORTNAME}.conf \
--with-sg-dbhome=${DATADIR} \
- --with-sg-logdir=${LOGDIR}
+ --with-sg-logdir=${LOGDIR} \
+ --exec-prefix=${PREFIX}
CFGINPUT= files/sgcfg.in
@@ -52,7 +52,7 @@ pre-install:
.if !exists(${DATADIR})
@${ECHO_MSG} "===> Installing blacklists"
- @${MKDIR} -p ${DATADIR}
+ @${MKDIR} ${DATADIR}
@${TAR} -C ${DATADIR} --exclude *.diff -pxzf ${WRKSRC}/samples/dest/blacklists.tar.gz
@${MV} -f ${DATADIR}/blacklists/README ${WRKDIR}/README.blacklists
@${MV} -f ${DATADIR}/blacklists/* ${DATADIR}/
@@ -109,14 +109,14 @@ post-install:
.if !defined(NOPORTDOCS)
@${ECHO_MSG} "===> Installing ${PORTNAME} documentation"
- -@${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+ -@${MKDIR} ${DOCSDIR}
.for i in ${WRKSRC}/doc/*.txt ${WRKSRC}/doc/*.html ${WRKSRC}/doc/*.gif ${WRKSRC}/doc/README
- @${INSTALL_DATA} ${WRKSRC}$i ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}$i ${DOCSDIR}
.endfor
@if [ -f ${WRKDIR}/README.blacklists ] ; then \
- ${INSTALL_DATA} ${WRKDIR}/README.blacklists ${PREFIX}/share/doc/${PORTNAME} ; \
+ ${INSTALL_DATA} ${WRKDIR}/README.blacklists ${DOCSDIR} ; \
fi
- @${ECHO_MSG} " -> Documentation installed in: ${PREFIX}/share/doc/${PORTNAME}"
+ @${ECHO_MSG} " -> Documentation installed in: ${DOCSDIR}"
.endif
.if !exists(${LOGDIR})