aboutsummaryrefslogtreecommitdiff
path: root/www/squirm
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-01 15:16:20 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-01 15:16:20 +0000
commitd189711492ee2f9e5ac5bb79c2a064c0c52a37a0 (patch)
treeb95203d57042cdc6931c49a43594693c73949c48 /www/squirm
parent33f0d398586be3bd82da2fe66040c2dcc057750c (diff)
- Update to 1.2.6 [1]
- Fix patch files to match new source [1] - Change logic in Makefile to use the SQUID_UID and SQUID_GID defaults that the squid port uses, remove the need to specify the uid/gid, but inform the user that the defaults are used. (remove the NO_PACKAGE block) [1] - Rename patches to reflect which files are patched PR: ports/85215 Submitted by: Phil Kernick <philk@rotfl.com.au> Reviewed by: Chris Larsen <darth@vader.dk> [1]
Notes
Notes: svn path=/head/; revision=141714
Diffstat (limited to 'www/squirm')
-rw-r--r--www/squirm/Makefile22
-rw-r--r--www/squirm/distinfo4
-rw-r--r--www/squirm/files/patch-Makefile (renamed from www/squirm/files/patch-aa)0
-rw-r--r--www/squirm/files/patch-ac29
-rw-r--r--www/squirm/files/patch-config.c11
-rw-r--r--www/squirm/files/patch-paths.h (renamed from www/squirm/files/patch-ab)10
-rw-r--r--www/squirm/files/patch-squirm.conf.dist (renamed from www/squirm/files/patch-ad)0
7 files changed, 29 insertions, 47 deletions
diff --git a/www/squirm/Makefile b/www/squirm/Makefile
index de1cd3983680..badaf849cdc4 100644
--- a/www/squirm/Makefile
+++ b/www/squirm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= squirm
-PORTVERSION= 1.23
-PORTREVISION= 2
+PORTVERSION= 1.26
CATEGORIES= www
MASTER_SITES= http://squirm.foote.com.au/
EXTRACT_SUFX= .tgz
@@ -17,30 +16,31 @@ COMMENT= A fast & configurable redirector for the Squid
RUN_DEPENDS= ${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid
-NO_PACKAGE= must set SQUID_UID and SQUID_GID before building
+SQUID_UID?= squid
+SQUID_GID?= squid
MAKE_ENV+= SQUID_UID=${SQUID_UID} SQUID_GID=${SQUID_GID}
PLIST_SUB= SQUID_UID=${SQUID_UID} SQUID_GID=${SQUID_GID}
pre-install:
-.if defined(SQUID_UID) && defined(SQUID_GID)
.if (${SQUID_UID} == "nobody") || (${SQUID_GID} == "nogroup")
@${ECHO_MSG}
@${ECHO_MSG} 'WARNING! You are going to install squirm files with either nobody owner or'
@${ECHO_MSG} 'nogroup group, which may be insecure.'
@${ECHO_MSG}
.endif
-.else
+post-install:
@${ECHO_MSG}
- @${ECHO_MSG} 'You should set SQUID_UID and SQUID_GID variables to your squid effective'
- @${ECHO_MSG} 'user/group. For example: SQUID_UID=squid SQUID_GID=squid.'
+.if (${SQUID_UID} == "squid") && (${SQUID_GID} == "squid")
@${ECHO_MSG}
- @${FALSE}
-.endif
-
-post-install:
+ @${ECHO_MSG} 'INFO: Your SQUID_UID and SQUID_GID variables are set to the default'
+ @${ECHO_MSG} ' squid user/group: SQUID_UID = ${SQUID_UID} SQUID_GID = ${SQUID_GID}'
+ @${ECHO_MSG} ' These values are used by the www/squid port. They must match what you have chosen'
+ @${ECHO_MSG} ' for the www/squid port. If you are using different UID/GID they must match,'
+ @${ECHO_MSG} ' or else you are asking for problems !'
@${ECHO_MSG}
+.endif
@${ECHO_MSG} ' +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++'
@${ECHO_MSG} ' You have to manually add "redirect_program ${PREFIX}/bin/squirm"'
@${ECHO_MSG} ' into your squid.conf file.'
diff --git a/www/squirm/distinfo b/www/squirm/distinfo
index d04ee8ccc0a8..9c433528a640 100644
--- a/www/squirm/distinfo
+++ b/www/squirm/distinfo
@@ -1,2 +1,2 @@
-MD5 (squirm-1.23.tgz) = aedcaab22ca3ae0c8440bd0ef9d6e75e
-SIZE (squirm-1.23.tgz) = 43151
+MD5 (squirm-1.26.tgz) = 54ac1d208620ec1e4419f97315d38848
+SIZE (squirm-1.26.tgz) = 24151
diff --git a/www/squirm/files/patch-aa b/www/squirm/files/patch-Makefile
index 756e066b3510..756e066b3510 100644
--- a/www/squirm/files/patch-aa
+++ b/www/squirm/files/patch-Makefile
diff --git a/www/squirm/files/patch-ac b/www/squirm/files/patch-ac
deleted file mode 100644
index b30d9eac669a..000000000000
--- a/www/squirm/files/patch-ac
+++ /dev/null
@@ -1,29 +0,0 @@
-
-$FreeBSD$
-
---- config.c.orig Fri Mar 31 08:08:04 2000
-+++ config.c Wed Nov 7 22:23:27 2001
-@@ -277,7 +277,7 @@
- return 0;
- }
-
-- fq_pattern_filename = gen_fq_name(pattern_filename, "etc/");
-+ fq_pattern_filename = gen_fq_name(pattern_filename, "etc/squirm/");
- if (fq_pattern_filename == NULL) {
- log(LOG_ERROR, "couldn't allocate memory in parse_squirm_conf()\n");
- dodo_mode = 1;
-@@ -304,11 +304,11 @@
- }
- else if (strncasecmp(tmp1,"post", min(strlen("post"), strlen(tmp1))) == 0) {
- methods |= POST;
-- tmp1 += strlen("get");
-+ tmp1 += strlen("post");
- }
- else if (strncasecmp(tmp1, "head", min(strlen("head"), strlen(tmp1))) == 0) {
-- methods |= GET;
-- tmp1 += strlen("get");
-+ methods |= HEAD;
-+ tmp1 += strlen("head");
- }
- else if (strncasecmp(tmp1, "all", min(strlen("all"), strlen(tmp1))) == 0) {
- methods |= ALL;
diff --git a/www/squirm/files/patch-config.c b/www/squirm/files/patch-config.c
new file mode 100644
index 000000000000..ceb10070cbf0
--- /dev/null
+++ b/www/squirm/files/patch-config.c
@@ -0,0 +1,11 @@
+--- config.c.org Tue Aug 30 21:19:29 2005
++++ config.c Tue Aug 30 21:21:10 2005
+@@ -273,7 +273,7 @@
+ return 0;
+ }
+
+- fq_pattern_filename = gen_fq_name(pattern_filename, "etc/");
++ fq_pattern_filename = gen_fq_name(pattern_filename, "etc/squirm/");
+ if (fq_pattern_filename == NULL) {
+ logprint(LOG_ERROR, "couldn't allocate memory in parse_squirm_conf()\n");
+ dodo_mode = 1;
diff --git a/www/squirm/files/patch-ab b/www/squirm/files/patch-paths.h
index 28cc6512cf66..a2bb51c737a3 100644
--- a/www/squirm/files/patch-ab
+++ b/www/squirm/files/patch-paths.h
@@ -1,6 +1,6 @@
---- ../squirm-1.23.orig/paths.h Fri Mar 31 08:08:43 2000
-+++ paths.h Wed Jun 7 10:26:23 2000
-@@ -17,14 +17,14 @@
+--- paths.h.org Tue Aug 30 21:14:48 2005
++++ paths.h Tue Aug 30 21:15:40 2005
+@@ -37,14 +37,14 @@
/************* Log File Locations (must be writable by **********/
/************* the user given in the squid.conf file **********/
@@ -9,13 +9,13 @@
-#define LOG_ERROR PREFIX"/logs/squirm.error"
-#define LOG_WHERE PREFIX"/logs/squirm.where"
-#define LOG_DEBUG PREFIX"/logs/squirm.debug"
--#define LOG_INFO PREFIX"/logs/squirm.info"
+-#define LOG_INFO PREFIX"/logs/squirm.info"
+#define LOG_MATCH PREFIX"/squirm/logs/squirm.match"
+#define LOG_FAIL PREFIX"/squirm/logs/squirm.fail"
+#define LOG_ERROR PREFIX"/squirm/logs/squirm.error"
+#define LOG_WHERE PREFIX"/squirm/logs/squirm.where"
+#define LOG_DEBUG PREFIX"/squirm/logs/squirm.debug"
-+#define LOG_INFO PREFIX"/squirm/logs/squirm.info"
++#define LOG_INFO PREFIX"/squirm/logs/squirm.info"
/************* Configuration file locations ***********/
-#define SQUIRM_CONF PREFIX"/etc/squirm.conf"
diff --git a/www/squirm/files/patch-ad b/www/squirm/files/patch-squirm.conf.dist
index 15fecee0f648..15fecee0f648 100644
--- a/www/squirm/files/patch-ad
+++ b/www/squirm/files/patch-squirm.conf.dist