aboutsummaryrefslogtreecommitdiff
path: root/www/srg
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2004-07-06 12:25:14 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2004-07-06 12:25:14 +0000
commit4e3013cd8d46bc12b506ff9bfcb16ae14bc6cad1 (patch)
treeb9af8c41797c1be06da373462bd37d8e9c91e5e3 /www/srg
parent04b79bac0a76e883145f4a18affeb9d6370a520d (diff)
downloadports-4e3013cd8d46bc12b506ff9bfcb16ae14bc6cad1.tar.gz
ports-4e3013cd8d46bc12b506ff9bfcb16ae14bc6cad1.zip
Notes
Diffstat (limited to 'www/srg')
-rw-r--r--www/srg/Makefile9
-rw-r--r--www/srg/files/patch-resolver-test-cpp24
2 files changed, 23 insertions, 10 deletions
diff --git a/www/srg/Makefile b/www/srg/Makefile
index 6d5fe70c4695..f87e06e2e311 100644
--- a/www/srg/Makefile
+++ b/www/srg/Makefile
@@ -7,6 +7,7 @@
PORTNAME= srg
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://mirror.crc.net.nz/pub/srg/
@@ -30,12 +31,6 @@ PLIST_FILES+= share/examples/srg/${i}
.endfor
PLIST_DIRS= share/examples/srg
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= "Fails self-tests on sparc64"
-.endif
-
post-patch:
${REINPLACE_CMD} -e 's|-g |${CFLAGS} ${CPPFLAGS} |' ${WRKSRC}/Makefile \
${WRKSRC}/lib/Makefile
@@ -46,4 +41,4 @@ do-install:
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/srg/files/patch-resolver-test-cpp b/www/srg/files/patch-resolver-test-cpp
index 13adeeb83f24..c4053d39c2cb 100644
--- a/www/srg/files/patch-resolver-test-cpp
+++ b/www/srg/files/patch-resolver-test-cpp
@@ -1,6 +1,24 @@
---- resolver-test.cpp.orig Mon Jun 28 21:06:59 2004
-+++ resolver-test.cpp Mon Jun 28 21:08:30 2004
-@@ -32,16 +32,16 @@
+--- resolver-test.cpp.orig Mon Jun 7 08:37:17 2004
++++ resolver-test.cpp Tue Jul 6 16:16:12 2004
+@@ -1,12 +1,15 @@
+-#include "resolver.hh"
++#include <sys/param.h>
++
+ #include <assert.h>
++
++#include "resolver.hh"
+ /*
+ Originally Written by John MacPherson <jrm21@cs.waikato.ac.nz>
+
+ */
+
+ // grrr... stupid intel little endian!
+-#define dottedquad(a,b,c,d) (a) + (b << 8) + (c << 16) + (d << 24);
++#define dottedquad(a,b,c,d) htonl((d) + (c << 8) + (b << 16) + (a << 24));
+
+ int main(void) {
+
+@@ -32,16 +35,16 @@
}
/* Use Root Servers because they are unlikey to change IP */