aboutsummaryrefslogtreecommitdiff
path: root/www/srg
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2004-07-01 08:30:35 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2004-07-01 08:30:35 +0000
commitfc66779d4838bd15d13f11fbd052926902196b56 (patch)
tree2d2f462438b38f559596cde6f15d99d6905ec039 /www/srg
parent6d3a39a1916fa2ba808dc0620b0f9a8213239f5d (diff)
downloadports-fc66779d4838bd15d13f11fbd052926902196b56.tar.gz
ports-fc66779d4838bd15d13f11fbd052926902196b56.zip
Notes
Diffstat (limited to 'www/srg')
-rw-r--r--www/srg/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/www/srg/Makefile b/www/srg/Makefile
index a6647ace872b..90a8a632d160 100644
--- a/www/srg/Makefile
+++ b/www/srg/Makefile
@@ -19,8 +19,10 @@ USE_GMAKE= yes
USE_BISON= yes
USE_BZIP2= yes
USE_REINPLACE= yes
+USE_GETOPT_LONG=yes
NO_INSTALL_MANPAGES= yes
-MAKE_ENV= CC="${CC}" CXX="${CXX}"
+MAKE_ENV= CC="${CC}" CXX="${CXX}" \
+ CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
PLIST_FILES= bin/srg
.for i in footer.php header.php ip2user.txt srg.conf
@@ -29,8 +31,9 @@ PLIST_FILES+= share/examples/srg/${i}
PLIST_DIRS= share/examples/srg
post-patch:
- ${REINPLACE_CMD} -e 's|-g |${CFLAGS} |' ${WRKSRC}/Makefile \
+ ${REINPLACE_CMD} -e 's|-g |${CFLAGS} ${CPPFLAGS} |' ${WRKSRC}/Makefile \
${WRKSRC}/lib/Makefile
+ ${REINPLACE_CMD} -e 's|^\(LDFLAGS\)=|\1+=|' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/srg ${PREFIX}/bin