aboutsummaryrefslogtreecommitdiff
path: root/www/subsonic
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2011-08-18 18:35:56 +0000
committerRene Ladan <rene@FreeBSD.org>2011-08-18 18:35:56 +0000
commit08e4118191934e39a0e06468d08484332d0eb5e1 (patch)
tree783b0290063a9106348368ede3af318b53086755 /www/subsonic
parentce5e11049cee26e79b713fd3ecada3d12cc296ec (diff)
downloadports-08e4118191934e39a0e06468d08484332d0eb5e1.tar.gz
ports-08e4118191934e39a0e06468d08484332d0eb5e1.zip
Notes
Diffstat (limited to 'www/subsonic')
-rw-r--r--www/subsonic/Makefile19
-rw-r--r--www/subsonic/distinfo4
-rw-r--r--www/subsonic/files/pkg-message.in2
-rw-r--r--www/subsonic/pkg-plist4
4 files changed, 12 insertions, 17 deletions
diff --git a/www/subsonic/Makefile b/www/subsonic/Makefile
index 441ae4b7cb88..161b12948c79 100644
--- a/www/subsonic/Makefile
+++ b/www/subsonic/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= subsonic
-PORTVERSION= 4.4
+PORTVERSION= 4.5
CATEGORIES= www java
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-war
@@ -30,23 +30,18 @@ RUN_DEPENDS+= ffmpeg:${PORTSDIR}/multimedia/ffmpeg \
SUB_FILES= pkg-message
.if exists(${LOCALBASE}/apache-tomcat-6.0/webapps)
WEBAPPDIR= ${PREFIX}/apache-tomcat-6.0/webapps
-BUILD_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0:${PORTSDIR}/www/tomcat6
-RUN_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0:${PORTSDIR}/www/tomcat6
+BUILD_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
+RUN_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
SUB_LIST= TOMCATOPTS="tomcat60_java_opts"
.elif exists(${LOCALBASE}/tomcat5.5/webapps)
WEBAPPDIR= ${PREFIX}/tomcat5.5/webapps
-BUILD_DEPENDS+= ${LOCALBASE}/tomcat5.5:${PORTSDIR}/www/tomcat55
-RUN_DEPENDS+= ${LOCALBASE}/tomcat5.5:${PORTSDIR}/www/tomcat55
+BUILD_DEPENDS+= ${LOCALBASE}/tomcat5.5/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
+RUN_DEPENDS+= ${LOCALBASE}/tomcat5.5/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
SUB_LIST= TOMCATOPTS="tomcat55_java_opts"
-.elif exists(${LOCALBASE}/apache-tomcat4.1/webapps)
-WEBAPPDIR= ${PREFIX}/apache-tomcat4.1/webapps
-BUILD_DEPENDS+= ${LOCALBASE}/apache-tomcat4.1:${PORTSDIR}/www/tomcat41
-RUN_DEPENDS+= ${LOCALBASE}/apache-tomcat4.1:${PORTSDIR}/www/tomcat41
-SUB_LIST= TOMCATOPTS="tomcat41_java_opts"
.else
WEBAPPDIR= ${PREFIX}/apache-tomcat-6.0/webapps
-BUILD_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0:${PORTSDIR}/www/tomcat6
-RUN_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0:${PORTSDIR}/www/tomcat6
+BUILD_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
+RUN_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
SUB_LIST= TOMCATOPTS="tomcat60_java_opts"
.endif
diff --git a/www/subsonic/distinfo b/www/subsonic/distinfo
index d07afac3d2da..e6f414eac94c 100644
--- a/www/subsonic/distinfo
+++ b/www/subsonic/distinfo
@@ -1,2 +1,2 @@
-SHA256 (subsonic-4.4-war.zip) = 6ad572f6e94620f03d2a39d84d56e790884c5100aa92b3ec7c7310e23ab684ca
-SIZE (subsonic-4.4-war.zip) = 18254238
+SHA256 (subsonic-4.5-war.zip) = ff5ee8011c174ac5531f8751875dfe2cdd99ebb447c643726c2bce8b522f11bb
+SIZE (subsonic-4.5-war.zip) = 18311536
diff --git a/www/subsonic/files/pkg-message.in b/www/subsonic/files/pkg-message.in
index f92b08289dbf..6f6557680d73 100644
--- a/www/subsonic/files/pkg-message.in
+++ b/www/subsonic/files/pkg-message.in
@@ -1,7 +1,7 @@
========================================================================
-Access Subsonic at http://localhost:8180/subsonic/ (if using the default
+Access Subsonic at http://127.0.0.1:8180/subsonic/ (if using the default
Tomcat HTTP port).
If you encounter problems with thumbnails, start tomcat with
diff --git a/www/subsonic/pkg-plist b/www/subsonic/pkg-plist
index cdda1e7ec4b6..54fdcc62612b 100644
--- a/www/subsonic/pkg-plist
+++ b/www/subsonic/pkg-plist
@@ -1,8 +1,8 @@
%%WEBAPPS%%/subsonic.war
-@unexec if [ ! -d %%WEBAPPS%%/subsonic ]; then rm -f %%WEBAPPS%%/subsonic; fi
+@unexec if [ -d %%WEBAPPS%%/subsonic ]; then rm -Rf %%WEBAPPS%%/subsonic; fi
@unexec test -d %%SUBSONIC_HOME%% && (echo "Configuration information saved. If you will *NOT* use this package anymore," && echo "please remove %%SUBSONIC_HOME%% and its contents manually.")
@exec mkdir -p %%SUBSONIC_HOME%%
-%%TRANSCODING%%@exec ln -sf %%PREFIX/bin/ffmpeg %%SUBSONIC_HOME%%/transcode/ffmpeg
+%%TRANSCODING%%@exec ln -sf %%PREFIX%%/bin/ffmpeg %%SUBSONIC_HOME%%/transcode/ffmpeg
%%TRANSCODING%%@exec ln -sf %%PREFIX%%/bin/lame %%SUBSONIC_HOME%%/transcode/lame
%%TRANSCODING%%@unexec rm -f %%SUBSONIC_HOME%%/transcode/ffmpeg
%%TRANSCODING%%@unexec rm -f %%SUBSONIC_HOME%%/transcode/lame