aboutsummaryrefslogtreecommitdiff
path: root/www/surf
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2010-01-04 17:32:01 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2010-01-04 17:32:01 +0000
commit0e36b8d885027b47ea8c503f3d8e2c394bb9c5dc (patch)
treee5a38ca99ccdbb367ab9df7b21e9168f301208a4 /www/surf
parent4964dea82a6d1f36ec9a471e8718985af1b3f31b (diff)
downloadports-0e36b8d885027b47ea8c503f3d8e2c394bb9c5dc.tar.gz
ports-0e36b8d885027b47ea8c503f3d8e2c394bb9c5dc.zip
Notes
Diffstat (limited to 'www/surf')
-rw-r--r--www/surf/Makefile44
-rw-r--r--www/surf/distinfo3
-rw-r--r--www/surf/files/patch-config.mk38
-rw-r--r--www/surf/pkg-descr6
4 files changed, 91 insertions, 0 deletions
diff --git a/www/surf/Makefile b/www/surf/Makefile
new file mode 100644
index 000000000000..a4106d882e4d
--- /dev/null
+++ b/www/surf/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: surf
+# Date created: December 21, 2009
+# Whom: Christopher Knaust <jigboe@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= surf
+PORTVERSION= 0.3
+CATEGORIES= www
+MASTER_SITES= http://dl.suckless.org/${PORTNAME}/ \
+ LOCAL/glarkin
+
+MAINTAINER= jigboe@gmx.de
+COMMENT= A simple Web browser based on WebKit/Gtk+
+
+LIB_DEPENDS= webkit-1.0:${PORTSDIR}/www/webkit-gtk2
+RUN_DEPENDS= dmenu:${PORTSDIR}/x11/dmenu
+
+USE_GNOME= gtk20 pkgconfig
+
+MAN1= surf.1
+PLIST_FILES= bin/surf
+PORTDOCS= LICENSE README
+
+pre-everything::
+ @${ECHO_MSG} "You can build surf with your own config.h using the SURF_CONF knob:"
+ @${ECHO_MSG} "make SURF_CONF=/path/to/surf/config.h install clean"
+
+post-extract:
+.if defined(SURF_CONF)
+ @${ECHO_MSG} "creating config.h from ${SURF_CONF}"
+ @${CP} ${SURF_CONF} ${WRKSRC}/config.h
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/LICENSE ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/surf/distinfo b/www/surf/distinfo
new file mode 100644
index 000000000000..8bd34c700acf
--- /dev/null
+++ b/www/surf/distinfo
@@ -0,0 +1,3 @@
+MD5 (surf-0.3.tar.gz) = 0b7bbe58f0ca140f1fb7aac09c4319d9
+SHA256 (surf-0.3.tar.gz) = 652a9ddb0a82a6350fabbc7c8d8a9f852b8c838263f892ac7695dfcdd5b31842
+SIZE (surf-0.3.tar.gz) = 9838
diff --git a/www/surf/files/patch-config.mk b/www/surf/files/patch-config.mk
new file mode 100644
index 000000000000..d19ad65c9123
--- /dev/null
+++ b/www/surf/files/patch-config.mk
@@ -0,0 +1,38 @@
+--- config.mk 2009-10-30 13:41:02.000000000 +0100
++++ config.mk 2009-12-21 19:25:11.000000000 +0100
+@@ -4,25 +4,25 @@ VERSION = 0.3
+ # Customize below to fit your system
+
+ # paths
+-PREFIX = /usr/local
+-MANPREFIX = ${PREFIX}/share/man
++PREFIX?= /usr/local
++MANPREFIX = ${PREFIX}/man
+
+-GTKINC=$(shell pkg-config --cflags gtk+-2.0 webkit-1.0)
+-GTKLIB=$(shell pkg-config --libs gtk+-2.0 webkit-1.0)
++GTKINC!= pkg-config --cflags gtk+-2.0 webkit-1.0
++GTKLIB!= pkg-config --libs gtk+-2.0 webkit-1.0
+
+
+ # includes and libs
+-INCS = -I. -I/usr/include ${GTKINC}
+-LIBS = -L/usr/lib -lc ${GTKLIB} -lgthread-2.0
++INCS = ${GTKINC}
++LIBS = ${PTHREAD_LIBS} ${GTKLIB}
+
+ # flags
+-CPPFLAGS = -DVERSION=\"${VERSION}\"
+-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
+-LDFLAGS = -s ${LIBS}
++CPPFLAGS+= -DVERSION=\"${VERSION}\"
++CFLAGS+= -std=c99 ${INCS} ${CPPFLAGS}
++LDFLAGS+= ${LIBS}
+
+ # Solaris
+ #CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"
+ #LDFLAGS = ${LIBS}
+
+ # compiler and linker
+-CC = cc
++CC?= cc
diff --git a/www/surf/pkg-descr b/www/surf/pkg-descr
new file mode 100644
index 000000000000..26aab1a1ffa8
--- /dev/null
+++ b/www/surf/pkg-descr
@@ -0,0 +1,6 @@
+surf is a simple web browser based on WebKit/GTK+. It is able to display
+websites and follow links. It supports the XEmbed protocol which makes
+it possible to embed it in another application. Furthermore, one can
+point surf to another URI by setting its XProperties.
+
+WWW: http://surf.suckless.org