aboutsummaryrefslogtreecommitdiff
path: root/www/swfdec-plugin
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2009-01-10 02:45:46 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2009-01-10 02:45:46 +0000
commit15b6544926b07a98710eeb765baf03e3fc9a195c (patch)
tree35103cf986d2ed2295c97768e62afcc47dfed877 /www/swfdec-plugin
parent23fcf54562404bb41380488c8318ac0e3ce15efc (diff)
Add a new framework for browser plugins, USE_WEBPLUGINS. It is for which foo
plugins support one of web browsers and can take care of plist (depend on how you use it) at the same time. I have written a complete document and even show how it works in the www/firefox/Makefile.webplugins so be sure to read in there. If there is anything that isn't clear in the document, please feel free to ask and I will try my best to improvement it. FYI: GNOME 2.24 depends on this, so it's coming. BTW: It's based on www/linux-mplayer-plugin/Makefile.npapi with heavy modified. Approved by: portmgr
Notes
Notes: svn path=/head/; revision=225627
Diffstat (limited to 'www/swfdec-plugin')
-rw-r--r--www/swfdec-plugin/Makefile11
-rw-r--r--www/swfdec-plugin/pkg-plist8
2 files changed, 12 insertions, 7 deletions
diff --git a/www/swfdec-plugin/Makefile b/www/swfdec-plugin/Makefile
index 7779a76ab70a..af9a85317e91 100644
--- a/www/swfdec-plugin/Makefile
+++ b/www/swfdec-plugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= swfdec-plugin
PORTVERSION= 0.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://swfdec.freedesktop.org/download/swfdec-mozilla/0.6/
DISTNAME= swfdec-mozilla-${PORTVERSION}
@@ -18,8 +18,13 @@ COMMENT= Flash rendering plugin
LIB_DEPENDS= swfdec-0.6:${PORTSDIR}/graphics/swfdec
USE_AUTOTOOLS= libtool:15
-CONFIGURE_ARGS= --with-plugin-dir="${PREFIX}/lib/browser_plugins"
+CONFIGURE_ARGS= --with-plugin-dir="${WEBPLUGINS_DIR}"
USE_LDCONFIG= yes
-.include <bsd.port.mk>
+USE_WEBPLUGINS= gecko*
+WEBPLUGINS_FILES=libswfdecmozilla.so
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
+.include <bsd.port.post.mk>
diff --git a/www/swfdec-plugin/pkg-plist b/www/swfdec-plugin/pkg-plist
index 30f2c911497f..ffed0eed5a40 100644
--- a/www/swfdec-plugin/pkg-plist
+++ b/www/swfdec-plugin/pkg-plist
@@ -1,4 +1,4 @@
-lib/browser_plugins/libswfdecmozilla.a
-lib/browser_plugins/libswfdecmozilla.la
-lib/browser_plugins/libswfdecmozilla.so
-@dirrmtry lib/browser_plugins
+%%WEBPLUGINS_DIR%%/libswfdecmozilla.a
+%%WEBPLUGINS_DIR%%/libswfdecmozilla.la
+%%WEBPLUGINS_DIR%%/libswfdecmozilla.so
+@dirrmtry %%WEBPLUGINS_DIR%%