aboutsummaryrefslogtreecommitdiff
path: root/www/swish-e/Makefile
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2010-05-16 06:18:19 +0000
committerSahil Tandon <sahil@FreeBSD.org>2010-05-16 06:18:19 +0000
commite432f4e4b641488636c1f932f4a9507e62b5d3d8 (patch)
tree5f2e4b211f6c13eb541c8e6985a20c75351d8d42 /www/swish-e/Makefile
parent0f6ef1ad1ce7dc81bfcc9420dbfa50610d590f5c (diff)
Notes
Diffstat (limited to 'www/swish-e/Makefile')
-rw-r--r--www/swish-e/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/www/swish-e/Makefile b/www/swish-e/Makefile
index 7dbf4a8b14c5..803b28fe7d22 100644
--- a/www/swish-e/Makefile
+++ b/www/swish-e/Makefile
@@ -18,10 +18,23 @@ USE_LDCONFIG= yes
USE_GNOME= libxml2
USE_GMAKE= yes
GNU_CONFIGURE= yes
-MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
+MAKE_ARGS+= pkgconfigdir="${PREFIX}/libdata/pkgconfig" \
+ pkgdatadir="${DATADIR}"
+.if !defined(NOPORTDOCS)
PORTDOCS= *
+.endif
-MAN1= SWISH-CONFIG.1 SWISH-FAQ.1 SWISH-LIBRARY.1 SWISH-RUN.1 swish-e.1
+MAN1= SWISH-CONFIG.1 SWISH-FAQ.1 SWISH-LIBRARY.1 SWISH-RUN.1 swish-e.1
+
+.if defined(NOPORTDOCS)
+post-patch:
+ @${REINPLACE_CMD} -E 's/^(install-data-am:) install-docDATA(.*)/\1\2/' \
+ ${WRKSRC}/Makefile.in
+.for p in pod prog-bin conf filter-bin filters html
+ @${REINPLACE_CMD} -E 's/^(install-data-am:).*DATA(.*)/\1\2/' \
+ ${WRKSRC}/${p}/Makefile.in
+.endfor
+.endif
.include <bsd.port.mk>