aboutsummaryrefslogtreecommitdiff
path: root/www/swish-e
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>1998-12-22 22:59:16 +0000
committerBill Fumerola <billf@FreeBSD.org>1998-12-22 22:59:16 +0000
commit5abcacf74e02e671f786a7ba3eb40e8ed9045618 (patch)
treecb63f025ff6ea0115b584bedb9cd86df9d44d76c /www/swish-e
parent11a329e5b3853ba9ba03a4f8d8cfc0a5e87f616b (diff)
downloadports-5abcacf74e02e671f786a7ba3eb40e8ed9045618.tar.gz
ports-5abcacf74e02e671f786a7ba3eb40e8ed9045618.zip
Notes
Diffstat (limited to 'www/swish-e')
-rw-r--r--www/swish-e/Makefile31
-rw-r--r--www/swish-e/distinfo1
-rw-r--r--www/swish-e/files/patch-aa38
-rw-r--r--www/swish-e/pkg-comment1
-rw-r--r--www/swish-e/pkg-descr9
-rw-r--r--www/swish-e/pkg-plist1
6 files changed, 81 insertions, 0 deletions
diff --git a/www/swish-e/Makefile b/www/swish-e/Makefile
new file mode 100644
index 000000000000..4a8bc641dd48
--- /dev/null
+++ b/www/swish-e/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: swish-e
+# Version required: 1.2.4
+# Date created: 23 Feb 98
+# Whom: Daniel O'Connor <doconnor@gsoft.com.au>
+#
+# $Id$
+#
+
+DISTNAME= swish-efiles.1.2.4
+PKGNAME= swish-e-1.2.4
+CATEGORIES= www textproc
+MASTER_SITES= ftp://sunsite.berkeley.edu/pub/swish-e/
+
+MAINTAINER= doconnor@gsoft.com.au
+
+WRKSRC= ${WRKDIR}/src
+USE_GMAKE= yes
+
+post-patch:
+
+ ${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.pre_sed
+ ${SED} -e 's#/vol/moby/moby_a/gnu/sun4_sunos5.1/bin/gcc#${CC}#' \
+ -e 's#\"-g\"#\"${CFLAGS}\"#g' \
+ -e 's#CFLAGS= -O2#CFLAGS = \"${CFLAGS}\"#' \
+ ${WRKSRC}/Makefile.pre_sed >> ${WRKSRC}/Makefile
+
+do-install:
+
+ $(INSTALL_PROGRAM) ${WRKSRC}/swish-e ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/www/swish-e/distinfo b/www/swish-e/distinfo
new file mode 100644
index 000000000000..96cc576821db
--- /dev/null
+++ b/www/swish-e/distinfo
@@ -0,0 +1 @@
+MD5 (swish-efiles.1.2.4.tar.gz) = f6c2ec409aedcbf0b2efee0a40c2e027
diff --git a/www/swish-e/files/patch-aa b/www/swish-e/files/patch-aa
new file mode 100644
index 000000000000..0d59a382d762
--- /dev/null
+++ b/www/swish-e/files/patch-aa
@@ -0,0 +1,38 @@
+--- fs.c.old Fri Nov 27 13:30:13 1998
++++ fs.c Fri Nov 27 13:32:19 1998
+@@ -539,23 +539,28 @@
+ int ishtml(filename)
+ char *filename;
+ {
+- char *c, suffix[MAXSUFFIXLEN];
++ char *c, *d;
+
++ d = (char *) strrchr(filename, '/');
+ c = (char *) strrchr(filename, '.');
+
++ /* make sure the . is part of the filename */
++ if (d != NULL && c < d) {
++ return 0;
++ }
++
+ if (c == NULL)
+ return 0;
+- strcpy(suffix, c + 1);
+- if (suffix[0] == '\0')
++ if (c++ == '\0')
+ return 0;
+
+- if (!strncmp(suffix, "htm", 3))
++ if (!strncmp(c, "htm", 3))
+ return 1;
+- else if (!strncmp(suffix, "HTM", 3))
++ else if (!strncmp(c, "HTM", 3))
+ return 1;
+- else if (!strncmp(suffix, "shtml", 5))
++ else if (!strncmp(c, "shtml", 5))
+ return 1;
+- else if (!strncmp(suffix, "SHTML", 5))
++ else if (!strncmp(c, "SHTML", 5))
+ return 1;
+ return 0;
+ }
diff --git a/www/swish-e/pkg-comment b/www/swish-e/pkg-comment
new file mode 100644
index 000000000000..c58653b5cc9c
--- /dev/null
+++ b/www/swish-e/pkg-comment
@@ -0,0 +1 @@
+simple web indexing for humans - enhanced
diff --git a/www/swish-e/pkg-descr b/www/swish-e/pkg-descr
new file mode 100644
index 000000000000..8987301db419
--- /dev/null
+++ b/www/swish-e/pkg-descr
@@ -0,0 +1,9 @@
+SWISH-Enhanced is a fast, powerful, flexible, and easy to use system for
+indexing collections of Web pages or other text files. Key features include
+the ability to limit searches to certain HTML tags (META, TITLE, comments,
+etc.). The SWISH-E software is free, and includes a package of Perl programs
+that enable anyone who is authorized to create and maintain their own indexes
+(AutoSwish). SWISH-E is an enhanced version of SWISH, which was originally
+written by Kevin Hughes and modified and released with his permission.
+
+http://sunsite.berkeley.edu/SWISH-E/
diff --git a/www/swish-e/pkg-plist b/www/swish-e/pkg-plist
new file mode 100644
index 000000000000..a828466c26ca
--- /dev/null
+++ b/www/swish-e/pkg-plist
@@ -0,0 +1 @@
+bin/swish-e