aboutsummaryrefslogtreecommitdiff
path: root/www/tclhttpd
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-07-10 13:54:22 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-07-10 13:54:22 +0000
commitec7b561464bf844cc65b843d4f531945aa1d09fc (patch)
treeacf3f96eca894e3e032f914d0b0e69216c46a7ae /www/tclhttpd
parent0802ab78d38d28b4df1862bd943c1dd923e073f5 (diff)
downloadports-ec7b561464bf844cc65b843d4f531945aa1d09fc.tar.gz
ports-ec7b561464bf844cc65b843d4f531945aa1d09fc.zip
Notes
Diffstat (limited to 'www/tclhttpd')
-rw-r--r--www/tclhttpd/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/www/tclhttpd/Makefile b/www/tclhttpd/Makefile
index 4ac69f0ae000..61c92fa538ec 100644
--- a/www/tclhttpd/Makefile
+++ b/www/tclhttpd/Makefile
@@ -38,24 +38,24 @@ do-build:
FILESDIR="${FILESDIR}" -f "${FILESDIR}/Makefile.lib"
pre-install:
- ${MKDIR} ${LOCALBASE}/tclhttpd/custom
+ ${MKDIR} ${PREFIX}/tclhttpd/custom
post-install:
test -e ${RCD} || ${SED} \
"s%COMMAND_LINE%${LOCALBASE}/bin/tclsh${TCL_DVER} ${PREFIX}/bin/httpd.tcl%" \
< ${FILESDIR}/tclhttpd.sh > ${RCD}
- ${CHOWN} -R nobody ${LOCALBASE}/share/${PORTNAME}${PORTVERSION}
+ ${CHOWN} -R nobody ${DATADIR}${PORTVERSION}
${CHMOD} +x ${RCD}
${INSTALL_DATA} ${WRKSRC}/${SHLIB_NAME} \
- ${LOCALBASE}/lib/${PORTNAME}${PORTVERSION}/${SHLIB_NAME}
+ ${PREFIX}/lib/${PORTNAME}${PORTVERSION}/${SHLIB_NAME}
${INSTALL_SCRIPT} ${WRKSRC}/bin/httpd.tcl \
- ${WRKSRC}/bin/httpdthread.tcl ${LOCALBASE}/bin/
+ ${WRKSRC}/bin/httpdthread.tcl ${PREFIX}/bin/
${SED} 's%@VER@%${PORTVERSION}%g' < ${WRKSRC}/bin/tclhttpd.rc \
- > ${LOCALBASE}/etc/tclhttpd.rc.default
- cd ${LOCALBASE}/etc; test -e tclhttpd.rc || \
+ > ${PREFIX}/etc/tclhttpd.rc.default
+ cd ${PREFIX}/etc; test -e tclhttpd.rc || \
${CP} -p tclhttpd.rc.default tclhttpd.rc
${SED} 's%@LIB@%${SHLIB_NAME}%g' < \
${FILESDIR}/pkgIndex.tcl >> \
- ${LOCALBASE}/lib/${PORTNAME}${PORTVERSION}/pkgIndex.tcl
+ ${PREFIX}/lib/${PORTNAME}${PORTVERSION}/pkgIndex.tcl
.include <bsd.port.post.mk>