aboutsummaryrefslogtreecommitdiff
path: root/www/tclhttpd
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2004-11-19 21:36:45 +0000
committerMikhail Teterin <mi@FreeBSD.org>2004-11-19 21:36:45 +0000
commit554e996bf8011a2cdffa719cdc837bf00afe32a1 (patch)
treead62c23fb212f3ad09c0c63a589a1ad94f370d60 /www/tclhttpd
parent36e68529f260445f3fce81274e05ee3c2b21f8eb (diff)
downloadports-554e996bf8011a2cdffa719cdc837bf00afe32a1.tar.gz
ports-554e996bf8011a2cdffa719cdc837bf00afe32a1.zip
Notes
Diffstat (limited to 'www/tclhttpd')
-rw-r--r--www/tclhttpd/Makefile14
-rw-r--r--www/tclhttpd/distinfo4
-rw-r--r--www/tclhttpd/files/Makefile.lib7
-rw-r--r--www/tclhttpd/files/metaPackage.c1
-rw-r--r--www/tclhttpd/files/patch-ab13
-rw-r--r--www/tclhttpd/files/patch-af5
-rw-r--r--www/tclhttpd/files/patch-ak90
-rw-r--r--www/tclhttpd/files/patch-tcl8415
-rw-r--r--www/tclhttpd/files/tclhttpd.sh2
-rw-r--r--www/tclhttpd/pkg-plist228
-rw-r--r--www/tclhttpd/scripts/post-patch8
11 files changed, 219 insertions, 168 deletions
diff --git a/www/tclhttpd/Makefile b/www/tclhttpd/Makefile
index ad7fd83a786c..abcc24e71fb6 100644
--- a/www/tclhttpd/Makefile
+++ b/www/tclhttpd/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= tclhttpd
-PORTVERSION= 3.4.2
-CATEGORIES= www tcl83
+PORTVERSION= 3.5.1
+CATEGORIES= www tcl83 tcl84
MASTER_SITES= ${MASTER_SITE_TCLTK}
MASTER_SITE_SUBDIR= httpd
DISTNAME= ${PORTNAME}${PORTVERSION}
@@ -15,7 +15,7 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= mi@aldan.algebra.com
COMMENT= An http-server implemented in TCL
-RUN_DEPENDS= ${LOCALBASE}/lib/tcllib1.6/pkgIndex.tcl:${PORTSDIR}/devel/tcllib
+RUN_DEPENDS= ${LOCALBASE}/lib/tcllib1.7/pkgIndex.tcl:${PORTSDIR}/devel/tcllib
LIB_DEPENDS= tcl${TCL_VER}:${PORTSDIR}/lang/tcl${TCL_VER}
TCL_DVER?= 8.4
@@ -28,14 +28,20 @@ MAN1= tclhttpd.1
RCD= ${LOCALBASE}/etc/rc.d/tclhttpd.sh
.include <bsd.port.pre.mk>
-SHLIB_NAME!= ${MAKE} -f "${FILESDIR}/Makefile.lib" ech
+SHLIB_NAME!= ${MAKE} -f "${FILESDIR}/Makefile.lib" -V SHLIB_NAME
PLIST_SUB+= TCL_VER=${TCL_VER} PORTVERSION=${PORTVERSION} \
SHLIB_NAME=${SHLIB_NAME}
MAKE_ENV+= TCLSH_PROG=tclsh${TCL_DVER}
+SCRIPTS_ENV+= TCL_DVER=${TCL_DVER}
do-build:
cd ${WRKSRC} && ${MAKE_ENV} ${MAKE} -j 2 TCL_DVER="${TCL_DVER}" \
FILESDIR="${FILESDIR}" -f "${FILESDIR}/Makefile.lib"
+ #
+ # Note, the ``utime'' command supplied by the tclhttpd's library
+ # (interface to utimes(2)) has been long obsoleted by TCL's own
+ # file(n) and is finally removed from this port
+ #
pre-install:
${MKDIR} ${PREFIX}/tclhttpd/custom
diff --git a/www/tclhttpd/distinfo b/www/tclhttpd/distinfo
index 8548b484a7b5..9daa8674e2f9 100644
--- a/www/tclhttpd/distinfo
+++ b/www/tclhttpd/distinfo
@@ -1,2 +1,2 @@
-MD5 (tclhttpd3.4.2.tar.gz) = d5c6517430023735a78afb5e8d707e83
-SIZE (tclhttpd3.4.2.tar.gz) = 450344
+MD5 (tclhttpd3.5.1.tar.gz) = f48676606a8715312308f178ccd9289d
+SIZE (tclhttpd3.5.1.tar.gz) = 594484
diff --git a/www/tclhttpd/files/Makefile.lib b/www/tclhttpd/files/Makefile.lib
index fc8e63104efa..0a0fd8a4ae69 100644
--- a/www/tclhttpd/files/Makefile.lib
+++ b/www/tclhttpd/files/Makefile.lib
@@ -1,8 +1,8 @@
-TCL_DVER?= 8.3
+TCL_DVER?= 8.4
TCL_VER= ${TCL_DVER:S/.//}
PREFIX?= /usr/local
-SRCS=crypt.c setuid.c limit.c utime.c metaPackage.c
+SRCS=crypt.c setuid.c limit.c metaPackage.c
CFLAGS+=-I${LOCALBASE}/include/tcl${TCL_DVER} -DUSE_TCL_STUBS \
-DTclhttpdbin_Init=${LIBNAME}_Init -Wall -Werror
@@ -13,7 +13,4 @@ LDADD+=-L${LOCALBASE}/lib -ltclstub${TCL_VER} -lcrypt
LIBNAME= Tclhttpdbin
SHLIB_NAME= lib${LIBNAME}.so
-ech:
- @echo ${SHLIB_NAME}
-
.include <bsd.lib.mk>
diff --git a/www/tclhttpd/files/metaPackage.c b/www/tclhttpd/files/metaPackage.c
index 6046531e084e..4629a41964f9 100644
--- a/www/tclhttpd/files/metaPackage.c
+++ b/www/tclhttpd/files/metaPackage.c
@@ -7,7 +7,6 @@ int Tclhttpdbin_Init(Tcl_Interp *I) {
Crypt_Init(I);
Limit_Init(I);
Setuid_Init(I);
- Utime_Init(I);
return TCL_OK;
}
diff --git a/www/tclhttpd/files/patch-ab b/www/tclhttpd/files/patch-ab
index 8a95f84c0d89..750aa3737aef 100644
--- a/www/tclhttpd/files/patch-ab
+++ b/www/tclhttpd/files/patch-ab
@@ -5,11 +5,6 @@
-htdocsdir = $(SERVER_ROOT)/htdocs
+htdocsdir = $(prefix)/share/@PACKAGE@@VERSION@
-@@ -183,3 +183,3 @@
- TCL_GENERIC_DIR_NATIVE = @TCL_GENERIC_DIR_NATIVE@
--TCLSH_PROG = @TCLSH_PROG@
-+TCLSH_PROG ?= tclsh8.3
- SHARED_BUILD = @SHARED_BUILD@
@@ -198,3 +198,3 @@
CONFIGDIR = @CONFIGDIR@
-mkinstalldirs = $(SHELL) $(CONFIGDIR)/mkinstalldirs
@@ -28,8 +23,10 @@
@@ -330,1 +330,1 @@
- $(INSTALL_DATA) $(srcdir)/doc/httpd.1 $(mandir)/man1/httpd.1
+ $(INSTALL_DATA) $(srcdir)/doc/httpd.1 $(mandir)/man1/tclhttpd.1
-@@ -335,3 +335,3 @@
+@@ -343,5 +343,5 @@
+
installdirs:
-- $(mkinstalldirs) $(pkglibdir) $(cryptlibdir) $(prefix)/bin $(htdocsdir) $(customdir)
-+ $(mkinstalldirs) $(pkglibdir) $(prefix)/bin $(htdocsdir) $(customdir)
+- $(mkinstalldirs) $(DESTDIR)$(pkglibdir) $(DESTDIR)$(cryptlibdir) $(DESTDIR)$(prefix)/bin $(DESTDIR)$(htdocsdir) $(DESTDIR)$(customdir)
++ $(mkinstalldirs) $(DESTDIR)$(pkglibdir) $(DESTDIR)$(prefix)/bin $(DESTDIR)$(htdocsdir) $(DESTDIR)$(customdir)
+ clean:
diff --git a/www/tclhttpd/files/patch-af b/www/tclhttpd/files/patch-af
deleted file mode 100644
index 74df2c3f7272..000000000000
--- a/www/tclhttpd/files/patch-af
+++ /dev/null
@@ -1,5 +0,0 @@
---- lib/log.tcl Mon Apr 3 20:00:28 2000
-+++ lib/log.tcl Fri May 5 10:01:58 2000
-@@ -29,1 +29,1 @@
-- set Log(compressProg) /usr/local/bin/gzip
-+ set Log(compressProg) /usr/bin/gzip
diff --git a/www/tclhttpd/files/patch-ak b/www/tclhttpd/files/patch-ak
index 48137087c614..5f8e65a3899f 100644
--- a/www/tclhttpd/files/patch-ak
+++ b/www/tclhttpd/files/patch-ak
@@ -1,6 +1,15 @@
---- src/limit.c Thu May 11 02:00:43 2000
-+++ src/limit.c Fri Dec 1 20:04:58 2000
-@@ -20,7 +20,6 @@
+--- src/limit.c Thu May 1 19:42:14 2003
++++ src/limit.c Fri Nov 19 13:21:15 2004
+@@ -9,6 +9,5 @@
+
+
+-static int LimitCmd _ANSI_ARGS_((ClientData clientData,
+- Tcl_Interp *interp, int argc, char *argv[]));
++Tcl_ObjCmdProc LimitCmd;
+
+ #undef TCL_STORAGE_CLASS
+@@ -29,9 +28,8 @@
+ */
int
-LimitCmd(ClientData data, Tcl_Interp *interp, int argc, char *argv[])
+LimitCmd(ClientData data, Tcl_Interp *interp, int argc, Tcl_Obj *CONST objv[])
@@ -10,66 +19,35 @@
struct rlimit limit;
+ Tcl_Obj *limObj[2];
Tcl_ResetResult(interp);
-@@ -31,3 +30,4 @@
+ if (getrlimit(RLIMIT_NOFILE, &limit) < 0) {
+@@ -40,12 +38,18 @@
+ }
if (argc > 1) {
-- Tcl_GetInt(interp, argv[1], (int *)&limit.rlim_cur);
-+ if (Tcl_GetLongFromObj(interp, objv[1], (long *)&limit.rlim_cur)
-+ != TCL_OK) return TCL_ERROR;
+- Tcl_GetInt(interp, argv[1], (int *)&limit.rlim_cur);
++ long rlim_cur;
++
++ if (Tcl_GetLongFromObj(interp, objv[1], &rlim_cur) != TCL_OK)
++ return TCL_ERROR;
++ limit.rlim_cur = rlim_cur;
if (setrlimit(RLIMIT_NOFILE, &limit) < 0) {
-@@ -37,3 +37,5 @@
+- Tcl_AppendResult(interp, "NOFILE: ", Tcl_PosixError(interp), NULL);
+- return TCL_ERROR;
+- }
++ Tcl_AppendResult(interp, "NOFILE: ", Tcl_PosixError(interp), NULL);
++ return TCL_ERROR;
++ }
}
+ /* bad, bad style, direct writing to interp->result */
- sprintf(interp->result, "%d %d", limit.rlim_cur, limit.rlim_max);
+ limObj[0] = Tcl_NewLongObj((long)limit.rlim_cur);
+ limObj[1] = Tcl_NewLongObj((long)limit.rlim_max);
+ Tcl_SetObjResult(interp, Tcl_NewListObj(2, limObj));
return TCL_OK;
-@@ -54,3 +56,3 @@
- {
+ }
+@@ -71,5 +75,5 @@
+ #endif
+
- Tcl_CreateCommand(interp, "limit", LimitCmd, NULL, NULL);
+ Tcl_CreateObjCommand(interp, "limit", LimitCmd, NULL, NULL);
- Tcl_PkgProvide(interp, "limit", "1.0");
---- src/setuid.c Tue Oct 6 20:12:11 1998
-+++ src/setuid.c Fri Dec 1 20:05:52 2000
-@@ -7,2 +7,3 @@
- #include <sys/types.h>
-+#include <unistd.h>
-
---- src/utime.c Tue Oct 6 20:12:11 1998
-+++ src/utime.c Fri Dec 1 20:14:21 2000
-@@ -20,13 +20,8 @@
- int
--UtimeCmd(ClientData data, Tcl_Interp *interp, int argc, char *argv[])
-+UtimeCmd(ClientData data, Tcl_Interp *interp, int argc, Tcl_Obj *CONST objv[])
- {
- struct utimbuf u = {0, 0};
-+ char *file;
-
- Tcl_ResetResult(interp);
-- if (argc > 3) {
-- Tcl_GetInt(interp, argv[3], &u.actime); /* new access time */
-- }
-- if (argc > 2) {
-- Tcl_GetInt(interp, argv[2], &u.modtime); /* new modify time */
-- }
- if (argc > 4 || argc <= 1) {
-@@ -35,4 +30,13 @@
- }
-- if (utime(argv[1], &u) < 0) {
-- Tcl_AppendResult(interp, "utime: ", argv[1], Tcl_PosixError(interp), NULL);
-+ if (argc > 3) {
-+ if (Tcl_GetLongFromObj(interp, objv[3], (long *)&u.actime)
-+ != TCL_OK) return TCL_ERROR; /* new access time */
-+ }
-+ if (argc > 2) {
-+ if (Tcl_GetLongFromObj(interp, objv[2], (long *)&u.modtime)
-+ != TCL_OK) return TCL_ERROR; /* new modify time */
-+ }
-+ file = Tcl_GetString(objv[1]);
-+ if (utime(file, &u) < 0) {
-+ Tcl_AppendResult(interp, "utime: ", file, Tcl_PosixError(interp), NULL);
- return TCL_ERROR;
-@@ -55,3 +59,3 @@
- {
-- Tcl_CreateCommand(interp, "utime", UtimeCmd, NULL, NULL);
-+ Tcl_CreateObjCommand(interp, "utime", UtimeCmd, NULL, NULL);
- Tcl_PkgProvide(interp, "utime", "1.0");
+ code = Tcl_PkgProvide(interp, "limit", "1.0");
+ if (code != TCL_OK) {
diff --git a/www/tclhttpd/files/patch-tcl84 b/www/tclhttpd/files/patch-tcl84
index 0d9b472f8fe0..d3da03a679ab 100644
--- a/www/tclhttpd/files/patch-tcl84
+++ b/www/tclhttpd/files/patch-tcl84
@@ -27,17 +27,18 @@
{
char *result;
--- src/setuid.c Tue Oct 6 20:12:11 1998
-+++ src/setuid.c Thu Apr 24 12:03:18 2003
-@@ -8,4 +8,8 @@
- #include <unistd.h>
-
++++ src/setuid.c Fri Nov 19 13:17:06 2004
+@@ -6,4 +6,9 @@
+ #include <tcl.h>
+ #include <sys/types.h>
++#include <unistd.h>
++
+#ifndef CONST84
+# define CONST84
+#endif
-+
+
/*
- * SetuidCmd --
-@@ -19,5 +23,5 @@
+@@ -18,5 +23,5 @@
*/
int
-SetuidCmd(ClientData data, Tcl_Interp *interp, int argc, char *argv[])
diff --git a/www/tclhttpd/files/tclhttpd.sh b/www/tclhttpd/files/tclhttpd.sh
index bba81a73cb35..6376cb49a646 100644
--- a/www/tclhttpd/files/tclhttpd.sh
+++ b/www/tclhttpd/files/tclhttpd.sh
@@ -12,7 +12,7 @@ case $1 in
fi
;;
''|start)
- COMMAND_LINE &
+ env LANG=C COMMAND_LINE &
sleep 2
if kill -0 $! ; then
echo -n ' tclhttpd'
diff --git a/www/tclhttpd/pkg-plist b/www/tclhttpd/pkg-plist
index 9c145e03108d..c065bd260ad1 100644
--- a/www/tclhttpd/pkg-plist
+++ b/www/tclhttpd/pkg-plist
@@ -7,13 +7,18 @@ lib/tclhttpd%%PORTVERSION%%/%%SHLIB_NAME%%
lib/tclhttpd%%PORTVERSION%%/admin.tcl
lib/tclhttpd%%PORTVERSION%%/auth.tcl
lib/tclhttpd%%PORTVERSION%%/cgi.tcl
+lib/tclhttpd%%PORTVERSION%%/compat.tcl
lib/tclhttpd%%PORTVERSION%%/config.tcl
+lib/tclhttpd%%PORTVERSION%%/cookie.tcl
lib/tclhttpd%%PORTVERSION%%/counter.tcl
lib/tclhttpd%%PORTVERSION%%/debug.tcl
-lib/tclhttpd%%PORTVERSION%%/demo.tcl
+lib/tclhttpd%%PORTVERSION%%/digest.tcl
lib/tclhttpd%%PORTVERSION%%/direct.tcl
lib/tclhttpd%%PORTVERSION%%/dirlist.tcl
lib/tclhttpd%%PORTVERSION%%/doc.tcl
+lib/tclhttpd%%PORTVERSION%%/doc_error.tcl
+lib/tclhttpd%%PORTVERSION%%/doctools.tcl
+lib/tclhttpd%%PORTVERSION%%/fallback.tcl
lib/tclhttpd%%PORTVERSION%%/httpd.tcl
lib/tclhttpd%%PORTVERSION%%/imagemap.tcl
lib/tclhttpd%%PORTVERSION%%/include.tcl
@@ -25,17 +30,18 @@ lib/tclhttpd%%PORTVERSION%%/maptk.tcl
lib/tclhttpd%%PORTVERSION%%/mtype.tcl
lib/tclhttpd%%PORTVERSION%%/open.tcl
lib/tclhttpd%%PORTVERSION%%/passcheck.tcl
+lib/tclhttpd%%PORTVERSION%%/passgen.tcl
lib/tclhttpd%%PORTVERSION%%/pkgIndex.tcl
lib/tclhttpd%%PORTVERSION%%/prodebug.tcl
lib/tclhttpd%%PORTVERSION%%/redirect.tcl
lib/tclhttpd%%PORTVERSION%%/safecgio.tcl
lib/tclhttpd%%PORTVERSION%%/session.tcl
-lib/tclhttpd%%PORTVERSION%%/sendsock.tcl
-lib/tclhttpd%%PORTVERSION%%/snmp.tcl
lib/tclhttpd%%PORTVERSION%%/srvui.tcl
lib/tclhttpd%%PORTVERSION%%/status.tcl
lib/tclhttpd%%PORTVERSION%%/stdin.tcl
-lib/tclhttpd%%PORTVERSION%%/telnet.tcl
+lib/tclhttpd%%PORTVERSION%%/subst.tcl
+lib/tclhttpd%%PORTVERSION%%/tclcrypt.tcl
+lib/tclhttpd%%PORTVERSION%%/template.tcl
lib/tclhttpd%%PORTVERSION%%/thread.tcl
lib/tclhttpd%%PORTVERSION%%/upload.tcl
lib/tclhttpd%%PORTVERSION%%/url.tcl
@@ -43,35 +49,30 @@ lib/tclhttpd%%PORTVERSION%%/utils.tcl
lib/tclhttpd%%PORTVERSION%%/version.tcl
lib/tclhttpd%%PORTVERSION%%/mime.types
@dirrm lib/tclhttpd%%PORTVERSION%%
-share/tclhttpd%%PORTVERSION%%/empty.html
-share/tclhttpd%%PORTVERSION%%/error.html
-share/tclhttpd%%PORTVERSION%%/hacks.tml
-share/tclhttpd%%PORTVERSION%%/include.shtml
-share/tclhttpd%%PORTVERSION%%/index.tml
-share/tclhttpd%%PORTVERSION%%/license.terms
-share/tclhttpd%%PORTVERSION%%/notfound.html
-share/tclhttpd%%PORTVERSION%%/redirect
-share/tclhttpd%%PORTVERSION%%/register.tml
-share/tclhttpd%%PORTVERSION%%/test.tml
+share/tclhttpd%%PORTVERSION%%/.tml
+share/tclhttpd%%PORTVERSION%%/access/.htaccess
share/tclhttpd%%PORTVERSION%%/access/README.txt
-share/tclhttpd%%PORTVERSION%%/access/index.tml
+share/tclhttpd%%PORTVERSION%%/access/auth/.htaccess
share/tclhttpd%%PORTVERSION%%/access/auth/hello.txt
share/tclhttpd%%PORTVERSION%%/access/auth/test.cgi
-share/tclhttpd%%PORTVERSION%%/access/auth/.htaccess
+share/tclhttpd%%PORTVERSION%%/access/bydir/.htaccess
share/tclhttpd%%PORTVERSION%%/access/bydir/README.txt
share/tclhttpd%%PORTVERSION%%/access/bydir/user.cgi
-share/tclhttpd%%PORTVERSION%%/access/bydir/.htaccess
-share/tclhttpd%%PORTVERSION%%/access/bytcl/index.tml
share/tclhttpd%%PORTVERSION%%/access/bytcl/.tclaccess
-share/tclhttpd%%PORTVERSION%%/access/multiple/index.tml
+share/tclhttpd%%PORTVERSION%%/access/bytcl/index.tml
+share/tclhttpd%%PORTVERSION%%/access/digest/.htaccess
+share/tclhttpd%%PORTVERSION%%/access/digest/Readme.txt
+share/tclhttpd%%PORTVERSION%%/access/htaccess.tml
+share/tclhttpd%%PORTVERSION%%/access/htman.tml
+share/tclhttpd%%PORTVERSION%%/access/index.tml
share/tclhttpd%%PORTVERSION%%/access/multiple/.htaccess
+share/tclhttpd%%PORTVERSION%%/access/multiple/index.tml
share/tclhttpd%%PORTVERSION%%/access/noawe/.htaccess
-share/tclhttpd%%PORTVERSION%%/access/null/index.tml
share/tclhttpd%%PORTVERSION%%/access/null/.tclaccess
-share/tclhttpd%%PORTVERSION%%/access/session/page.auth
+share/tclhttpd%%PORTVERSION%%/access/null/index.tml
share/tclhttpd%%PORTVERSION%%/access/session/.tclaccess
-share/tclhttpd%%PORTVERSION%%/access/.htaccess
-share/tclhttpd%%PORTVERSION%%/access/htaccess.tml
+share/tclhttpd%%PORTVERSION%%/access/session/page.auth
+share/tclhttpd%%PORTVERSION%%/admin/.htaccess
share/tclhttpd%%PORTVERSION%%/book/TCLHTTPD-1.gif
share/tclhttpd%%PORTVERSION%%/book/TCLHTTPD-2.gif
share/tclhttpd%%PORTVERSION%%/book/TCLHTTPD.css
@@ -96,22 +97,37 @@ share/tclhttpd%%PORTVERSION%%/cgi-bin/tclIndex
share/tclhttpd%%PORTVERSION%%/cgi-bin/test.cgi
share/tclhttpd%%PORTVERSION%%/cgi-bin/testupload.cgi
share/tclhttpd%%PORTVERSION%%/cgi-bin/user.cgi
+share/tclhttpd%%PORTVERSION%%/cgi-bin/wiki.cgi
+share/tclhttpd%%PORTVERSION%%/debug/.htaccess
+share/tclhttpd%%PORTVERSION%%/debug/.tclaccess
+share/tclhttpd%%PORTVERSION%%/debug/README
+share/tclhttpd%%PORTVERSION%%/empty.html
+share/tclhttpd%%PORTVERSION%%/error.html
+share/tclhttpd%%PORTVERSION%%/forms/.tml
share/tclhttpd%%PORTVERSION%%/forms/file.tml
share/tclhttpd%%PORTVERSION%%/forms/form1.tml
share/tclhttpd%%PORTVERSION%%/forms/formget.tml
share/tclhttpd%%PORTVERSION%%/forms/headers.tml
share/tclhttpd%%PORTVERSION%%/forms/headerspost.tml
share/tclhttpd%%PORTVERSION%%/forms/index.tml
+share/tclhttpd%%PORTVERSION%%/forms/multi.tml
share/tclhttpd%%PORTVERSION%%/forms/ncgiredirect.cgi
+share/tclhttpd%%PORTVERSION%%/forms/posttest.tml
share/tclhttpd%%PORTVERSION%%/forms/redirect.tml
share/tclhttpd%%PORTVERSION%%/forms/redirect2.tml
-share/tclhttpd%%PORTVERSION%%/forms/multi.tml
-share/tclhttpd%%PORTVERSION%%/forms/posttest.tml
share/tclhttpd%%PORTVERSION%%/forms/testupload.tml
-share/tclhttpd%%PORTVERSION%%/forms/.tml
share/tclhttpd%%PORTVERSION%%/guestbook/guestbook.cgi
share/tclhttpd%%PORTVERSION%%/guestbook/newguest.cgi
share/tclhttpd%%PORTVERSION%%/guestbook/newguest.html
+share/tclhttpd%%PORTVERSION%%/hacks.tml
+share/tclhttpd%%PORTVERSION%%/htaccess/.htaccess
+share/tclhttpd%%PORTVERSION%%/htaccess/.tml
+share/tclhttpd%%PORTVERSION%%/htaccess/group
+share/tclhttpd%%PORTVERSION%%/htaccess/group.tml
+share/tclhttpd%%PORTVERSION%%/htaccess/htaccess.org
+share/tclhttpd%%PORTVERSION%%/htaccess/index.tml
+share/tclhttpd%%PORTVERSION%%/htaccess/register.tml
+share/tclhttpd%%PORTVERSION%%/htaccess/user.tml
share/tclhttpd%%PORTVERSION%%/images/AjubaLogo.gif
share/tclhttpd%%PORTVERSION%%/images/Blue.gif
share/tclhttpd%%PORTVERSION%%/images/Red.gif
@@ -134,7 +150,9 @@ share/tclhttpd%%PORTVERSION%%/images/pwrdLogo75.gif
share/tclhttpd%%PORTVERSION%%/images/setup.gif
share/tclhttpd%%PORTVERSION%%/images/tcl89.gif
share/tclhttpd%%PORTVERSION%%/images/tclp.gif
+share/tclhttpd%%PORTVERSION%%/include.shtml
share/tclhttpd%%PORTVERSION%%/include/footer.html
+share/tclhttpd%%PORTVERSION%%/index.tml
share/tclhttpd%%PORTVERSION%%/java/Auth.class
share/tclhttpd%%PORTVERSION%%/java/Getpass.class
share/tclhttpd%%PORTVERSION%%/java/Helper.class
@@ -144,35 +162,75 @@ share/tclhttpd%%PORTVERSION%%/java/ServerDemo.class
share/tclhttpd%%PORTVERSION%%/java/ServerDemo.html
share/tclhttpd%%PORTVERSION%%/java/auth.js
share/tclhttpd%%PORTVERSION%%/java/test.html
+share/tclhttpd%%PORTVERSION%%/learn/direct.tml
+share/tclhttpd%%PORTVERSION%%/learn/domain.tml
+share/tclhttpd%%PORTVERSION%%/learn/index.tml
+share/tclhttpd%%PORTVERSION%%/learn/security.tml
+share/tclhttpd%%PORTVERSION%%/learn/setup.tml
+share/tclhttpd%%PORTVERSION%%/license.terms
share/tclhttpd%%PORTVERSION%%/links/INSTALL.txt
-share/tclhttpd%%PORTVERSION%%/links/README.txt
share/tclhttpd%%PORTVERSION%%/links/README.ssl.txt
+share/tclhttpd%%PORTVERSION%%/links/README.txt
share/tclhttpd%%PORTVERSION%%/links/WHATSNEW.txt
-share/tclhttpd%%PORTVERSION%%/libtml/Index
-share/tclhttpd%%PORTVERSION%%/libtml/faq.tcl
-share/tclhttpd%%PORTVERSION%%/libtml/htmlutils.tcl
-share/tclhttpd%%PORTVERSION%%/libtml/mypage.tcl
-share/tclhttpd%%PORTVERSION%%/libtml/pkgIndex.tcl
-share/tclhttpd%%PORTVERSION%%/libtml/ss_survey.tcl
-share/tclhttpd%%PORTVERSION%%/libtml/sunscript.tcl
+share/tclhttpd%%PORTVERSION%%/man/architecture.man
+share/tclhttpd%%PORTVERSION%%/man/base64.man
+share/tclhttpd%%PORTVERSION%%/man/cgi.man
+share/tclhttpd%%PORTVERSION%%/man/changelog.man
+share/tclhttpd%%PORTVERSION%%/man/cmdline.man
+share/tclhttpd%%PORTVERSION%%/man/config.man
+share/tclhttpd%%PORTVERSION%%/man/cookie.man
+share/tclhttpd%%PORTVERSION%%/man/counter.man
+share/tclhttpd%%PORTVERSION%%/man/cvs.man
+share/tclhttpd%%PORTVERSION%%/man/direct.man
+share/tclhttpd%%PORTVERSION%%/man/dirlist.man
+share/tclhttpd%%PORTVERSION%%/man/doc.man
+share/tclhttpd%%PORTVERSION%%/man/doc_error.man
+share/tclhttpd%%PORTVERSION%%/man/docidx.man
+share/tclhttpd%%PORTVERSION%%/man/docidx_api.man
+share/tclhttpd%%PORTVERSION%%/man/docidx_fmt.man
+share/tclhttpd%%PORTVERSION%%/man/doctoc.man
+share/tclhttpd%%PORTVERSION%%/man/doctoc_api.man
+share/tclhttpd%%PORTVERSION%%/man/doctoc_fmt.man
+share/tclhttpd%%PORTVERSION%%/man/doctools.man
+share/tclhttpd%%PORTVERSION%%/man/doctools_api.man
+share/tclhttpd%%PORTVERSION%%/man/doctools_fmt.man
+share/tclhttpd%%PORTVERSION%%/man/expander.man
+share/tclhttpd%%PORTVERSION%%/man/fileutil.man
+share/tclhttpd%%PORTVERSION%%/man/html.man
+share/tclhttpd%%PORTVERSION%%/man/httpd.man
+share/tclhttpd%%PORTVERSION%%/man/index.tml
+share/tclhttpd%%PORTVERSION%%/man/log.man
+share/tclhttpd%%PORTVERSION%%/man/logstd.man
+share/tclhttpd%%PORTVERSION%%/man/md5.man
+share/tclhttpd%%PORTVERSION%%/man/md5crypt.man
+share/tclhttpd%%PORTVERSION%%/man/mime.man
+share/tclhttpd%%PORTVERSION%%/man/mpexpand.man
+share/tclhttpd%%PORTVERSION%%/man/mtype.man
+share/tclhttpd%%PORTVERSION%%/man/ncgi.man
+share/tclhttpd%%PORTVERSION%%/man/session.man
+share/tclhttpd%%PORTVERSION%%/man/smtp.man
+share/tclhttpd%%PORTVERSION%%/man/subst.man
+share/tclhttpd%%PORTVERSION%%/man/tclhttpd.man
+share/tclhttpd%%PORTVERSION%%/man/textutil.man
+share/tclhttpd%%PORTVERSION%%/man/uri.man
+share/tclhttpd%%PORTVERSION%%/man/url.man
+share/tclhttpd%%PORTVERSION%%/man/uuencode.man
+share/tclhttpd%%PORTVERSION%%/man/version.man
+share/tclhttpd%%PORTVERSION%%/man/yencode.man
+share/tclhttpd%%PORTVERSION%%/manual/embedding.tml
share/tclhttpd%%PORTVERSION%%/manual/htdig.html
-share/tclhttpd%%PORTVERSION%%/manual/reference.tml
+share/tclhttpd%%PORTVERSION%%/manual/intro.tml
share/tclhttpd%%PORTVERSION%%/manual/stdin.html
-share/tclhttpd%%PORTVERSION%%/manual/technotes.tml
share/tclhttpd%%PORTVERSION%%/map/bush.tml
share/tclhttpd%%PORTVERSION%%/map/index.tml
share/tclhttpd%%PORTVERSION%%/map/mapdefault.tml
share/tclhttpd%%PORTVERSION%%/map/surfer.tml
+share/tclhttpd%%PORTVERSION%%/notfound.html
+share/tclhttpd%%PORTVERSION%%/redirect
+share/tclhttpd%%PORTVERSION%%/register.tml
+share/tclhttpd%%PORTVERSION%%/sampleapp/bugdb/.tml
+share/tclhttpd%%PORTVERSION%%/sampleapp/calendar.tml
share/tclhttpd%%PORTVERSION%%/snmp/allport.snmp
-share/tclhttpd%%PORTVERSION%%/snmp/discover.snmp
-share/tclhttpd%%PORTVERSION%%/snmp/host.snmp
-share/tclhttpd%%PORTVERSION%%/snmp/index.html
-share/tclhttpd%%PORTVERSION%%/snmp/outdiscov.snmp
-share/tclhttpd%%PORTVERSION%%/snmp/portdetail.snmp
-share/tclhttpd%%PORTVERSION%%/snmp/repeat.snmp
-share/tclhttpd%%PORTVERSION%%/snmp/system.snmp
-share/tclhttpd%%PORTVERSION%%/snmp/telnet.snmp
-share/tclhttpd%%PORTVERSION%%/snmp/telnet_pass.snmp
share/tclhttpd%%PORTVERSION%%/snmp/browser/README
share/tclhttpd%%PORTVERSION%%/snmp/browser/browser.snmp
share/tclhttpd%%PORTVERSION%%/snmp/browser/browser2.snmp
@@ -184,6 +242,15 @@ share/tclhttpd%%PORTVERSION%%/snmp/browser/title.html
share/tclhttpd%%PORTVERSION%%/snmp/browser/title.snmp
share/tclhttpd%%PORTVERSION%%/snmp/browser/walk.snmp
share/tclhttpd%%PORTVERSION%%/snmp/browser/walker.snmp
+share/tclhttpd%%PORTVERSION%%/snmp/discover.snmp
+share/tclhttpd%%PORTVERSION%%/snmp/host.snmp
+share/tclhttpd%%PORTVERSION%%/snmp/index.html
+share/tclhttpd%%PORTVERSION%%/snmp/outdiscov.snmp
+share/tclhttpd%%PORTVERSION%%/snmp/portdetail.snmp
+share/tclhttpd%%PORTVERSION%%/snmp/repeat.snmp
+share/tclhttpd%%PORTVERSION%%/snmp/system.snmp
+share/tclhttpd%%PORTVERSION%%/snmp/telnet.snmp
+share/tclhttpd%%PORTVERSION%%/snmp/telnet_pass.snmp
share/tclhttpd%%PORTVERSION%%/snmp/test_mibTable/README
share/tclhttpd%%PORTVERSION%%/snmp/test_mibTable/index.html
share/tclhttpd%%PORTVERSION%%/snmp/test_mibTable/table1.snmp
@@ -191,46 +258,61 @@ share/tclhttpd%%PORTVERSION%%/snmp/test_mibTable/table2.snmp
share/tclhttpd%%PORTVERSION%%/snmp/test_mibTable/table3.snmp
share/tclhttpd%%PORTVERSION%%/snmp/test_mibTable/table4.snmp
share/tclhttpd%%PORTVERSION%%/snmp/test_mibTable/test2.snmp
+share/tclhttpd%%PORTVERSION%%/stats/.tml
share/tclhttpd%%PORTVERSION%%/stats/doc.tml
share/tclhttpd%%PORTVERSION%%/stats/index.tml
share/tclhttpd%%PORTVERSION%%/stats/notfound.tml
-share/tclhttpd%%PORTVERSION%%/stats/.tml
+share/tclhttpd%%PORTVERSION%%/status/.htaccess
+share/tclhttpd%%PORTVERSION%%/status/.tclaccess
+share/tclhttpd%%PORTVERSION%%/templates/.tml
share/tclhttpd%%PORTVERSION%%/templates/faqfaq.tml
share/tclhttpd%%PORTVERSION%%/templates/form.tml
share/tclhttpd%%PORTVERSION%%/templates/index.tml
+share/tclhttpd%%PORTVERSION%%/templates/self.tml
share/tclhttpd%%PORTVERSION%%/templates/simple.subst
-share/tclhttpd%%PORTVERSION%%/templates/.tml
-share/tclhttpd%%PORTVERSION%%/.tml
-@dirrm share/tclhttpd%%PORTVERSION%%/access/auth
-@dirrm share/tclhttpd%%PORTVERSION%%/access/bydir
-@dirrm share/tclhttpd%%PORTVERSION%%/access/bytcl
-@dirrm share/tclhttpd%%PORTVERSION%%/access/multiple
-@dirrm share/tclhttpd%%PORTVERSION%%/access/noawe
-@dirrm share/tclhttpd%%PORTVERSION%%/access/null
-@dirrm share/tclhttpd%%PORTVERSION%%/access/session
-@dirrm share/tclhttpd%%PORTVERSION%%/access
-@dirrm share/tclhttpd%%PORTVERSION%%/book
-@dirrm share/tclhttpd%%PORTVERSION%%/cgi-bin
-@dirrm share/tclhttpd%%PORTVERSION%%/forms
-@dirrm share/tclhttpd%%PORTVERSION%%/guestbook
-@dirrm share/tclhttpd%%PORTVERSION%%/images
-@dirrm share/tclhttpd%%PORTVERSION%%/include
-@dirrm share/tclhttpd%%PORTVERSION%%/java
-@dirrm share/tclhttpd%%PORTVERSION%%/libtml
-@dirrm share/tclhttpd%%PORTVERSION%%/links
-@dirrm share/tclhttpd%%PORTVERSION%%/manual
-@dirrm share/tclhttpd%%PORTVERSION%%/map
-@dirrm share/tclhttpd%%PORTVERSION%%/snmp/browser
+share/tclhttpd%%PORTVERSION%%/test.tml
+share/tclhttpd%%PORTVERSION%%/tests/add_headers.tml
+share/tclhttpd%%PORTVERSION%%/tests/refresh.tml
+share/tclhttpd%%PORTVERSION%%/version_history.tml
+@dirrm share/tclhttpd%%PORTVERSION%%/tests
+@dirrm share/tclhttpd%%PORTVERSION%%/templates
+@dirrm share/tclhttpd%%PORTVERSION%%/status
+@dirrm share/tclhttpd%%PORTVERSION%%/stats
@dirrm share/tclhttpd%%PORTVERSION%%/snmp/test_mibTable
+@dirrm share/tclhttpd%%PORTVERSION%%/snmp/browser
@dirrm share/tclhttpd%%PORTVERSION%%/snmp
-@dirrm share/tclhttpd%%PORTVERSION%%/stats
-@dirrm share/tclhttpd%%PORTVERSION%%/templates
+@dirrm share/tclhttpd%%PORTVERSION%%/sampleapp/bugdb
+@dirrm share/tclhttpd%%PORTVERSION%%/sampleapp
+@dirrm share/tclhttpd%%PORTVERSION%%/map
+@dirrm share/tclhttpd%%PORTVERSION%%/manual
+@dirrm share/tclhttpd%%PORTVERSION%%/man
+@dirrm share/tclhttpd%%PORTVERSION%%/links
+@dirrm share/tclhttpd%%PORTVERSION%%/learn
+@dirrm share/tclhttpd%%PORTVERSION%%/java
+@dirrm share/tclhttpd%%PORTVERSION%%/include
+@dirrm share/tclhttpd%%PORTVERSION%%/images
+@dirrm share/tclhttpd%%PORTVERSION%%/htaccess
+@dirrm share/tclhttpd%%PORTVERSION%%/guestbook
+@dirrm share/tclhttpd%%PORTVERSION%%/forms
+@dirrm share/tclhttpd%%PORTVERSION%%/debug
+@dirrm share/tclhttpd%%PORTVERSION%%/cgi-bin
+@dirrm share/tclhttpd%%PORTVERSION%%/book
+@dirrm share/tclhttpd%%PORTVERSION%%/admin
+@dirrm share/tclhttpd%%PORTVERSION%%/access/session
+@dirrm share/tclhttpd%%PORTVERSION%%/access/null
+@dirrm share/tclhttpd%%PORTVERSION%%/access/noawe
+@dirrm share/tclhttpd%%PORTVERSION%%/access/multiple
+@dirrm share/tclhttpd%%PORTVERSION%%/access/digest
+@dirrm share/tclhttpd%%PORTVERSION%%/access/bytcl
+@dirrm share/tclhttpd%%PORTVERSION%%/access/bydir
+@dirrm share/tclhttpd%%PORTVERSION%%/access/auth
+@dirrm share/tclhttpd%%PORTVERSION%%/access
@dirrm share/tclhttpd%%PORTVERSION%%
tclhttpd/custom/README
-tclhttpd/custom/ddehack.tcl
+tclhttpd/custom/dodirs.tcl
+tclhttpd/custom/faq.tcl
tclhttpd/custom/hello.tcl
-tclhttpd/custom/snmpinit.tcl
-tclhttpd/custom/tclpro.tcl
+tclhttpd/custom/mypage.tcl
@dirrm tclhttpd/custom
tclhttpd/README
tclhttpd/README_custom
diff --git a/www/tclhttpd/scripts/post-patch b/www/tclhttpd/scripts/post-patch
index 26de6121b1fd..0ac49a5f89ca 100644
--- a/www/tclhttpd/scripts/post-patch
+++ b/www/tclhttpd/scripts/post-patch
@@ -1,10 +1,6 @@
if [ ${LOCALBASE} != /usr/local ] ; then
- for f in `find ${WRKSRC} -type f | xargs grep -l /usr/local`
- do
- cp -p $f $f.ul && \
- sed "s%/usr/local%${LOCALBASE}%g" < $f.ul > $f \
- && rm -f $f.ul
- done
+ find ${WRKSRC} -type f | xargs grep -l /usr/local |\
+ xargs sed -i "" -e s%/usr/local%${LOCALBASE}%g
fi
for f in `find ${WRKSRC} -type f | \
xargs grep -l '^exec tclsh.* '`