aboutsummaryrefslogtreecommitdiff
path: root/www/tdiary
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2014-04-26 10:06:08 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2014-04-26 10:06:08 +0000
commit9fe0f718265641f43c74f167c35eb326fa9a91ce (patch)
tree80ec5b156e24d4e0abaf334b77fc3b5038ef1c6f /www/tdiary
parent34b1e7616ac486129714d8c13dbbca966b3009da (diff)
downloadports-9fe0f718265641f43c74f167c35eb326fa9a91ce.tar.gz
ports-9fe0f718265641f43c74f167c35eb326fa9a91ce.zip
Notes
Diffstat (limited to 'www/tdiary')
-rw-r--r--www/tdiary/Makefile24
-rw-r--r--www/tdiary/distinfo4
-rw-r--r--www/tdiary/pkg-plist13
3 files changed, 25 insertions, 16 deletions
diff --git a/www/tdiary/Makefile b/www/tdiary/Makefile
index b1bc82c767ce..fa0f9d689dc6 100644
--- a/www/tdiary/Makefile
+++ b/www/tdiary/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tdiary
-PORTVERSION= 4.0.2
+PORTVERSION= 4.0.3
CATEGORIES?= www ruby
MASTER_SITES= http://www.tdiary.org/download/
DISTNAME= ${PORTNAME}-full-v${PORTVERSION}
@@ -12,14 +12,13 @@ COMMENT= Web-based diary system (like weblog) written in Ruby
LICENSE= GPLv2
-RUN_DEPENDS= rubygem-fastimage>=1.5.0:${PORTSDIR}/graphics/rubygem-fastimage \
+RUN_DEPENDS= rubygem-fastimage>=1.6.0:${PORTSDIR}/graphics/rubygem-fastimage \
hikidoc:${PORTSDIR}/textproc/ruby-hikidoc \
- rubygem-multi_json>=1.7.7:${PORTSDIR}/devel/rubygem-multi_json \
+ rubygem-multi_json>=1.8.4:${PORTSDIR}/devel/rubygem-multi_json \
rubygem-rack>=0:${PORTSDIR}/www/rubygem-rack
NO_BUILD= yes
USE_RUBY= yes
-RUBY_REQUIRE= Ruby >= 193
RUBY_SHEBANG_FILES= index.fcgi \
index.rb \
@@ -60,8 +59,6 @@ REINPLACE_ARGS= -i ''
OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
-
pre-patch:
@${RM} ${WRKSRC}/.coveralls.yml
@${RM} ${WRKSRC}/.gitignore
@@ -72,8 +69,9 @@ pre-patch:
@${RM} ${WRKSRC}/Procfile
@${RM} ${WRKSRC}/Rakefile
@${RM} ${WRKSRC}/config.ru
- @${RM} -r ${WRKSRC}/.bundle
- @${RM} -r ${WRKSRC}/misc/lib/bundler-1.3.5
+ @${RM} ${WRKSRC}/tmp/.gitkeep
+ @${RM} -rf ${WRKSRC}/.bundle
+ @${RM} -r ${WRKSRC}/misc/lib/bundler-1.6.0.rc
@${RM} -r ${WRKSRC}/public
@${RM} -r ${WRKSRC}/spec
@${RM} -r ${WRKSRC}/test
@@ -91,21 +89,19 @@ pre-install:
@${REINPLACE_CMD} '/#!\/usr\/bin\/env ruby/d' ${WRKSRC}/misc/migrate.rb
do-install:
- @${INSTALL_SCRIPT} ${WRKDIR}/${TDIARY_SCRIPT} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/${TDIARY_SCRIPT} ${STAGEDIR}${PREFIX}/bin
@-${MKDIR} ${STAGEDIR}${WWWDIR}
- @${TAR} --exclude "doc" -C ${WRKSRC} -cf - . | ${TAR} --unlink -C ${STAGEDIR}${WWWDIR} -xf -
+ ${TAR} --exclude "doc" -C ${WRKSRC} -cf - . | ${TAR} --unlink -C ${STAGEDIR}${WWWDIR} -xf -
post-install:
@${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}' >> ${TMPPLIST}
@${ECHO_CMD} bin/${TDIARY_SCRIPT} >> ${TMPPLIST}
-.if ${PORT_OPTIONS:MDOCS}
@${INSTALL} -d ${STAGEDIR}${DOCSDIR}
- @cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.endif
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
@${CAT} ${PKGMESSAGE}
x-generate-plist: stage
${FIND} ${STAGEDIR}${WWWDIR} -type f -o -type l | ${SORT} | ${SED} -e 's,${STAGEDIR}${WWWDIR},%%WWWDIR%%,g' > pkg-plist.new
${FIND} ${STAGEDIR}${WWWDIR} -type d -depth | ${SORT} -r | ${SED} -e 's,${STAGEDIR}${WWWDIR},@dirrm %%WWWDIR%%,g' >> pkg-plist.new
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/tdiary/distinfo b/www/tdiary/distinfo
index c32dcb883598..94f011c184b2 100644
--- a/www/tdiary/distinfo
+++ b/www/tdiary/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tdiary-full-v4.0.2.tar.gz) = 90c21f2aace7c5de1374901e1ec560ee8809ce2040507d7808e511a7cc62b510
-SIZE (tdiary-full-v4.0.2.tar.gz) = 15027180
+SHA256 (tdiary-full-v4.0.3.tar.gz) = e766d1017221336125b595a92ec16c21436a9dbbec36eafa75488e4a032968f5
+SIZE (tdiary-full-v4.0.3.tar.gz) = 77485225
diff --git a/www/tdiary/pkg-plist b/www/tdiary/pkg-plist
index a48fcbe78ec4..be2c51719076 100644
--- a/www/tdiary/pkg-plist
+++ b/www/tdiary/pkg-plist
@@ -146,6 +146,7 @@
%%WWWDIR%%/misc/plugin/referer-antibot.rb
%%WWWDIR%%/misc/plugin/referer-utf8.rb
%%WWWDIR%%/misc/plugin/referer_scheme.rb
+%%WWWDIR%%/misc/plugin/search-default.rb
%%WWWDIR%%/misc/plugin/search_control.rb
%%WWWDIR%%/misc/plugin/search_form.rb
%%WWWDIR%%/misc/plugin/sn.rb
@@ -153,6 +154,7 @@
%%WWWDIR%%/misc/plugin/squeeze.rb
%%WWWDIR%%/misc/plugin/src.rb
%%WWWDIR%%/misc/plugin/tb-show.rb
+%%WWWDIR%%/misc/plugin/theme_online.rb
%%WWWDIR%%/misc/plugin/title_list.rb
%%WWWDIR%%/misc/plugin/title_tag.rb
%%WWWDIR%%/misc/plugin/tlink.rb
@@ -233,6 +235,8 @@
%%WWWDIR%%/tdiary/dispatcher/index_main.rb
%%WWWDIR%%/tdiary/dispatcher/update_main.rb
%%WWWDIR%%/tdiary/environment.rb
+%%WWWDIR%%/tdiary/extensions.rb
+%%WWWDIR%%/tdiary/extensions/core.rb
%%WWWDIR%%/tdiary/filter.rb
%%WWWDIR%%/tdiary/filter/default.rb
%%WWWDIR%%/tdiary/filter/spam.rb
@@ -447,6 +451,7 @@
%%WWWDIR%%/theme/book2-feminine/book2-feminine.css
%%WWWDIR%%/theme/book3-sky/README
%%WWWDIR%%/theme/book3-sky/book3-sky.css
+%%WWWDIR%%/theme/bootstrap/README
%%WWWDIR%%/theme/bootstrap/bootstrap.css
%%WWWDIR%%/theme/bootstrap/css/bootstrap-responsive.css
%%WWWDIR%%/theme/bootstrap/css/bootstrap-responsive.min.css
@@ -471,6 +476,7 @@
%%WWWDIR%%/theme/bubble/bubble_anchor_b.png
%%WWWDIR%%/theme/bubble/bubble_back.png
%%WWWDIR%%/theme/bubble/bubble_pre.png
+%%WWWDIR%%/theme/cafe-mint-julep-soda/README
%%WWWDIR%%/theme/cafe-mint-julep-soda/cafe-mint-julep-soda-back-iphone.jpg
%%WWWDIR%%/theme/cafe-mint-julep-soda/cafe-mint-julep-soda-back.jpg
%%WWWDIR%%/theme/cafe-mint-julep-soda/cafe-mint-julep-soda-update.jpg
@@ -756,6 +762,7 @@
%%WWWDIR%%/theme/gear/gear.css
%%WWWDIR%%/theme/gear/gear_h2.png
%%WWWDIR%%/theme/gear/gear_sanchor.png
+%%WWWDIR%%/theme/genjson.rb
%%WWWDIR%%/theme/germany/README
%%WWWDIR%%/theme/germany/germany.css
%%WWWDIR%%/theme/germany/germany_anchor.png
@@ -947,6 +954,7 @@
%%WWWDIR%%/theme/greentea3/README
%%WWWDIR%%/theme/greentea3/greentea3.css
%%WWWDIR%%/theme/greentea3/greentea3_back.jpg
+%%WWWDIR%%/theme/gustav/README
%%WWWDIR%%/theme/gustav/gustav.css
%%WWWDIR%%/theme/gustav/gustav_back.jpg
%%WWWDIR%%/theme/gustav/gustav_back_iphone.jpg
@@ -1066,6 +1074,7 @@
%%WWWDIR%%/theme/himawari/himawari_anchor.gif
%%WWWDIR%%/theme/himawari/himawari_bg.jpg
%%WWWDIR%%/theme/himawari/himawari_canchor.gif
+%%WWWDIR%%/theme/hsbt/README
%%WWWDIR%%/theme/hsbt/hsbt.css
%%WWWDIR%%/theme/husen/README
%%WWWDIR%%/theme/husen/husen.css
@@ -1740,6 +1749,7 @@
%%WWWDIR%%/theme/teacup/teacup_anchor2.png
%%WWWDIR%%/theme/teacup/teacup_h1.png
%%WWWDIR%%/theme/themebench.html
+%%WWWDIR%%/theme/themes.json
%%WWWDIR%%/theme/thin/README
%%WWWDIR%%/theme/thin/thin.css
%%WWWDIR%%/theme/thin/thin_canchor.png
@@ -1883,6 +1893,8 @@
%%WWWDIR%%/theme/zef/zef.css
%%WWWDIR%%/update.fcgi
%%WWWDIR%%/update.rb
+@exec mkdir -p %D/%%WWWDIR%%/tmp
+@dirrm %%WWWDIR%%/tmp
@dirrm %%WWWDIR%%/theme/zef
@dirrm %%WWWDIR%%/theme/yukon
@dirrm %%WWWDIR%%/theme/ymck
@@ -2237,6 +2249,7 @@
@dirrm %%WWWDIR%%/tdiary/lang
@dirrm %%WWWDIR%%/tdiary/io
@dirrm %%WWWDIR%%/tdiary/filter
+@dirrm %%WWWDIR%%/tdiary/extensions
@dirrm %%WWWDIR%%/tdiary/dispatcher
@dirrm %%WWWDIR%%/tdiary/cache
@dirrm %%WWWDIR%%/tdiary/application/extensions