aboutsummaryrefslogtreecommitdiff
path: root/www/tdom
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-20 11:41:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-20 11:41:05 +0000
commitfadca6c0fe0779dd6a1f96368aef1b3394d0bf70 (patch)
treeb8f33c9086151a8279c122aa2dbf7e20b97f6dc5 /www/tdom
parent6ee3321befc07af15871586b4d11ed64fed416db (diff)
downloadports-fadca6c0fe0779dd6a1f96368aef1b3394d0bf70.tar.gz
ports-fadca6c0fe0779dd6a1f96368aef1b3394d0bf70.zip
Notes
Diffstat (limited to 'www/tdom')
-rw-r--r--www/tdom/Makefile32
1 files changed, 5 insertions, 27 deletions
diff --git a/www/tdom/Makefile b/www/tdom/Makefile
index 3f11abe77a79..130322d278d4 100644
--- a/www/tdom/Makefile
+++ b/www/tdom/Makefile
@@ -7,10 +7,9 @@
PORTNAME= tDOM
PORTVERSION= 0.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.tdom.org/files/
-PKGNAMESUFFIX?= -threads
MAINTAINER= martin@matuska.org
COMMENT= High performance XML data processing with Tcl (ARGS for OpenACS)
@@ -25,8 +24,7 @@ IGNORE= supported values for USE_TCL_VER are only 84 and 85
.endif
# by default we want a threaded build
-USE_TCL= ${USE_TCL_VER}-thread
-USE_TCL_BUILD= ${USE_TCL_VER}-thread
+LIB_DEPENDS= tcl${USE_TCL_VER}-threads:${PORTSDIR}/lang/tcl${USE_TCL_VER}-thread
USE_GMAKE= yes
HAS_CONFIGURE= yes
@@ -46,29 +44,9 @@ HTMLDOCS= category-index.html dom.html domDoc.html domNode.html \
.include <bsd.port.pre.mk>
-.if exists(${TCLSH})
-_TCL_IS_THREADED!= ${ECHO_CMD} 'puts [array names tcl_platform -exact threaded]' | ${TCLSH} || return 0
-. if empty(_TCL_IS_THREADED)
-# Check if a threaded build is forced
-. if defined(TCL_WITH_THREADS) || defined(WITH_THREADS)
-IGNORE= tcl with threads is required. Please install tcl with WITH_THREADS defined or from lang/tcl${USE_TCL} port and try again
-. else
-# Installed tcl is not threaded, so set correct dependencies
-CONFIGURE_ARGS+= --disable-threads
-PKGNAMESUFFIX=
-USE_TCL=${USE_TCL_VER}
-USE_TCL_BUILD=${USE_TCL_VER}
-.include "${PORTSDIR}/Mk/bsd.tcl.mk"
-. endif
-. else
-CONFIGURE_ARGS+= --enable-threads
-. endif
-.else
-CONFIGURE_ARGS+= --enable-threads
-.endif
-
-CONFIGURE_ARGS+= -disable-tdomalloc --with-tcl=${TCL_LIBDIR} \
- --with-tclinclude=${TCL_INCLUDEDIR} --prefix=${PREFIX}
+CONFIGURE_ARGS+= --enable-threads --disable-tdomalloc \
+ --with-tcl=${LOCALBASE}/lib/tcl${USE_TCL_VER:S/8/8./}-threads \
+ --with-tclinclude=${LOCALBASE}/include/tcl${USE_TCL_VER:S/8/8./} --prefix=${PREFIX}
post-install:
.if !defined(NOPORTDOCS)