aboutsummaryrefslogtreecommitdiff
path: root/www/template_
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-27 09:33:49 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-27 09:33:49 +0000
commit439241632693314cb9d9047d7c71568d48c28ef3 (patch)
tree9ff32145dd383cde0aab02d42674e612208b3059 /www/template_
parent0f816f5f032703ab92b175e26de8ac6e515247c1 (diff)
downloadports-439241632693314cb9d9047d7c71568d48c28ef3.tar.gz
ports-439241632693314cb9d9047d7c71568d48c28ef3.zip
Notes
Diffstat (limited to 'www/template_')
-rw-r--r--www/template_/Makefile36
-rw-r--r--www/template_/distinfo3
-rw-r--r--www/template_/pkg-descr3
-rw-r--r--www/template_/pkg-message9
-rw-r--r--www/template_/pkg-plist12
5 files changed, 63 insertions, 0 deletions
diff --git a/www/template_/Makefile b/www/template_/Makefile
new file mode 100644
index 000000000000..db53c03c7f8a
--- /dev/null
+++ b/www/template_/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: template_
+# Date created: 27 Dec 2005
+# Whom: Mun-Kyo Seo <munggo@pmy.lv>
+#
+# $FreeBSD$
+#
+
+PORTNAME= template_
+PORTVERSION= 2.2.3
+CATEGORIES= www
+MASTER_SITES= http://pmy.lv/mirror/Template_/ \
+ http://www.xtac.net/download/?file=
+DISTNAME= Template_.2.2.3
+
+MAINTAINER= munggo@pmy.lv
+COMMENT= High performance PHP compiling template engine
+
+WRKSRC= ${WRKDIR}
+
+USE_PHP= yes
+WANT_PHP_WEB= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-install:
+ ${MKDIR} ${DATADIR}
+.for f in Template_.class.php Template_.compiler.php
+ ${INSTALL_DATA} ${WRKSRC}/$f ${DATADIR}
+ ${MKDIR} ${DATADIR}/tpl_plugin
+ ${INSTALL_DATA} ${WRKSRC}/tpl_plugin/* ${DATADIR}/tpl_plugin
+.endfor
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/template_/distinfo b/www/template_/distinfo
new file mode 100644
index 000000000000..46d2c3bcedcd
--- /dev/null
+++ b/www/template_/distinfo
@@ -0,0 +1,3 @@
+MD5 (Template_.2.2.3.tar.gz) = 50e16aeef263f35ca434ef363c9fa6cf
+SHA256 (Template_.2.2.3.tar.gz) = 526579bc7e39f96fdd97e0e3534bb4e005b64364a6d204054eb9d5a0b43bc373
+SIZE (Template_.2.2.3.tar.gz) = 16732
diff --git a/www/template_/pkg-descr b/www/template_/pkg-descr
new file mode 100644
index 000000000000..e44952351671
--- /dev/null
+++ b/www/template_/pkg-descr
@@ -0,0 +1,3 @@
+Template_ is a LGPL-ed high performance and fast template engine for PHP.
+
+WWW: http://www.xtac.net/
diff --git a/www/template_/pkg-message b/www/template_/pkg-message
new file mode 100644
index 000000000000..2e7ed5a09964
--- /dev/null
+++ b/www/template_/pkg-message
@@ -0,0 +1,9 @@
+****************************************************************
+
+To use Template_ you have to add the correct include path into
+your ${LOCALBASE}/etc/php.ini configuration file, like:
+
+include_path = ".:${PREFIX}/share/template_"
+
+****************************************************************
+
diff --git a/www/template_/pkg-plist b/www/template_/pkg-plist
new file mode 100644
index 000000000000..c11df9c5f620
--- /dev/null
+++ b/www/template_/pkg-plist
@@ -0,0 +1,12 @@
+%%DATADIR%%/tpl_plugin/function.returnHello.php
+%%DATADIR%%/tpl_plugin/functions.safe_mode.ini
+%%DATADIR%%/tpl_plugin/object.say.php
+%%DATADIR%%/tpl_plugin/postfilter.arrangeSpace.php
+%%DATADIR%%/tpl_plugin/postfilter.removeTmpCode.php
+%%DATADIR%%/tpl_plugin/prefilter.adjustPath.php
+%%DATADIR%%/tpl_plugin/prefilter.parseMySyntax.php
+%%DATADIR%%/Template_.class.php
+%%DATADIR%%/Template_.compiler.php
+@dirrm %%DATADIR%%/tpl_plugin
+@dirrm %%DATADIR%%
+