aboutsummaryrefslogtreecommitdiff
path: root/www/thttpd/Makefile
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-08-13 21:39:47 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-08-13 21:39:47 +0000
commit1d3d4ec4597b8c52210b1b65a89dafc25a22133c (patch)
tree5e02d63380f8079c59e11092943ce23526a95c2c /www/thttpd/Makefile
parent29370d3dee624a43df8669a4d27f27ba751f8bf4 (diff)
Fix startup-script for -current /bin/sh issues, and set PREFIX during
install. Requested by: obrien
Notes
Notes: svn path=/head/; revision=64476
Diffstat (limited to 'www/thttpd/Makefile')
-rw-r--r--www/thttpd/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/www/thttpd/Makefile b/www/thttpd/Makefile
index 8b0e043ec401..f0801ba53539 100644
--- a/www/thttpd/Makefile
+++ b/www/thttpd/Makefile
@@ -20,6 +20,7 @@ MAINTAINER= anders@FreeBSD.org
IGNOREFILES= notes.html
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
MAN1= makeweb.1 htpasswd.1
MAN8= thttpd.8 redirect.8 ssi.8 syslogtocern.8
@@ -61,6 +62,7 @@ do-install:
@if [ ! -f ${PREFIX}/etc/rc.d/thttpd.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/thttpd.sh startup file."; \
${INSTALL_SCRIPT} -m 751 ${FILESDIR}/thttpd.sh ${PREFIX}/etc/rc.d/thttpd.sh; \
+ ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${PREFIX}/etc/rc.d/thttpd.sh; \
fi
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/thttpd