aboutsummaryrefslogtreecommitdiff
path: root/www/thttpd
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2007-06-17 19:37:11 +0000
committerAnders Nordby <anders@FreeBSD.org>2007-06-17 19:37:11 +0000
commit878cfd4798e4843746f357f33ca49eec12d42df5 (patch)
tree6dced9398c9cb3812dc7a1419d50447be3c12e93 /www/thttpd
parentbfc53df0af39c08f86f070ba2bd929f761558ab1 (diff)
downloadports-878cfd4798e4843746f357f33ca49eec12d42df5.tar.gz
ports-878cfd4798e4843746f357f33ca49eec12d42df5.zip
Notes
Diffstat (limited to 'www/thttpd')
-rw-r--r--www/thttpd/Makefile2
-rw-r--r--www/thttpd/files/patch-thttpd.c17
2 files changed, 16 insertions, 3 deletions
diff --git a/www/thttpd/Makefile b/www/thttpd/Makefile
index fe95661eb52d..30c092152d74 100644
--- a/www/thttpd/Makefile
+++ b/www/thttpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= thttpd
PORTVERSION= 2.25b
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www ipv6
MASTER_SITES= http://www.acme.com/software/thttpd/ \
http://atreides.freenix.no/~anders/
diff --git a/www/thttpd/files/patch-thttpd.c b/www/thttpd/files/patch-thttpd.c
index fa528be7f9e5..ffebb143cd0f 100644
--- a/www/thttpd/files/patch-thttpd.c
+++ b/www/thttpd/files/patch-thttpd.c
@@ -1,5 +1,5 @@
---- thttpd.c.orig Thu Dec 25 19:06:52 2003
-+++ thttpd.c Fri May 28 12:25:54 2004
+--- thttpd.c.orig Wed Jun 29 19:50:59 2005
++++ thttpd.c Sun Jun 17 21:30:11 2007
@@ -1723,12 +1723,45 @@
if ( hc->responselen == 0 )
{
@@ -54,3 +54,16 @@
}
if ( sz < 0 && errno == EINTR )
+@@ -1786,7 +1820,11 @@
+ **
+ ** And ECONNRESET isn't interesting either.
+ */
+- if ( errno != EPIPE && errno != EINVAL && errno != ECONNRESET )
++ if ( errno != EPIPE && errno != EINVAL && errno != ECONNRESET
++#ifdef USE_SENDFILE
++ && errno != ENOTCONN
++#endif
++ )
+ syslog( LOG_ERR, "write - %m sending %.80s", hc->encodedurl );
+ clear_connection( c, tvP );
+ return;