aboutsummaryrefslogtreecommitdiff
path: root/www/thttpd
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-07-13 23:47:54 +0000
committerSteve Price <steve@FreeBSD.org>2000-07-13 23:47:54 +0000
commit143b2d53ee6761b6d621e5ff9de48a05af0636c6 (patch)
tree755b55601977f901383856e8d448b4f5ec1efe7c /www/thttpd
parentae5a14a7cebec6b547cb933646e0a4aa48dbb283 (diff)
downloadports-143b2d53ee6761b6d621e5ff9de48a05af0636c6.tar.gz
ports-143b2d53ee6761b6d621e5ff9de48a05af0636c6.zip
Notes
Diffstat (limited to 'www/thttpd')
-rw-r--r--www/thttpd/Makefile1
-rw-r--r--www/thttpd/files/thttpd.sh4
2 files changed, 3 insertions, 2 deletions
diff --git a/www/thttpd/Makefile b/www/thttpd/Makefile
index dbce4834afcc..691f94183195 100644
--- a/www/thttpd/Makefile
+++ b/www/thttpd/Makefile
@@ -41,6 +41,7 @@ do-install:
@if [ ! -f ${PREFIX}/sbin/thttpd_wrapper ]; then \
${ECHO} "Installing ${PREFIX}/sbin/thttpd_wrapper file."; \
${ECHO} "#!/bin/sh" > ${PREFIX}/sbin/thttpd_wrapper; \
+ ${ECHO} "${ECHO} \$$\$$ > /var/run/thttpd_wrapper.pid" >> ${PREFIX}/sbin/thttpd_wrapper; \
${ECHO} "while true ; do" >> ${PREFIX}/sbin/thttpd_wrapper; \
${ECHO} " ${PREFIX}/sbin/thttpd -D -C ${PREFIX}/etc/thttpd.conf" >> ${PREFIX}/sbin/thttpd_wrapper; \
${ECHO} " sleep 10" >> ${PREFIX}/sbin/thttpd_wrapper; \
diff --git a/www/thttpd/files/thttpd.sh b/www/thttpd/files/thttpd.sh
index 34a848a96082..6129c1145d58 100644
--- a/www/thttpd/files/thttpd.sh
+++ b/www/thttpd/files/thttpd.sh
@@ -7,10 +7,10 @@ fi
case "$1" in
start)
- [ -x ${PREFIX}/sbin/thttpd_wrapper ] && ${PREFIX}/sbin/thttpd_wrapper && echo -n ' thttpd'
+ [ -x ${PREFIX}/sbin/thttpd_wrapper ] && ${PREFIX}/sbin/thttpd_wrapper & && echo -n ' thttpd'
;;
stop)
- killall thttpd_wrapper && killall thttpd && echo -n ' thttpd'
+ kill `cat /var/run/thttpd_wrapper.pid` && killall thttpd && echo -n ' thttpd'
;;
*)
echo "Usage: `basename $0` {start|stop}" >&2