aboutsummaryrefslogtreecommitdiff
path: root/www/thttpd
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2004-05-28 12:48:38 +0000
committerAnders Nordby <anders@FreeBSD.org>2004-05-28 12:48:38 +0000
commitbb8f925dd868f5d1aad719309af72e78d8fbf065 (patch)
tree50d9568ef4c30bf460d518645d9245af2bdf6f12 /www/thttpd
parentc4ab29bf66051ae6e12263066ca3a67d85410e33 (diff)
downloadports-bb8f925dd868f5d1aad719309af72e78d8fbf065.tar.gz
ports-bb8f925dd868f5d1aad719309af72e78d8fbf065.zip
Notes
Diffstat (limited to 'www/thttpd')
-rw-r--r--www/thttpd/Makefile2
-rw-r--r--www/thttpd/distinfo4
-rw-r--r--www/thttpd/files/patch-thttpd.c26
-rw-r--r--www/thttpd/pkg-plist4
4 files changed, 18 insertions, 18 deletions
diff --git a/www/thttpd/Makefile b/www/thttpd/Makefile
index 3684378442cc..1a7ed400eacd 100644
--- a/www/thttpd/Makefile
+++ b/www/thttpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= thttpd
-PORTVERSION= 2.24
+PORTVERSION= 2.25b
CATEGORIES= www ipv6
MASTER_SITES= http://www.acme.com/software/thttpd/ \
http://atreides.freenix.no/~anders/
diff --git a/www/thttpd/distinfo b/www/thttpd/distinfo
index 4a24fe4c155f..cb4561dd8761 100644
--- a/www/thttpd/distinfo
+++ b/www/thttpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (thttpd/thttpd-2.24.tar.gz) = 9e72c27986548d0cbc8ea850b7b47bdd
-SIZE (thttpd/thttpd-2.24.tar.gz) = 130116
+MD5 (thttpd/thttpd-2.25b.tar.gz) = a0e9cd87455d3a0ea11e5ea7e947adf6
+SIZE (thttpd/thttpd-2.25b.tar.gz) = 132363
MD5 (thttpd/notes.html) = IGNORE
diff --git a/www/thttpd/files/patch-thttpd.c b/www/thttpd/files/patch-thttpd.c
index fde13bd8bbe3..fa528be7f9e5 100644
--- a/www/thttpd/files/patch-thttpd.c
+++ b/www/thttpd/files/patch-thttpd.c
@@ -1,6 +1,6 @@
---- thttpd.c.orig Tue May 13 17:14:33 2003
-+++ thttpd.c Wed Oct 29 05:50:14 2003
-@@ -1593,12 +1593,45 @@
+--- thttpd.c.orig Thu Dec 25 19:06:52 2003
++++ thttpd.c Fri May 28 12:25:54 2004
+@@ -1723,12 +1723,45 @@
if ( hc->responselen == 0 )
{
/* No, just write the file. */
@@ -8,8 +8,8 @@
+ off_t sbytes;
+
+ sz = sendfile(
-+ hc->file_fd, hc->conn_fd, c->bytes_sent,
-+ MIN( c->bytes_to_send - c->bytes_sent, c->max_limit ),
++ hc->file_fd, hc->conn_fd, c->next_byte_index,
++ MIN( c->end_byte_index - c->next_byte_index, max_bytes ),
+ NULL, &sbytes, 0 );
+ if (sz == -1 && errno == EAGAIN)
+ sz = sbytes > 0 ? sbytes : -1;
@@ -17,8 +17,8 @@
+ sz = sbytes;
+#else
sz = write(
- hc->conn_fd, &(hc->file_address[c->bytes_sent]),
- MIN( c->bytes_to_send - c->bytes_sent, c->max_limit ) );
+ hc->conn_fd, &(hc->file_address[c->next_byte_index]),
+ MIN( c->end_byte_index - c->next_byte_index, max_bytes ) );
+#endif
}
else
@@ -35,8 +35,8 @@
+ sf.trailers = NULL;
+ sf.trl_cnt = 0;
+ sz = sendfile(
-+ hc->file_fd, hc->conn_fd, c->bytes_sent,
-+ MIN( c->bytes_to_send - c->bytes_sent, c->max_limit ),
++ hc->file_fd, hc->conn_fd, c->next_byte_index,
++ MIN( c->end_byte_index - c->next_byte_index, max_bytes ),
+ &sf, &sbytes, 0 );
+ if (sz == -1 && errno == EAGAIN)
+ sz = sbytes > 0 ? sbytes : -1;
@@ -46,11 +46,11 @@
/* Yes. We'll combine headers and file into a single writev(),
** hoping that this generates a single packet.
*/
-@@ -1609,6 +1642,7 @@
- iv[1].iov_base = &(hc->file_address[c->bytes_sent]);
- iv[1].iov_len = MIN( c->bytes_to_send - c->bytes_sent, c->max_limit );
+@@ -1739,6 +1772,7 @@
+ iv[1].iov_base = &(hc->file_address[c->next_byte_index]);
+ iv[1].iov_len = MIN( c->end_byte_index - c->next_byte_index, max_bytes );
sz = writev( hc->conn_fd, iv, 2 );
+#endif
}
- if ( sz == 0 ||
+ if ( sz < 0 && errno == EINTR )
diff --git a/www/thttpd/pkg-plist b/www/thttpd/pkg-plist
index fa27c02a1829..7822c8c1c112 100644
--- a/www/thttpd/pkg-plist
+++ b/www/thttpd/pkg-plist
@@ -5,11 +5,11 @@ etc/rc.d/thttpd.sh
etc/thttpd.conf.sample
sbin/thttpd
sbin/thttpd_wrapper
-%%PORTDOCS%%share/doc/thttpd/notes.html
+%%PORTDOCS%%%%DOCSDIR%%/notes.html
www/cgi-bin/phf
www/cgi-bin/redirect
www/cgi-bin/ssi
-%%PORTDOCS%%@dirrm share/doc/thttpd
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@unexec rmdir %D/www/cgi-bin 2> /dev/null || true
@unexec rmdir %D/www/data 2> /dev/null || true
@unexec rmdir %D/www/logs 2> /dev/null || true