aboutsummaryrefslogtreecommitdiff
path: root/www/tidy-devel/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-02-03 22:35:20 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-02-03 22:35:20 +0000
commit837b118303151ea6a4c7dcaea8b50c317247bf9d (patch)
tree0cc42e9347d1c594d500c900441160020d9370b2 /www/tidy-devel/Makefile
parent127287b4193da0876eed4d97b7bfb99aec88fd30 (diff)
downloadports-837b118303151ea6a4c7dcaea8b50c317247bf9d.tar.gz
ports-837b118303151ea6a4c7dcaea8b50c317247bf9d.zip
Notes
Diffstat (limited to 'www/tidy-devel/Makefile')
-rw-r--r--www/tidy-devel/Makefile66
1 files changed, 46 insertions, 20 deletions
diff --git a/www/tidy-devel/Makefile b/www/tidy-devel/Makefile
index afce0561819d..4a173c716db3 100644
--- a/www/tidy-devel/Makefile
+++ b/www/tidy-devel/Makefile
@@ -6,20 +6,20 @@
#
PORTNAME?= tidy
-PORTVERSION= 051026
-PORTREVISION= 2
+DISTVERSION= 070203-cvs
CATEGORIES= www
-MASTER_SITES= http://tidy.sourceforge.net/src/%SUBDIR%/ \
- http://tidy.sourceforge.net/docs/:docs
-MASTER_SITE_SUBDIR= . old
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+#MASTER_SITES= http://tidy.sourceforge.net/src/%SUBDIR%/ \
+# http://tidy.sourceforge.net/docs/:docs
+#MASTER_SITE_SUBDIR= . old
PKGNAMESUFFIX?= -devel
-DISTNAME= tidy_src
-EXTRACT_SUFX= .tgz
-DISTFILES= ${DISTNAME}_${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER?= thierry@FreeBSD.org
COMMENT?= Utility to clean up and pretty print HTML/XHTML/XML
+USE_BZIP2= yes
+
+SLAVEDIRS= www/tidy-lib
WRKSRC= ${WRKDIR}/${PORTNAME}
.if !defined(WITH_SHLIB)
@@ -29,7 +29,7 @@ PLIST_SUB= SHLIB="@comment " NSHLIB=""
USE_AUTOTOOLS= automake:15 autoconf:253 libtool:15
AUTOMAKE_ARGS+= -a -c --foreign
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
PLIST_SUB= SHLIB="" NSHLIB="@comment "
.endif
@@ -47,26 +47,48 @@ BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt
ALL_TARGET= all doc
DOCFILES= quickref.html
. endif
-DOCVER= 051020
-DISTFILES+= tidy_docs_${DOCVER}${EXTRACT_SUFX}:docs
DOCFILES+= Overview.html checked_by_tidy.gif faq.html grid.gif pending.html \
release-notes.html tidy.css tidy.gif
.endif
+.if defined(MAINTAINER_MODE)
+
+CVSROOT= ":pserver:anonymous@tidy.cvs.sourceforge.net:/cvsroot/tidy"
+CVS_PASSFILE= ${WRKDIR}/temp-cvs-passfile
+
+getcvs:
+ ${MKDIR} ${WRKDIR}/cvs
+ ${ECHO_CMD} ${CVSROOT} A > ${CVS_PASSFILE}
+ cd ${WRKDIR}/cvs && \
+ CVSROOT=${CVSROOT} CVS_PASSFILE=${CVS_PASSFILE} cvs -z3 co -P tidy
+
+tarball:
+ ${RM} -rf ${WRKDIR}/cvs/tidy/CVSROOT
+ ${FIND} ${WRKDIR}/cvs -name CVS | ${XARGS} ${RM} -rf
+ cd ${WRKDIR}/cvs && \
+ ${TAR} cfj ${_DISTDIR}${DISTFILES} tidy
+
+.endif
+
post-patch:
+ ${CHMOD} a+x ${WRKSRC}/test/testxml.sh
.if !defined(WITH_SHLIB)
- @${CP} ${WRKSRC}/build/gmake/Makefile ${WRKSRC}
+ ${CP} ${WRKSRC}/build/gmake/Makefile ${WRKSRC}
.else
- @${CP} -R -f ${WRKSRC}/build/gnuauto/* ${WRKSRC}
+ ${CP} -R -f ${WRKSRC}/build/gnuauto/* ${WRKSRC}
+. for t in testone.sh testaccessone.sh
+ ${REINPLACE_CMD} -e 's|../bin/tidy|../console/tidy|' \
+ ${WRKSRC}/test/${t}
+. endfor
.endif
patch-autotools::
.if defined(WITH_SHLIB)
- @(cd ${WRKSRC} \
+ (cd ${WRKSRC} \
&& ${LIBTOOLIZE} --force --copy \
&& ${ACLOCAL} \
&& ${REINPLACE_CMD} -e '/^_LT_AC_SHELL_INIT/d' aclocal.m4)
- @(cd ${PATCH_WRKSRC}; \
+ (cd ${PATCH_WRKSRC}; \
for ltf in ${LIBTOOLFILES}; do \
${CP} $$ltf $$ltf.tmp; \
${SED} -e "s^\$$ac_aux_dir/ltconfig^${LTCONFIG}^g" \
@@ -86,17 +108,21 @@ pre-install:
post-install:
.for pgm in ${BIN2STRIP}
- @${STRIP_CMD} ${PREFIX}/bin/${pgm}
+ ${STRIP_CMD} ${PREFIX}/bin/${pgm}
.endfor
.if defined(WITH_SHLIB)
- @${STRIP_CMD} ${PREFIX}/lib/libtidy-0.99.so.0
+ ${STRIP_CMD} ${PREFIX}/lib/libtidy-0.99.so.0
.endif
.if !defined(NOPORTDOCS)
@${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
- @${MKDIR} ${DOCSDIR}/api
- @${INSTALL_DATA} ${DOCFILES:S|^|${WRKSRC}/htmldoc/|} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/htmldoc/api/* ${DOCSDIR}/api
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOCFILES:S|^|${WRKSRC}/htmldoc/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
+regression-test:
+.for t in testaccess.sh testall.sh testxml.sh
+ cd ${WRKSRC}/test && ./${t}
+.endfor
+
.include <bsd.port.mk>