aboutsummaryrefslogtreecommitdiff
path: root/www/tinyproxy
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2002-03-22 07:32:13 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2002-03-22 07:32:13 +0000
commitcbde27d2e24878fc40d9e7dbb58ab124fc895c3c (patch)
tree07e0f060d4b3ab1eb8b90201bd876d912b3fe205 /www/tinyproxy
parent8a24b5f58b14f41e646761c45def646939ad4087 (diff)
downloadports-cbde27d2e24878fc40d9e7dbb58ab124fc895c3c.tar.gz
ports-cbde27d2e24878fc40d9e7dbb58ab124fc895c3c.zip
Notes
Diffstat (limited to 'www/tinyproxy')
-rw-r--r--www/tinyproxy/Makefile16
-rw-r--r--www/tinyproxy/distinfo2
-rw-r--r--www/tinyproxy/files/patch-aa11
-rw-r--r--www/tinyproxy/files/patch-ab22
-rw-r--r--www/tinyproxy/pkg-descr14
-rw-r--r--www/tinyproxy/pkg-plist2
6 files changed, 56 insertions, 11 deletions
diff --git a/www/tinyproxy/Makefile b/www/tinyproxy/Makefile
index 58f844d68384..71e4908e186f 100644
--- a/www/tinyproxy/Makefile
+++ b/www/tinyproxy/Makefile
@@ -6,19 +6,27 @@
#
PORTNAME= tinyproxy
-PORTVERSION= 1.3.3b
+PORTVERSION= 1.4.3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mitsuru@riken.go.jp
-BUILD_DEPENDS= ${LOCALBASE}/lib/libadns.a:${PORTSDIR}/net/adns
-
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --with-log-file=/var/log/tinyproxy.log --with-port=8080 --with-user=nobody --with-adns-include=${LOCALBASE}/include --with-adns-lib=${LOCALBASE}/lib
+CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --with-config=${PREFIX}/etc/tinyproxy/tinyproxy.conf
MAN8= tinyproxy.8
+post-patch:
+ @cd ${WRKSRC}/doc; f=tinyproxy.8; \
+ ${MV} $$f $$f.orig; \
+ ${SED} -e s:/etc/tinyproxy/tinyproxy.conf:${PREFIX}/etc/tinyproxy/tinyproxy.conf: \
+ < $$f.orig > $$f
+
+post-install:
+ ${MKDIR} ${PREFIX}/etc/tinyproxy
+ ${INSTALL_DATA} ${WRKSRC}/doc/tinyproxy.conf ${PREFIX}/etc/tinyproxy/tinyproxy.conf.sample
+
.include <bsd.port.mk>
diff --git a/www/tinyproxy/distinfo b/www/tinyproxy/distinfo
index 5b7de88448ec..f516fbdac72f 100644
--- a/www/tinyproxy/distinfo
+++ b/www/tinyproxy/distinfo
@@ -1 +1 @@
-MD5 (tinyproxy-1.3.3b.tar.gz) = bd60ff82019c63abc67491c261e9d351
+MD5 (tinyproxy-1.4.3.tar.gz) = d8b35d99e739023e8442ece2e3546398
diff --git a/www/tinyproxy/files/patch-aa b/www/tinyproxy/files/patch-aa
new file mode 100644
index 000000000000..225c927521d1
--- /dev/null
+++ b/www/tinyproxy/files/patch-aa
@@ -0,0 +1,11 @@
+--- src/sock.c.dist Tue Nov 13 06:10:29 2001
++++ src/sock.c Thu Feb 7 18:33:24 2002
+@@ -259,7 +259,7 @@
+
+ for (n = 1; n < maxlen; n++) {
+ again:
+- if ((rc = recv(fd, &c, 1, MSG_NOSIGNAL)) == 1) {
++ if ((rc = recv(fd, &c, 1, 0)) == 1) {
+ *ptr++ = c;
+ if (c == '\n')
+ break;
diff --git a/www/tinyproxy/files/patch-ab b/www/tinyproxy/files/patch-ab
new file mode 100644
index 000000000000..98be5cf05ee4
--- /dev/null
+++ b/www/tinyproxy/files/patch-ab
@@ -0,0 +1,22 @@
+--- src/tinyproxy.h.dist Fri Oct 26 02:27:17 2001
++++ src/tinyproxy.h Thu Feb 7 18:34:32 2002
+@@ -27,9 +27,6 @@
+ * Include standard headers which are used through-out tinyproxy
+ */
+ #include <sys/types.h>
+-#ifdef HAVE_SYS_RESOURCE_H
+-# include <sys/resource.h>
+-#endif
+ #ifdef HAVE_SYS_SELECT_H
+ # include <sys/select.h>
+ #endif
+@@ -44,6 +41,9 @@
+ # else
+ # include <time.h>
+ # endif
++#endif
++#ifdef HAVE_SYS_RESOURCE_H
++# include <sys/resource.h>
+ #endif
+ #include <sys/uio.h>
+ #include <netinet/in.h>
diff --git a/www/tinyproxy/pkg-descr b/www/tinyproxy/pkg-descr
index abfc9c1c040c..13b6cfc26e6b 100644
--- a/www/tinyproxy/pkg-descr
+++ b/www/tinyproxy/pkg-descr
@@ -1,10 +1,12 @@
-Tinyproxy is a lightweight, non-caching,optionally anonymizing http proxy.
-It is designed to consume a minimum of system resources.
-It listens on a given TCP port and handles HTTP proxy requests.
+tinyproxy is a GPLed, lightweight HTTP proxy. Designed from the ground up to be
+fast and yet small, it is an ideal solution for sites where a full-featured
+HTTP proxy is required, but the system resources required to run a more
+demanding HTTP proxy are unavailable. tinyproxy is fully compatible with all
+existing web browsers, and has a number of useful features including
+anonymous mode.
-Note that tinyproxy requires commandline arguments to run in anonymizing
-mode. For most people, "/usr/local/sbin/tinyproxy -a Host: -a Authorization:"
-is sufficient for an anonymizing proxy.
+Note that tinyproxy requires configuration to run in anonymizing
+mode. See tinyproxy.conf.sample for detail.
WWW: http://tinyproxy.sourceforge.net/
diff --git a/www/tinyproxy/pkg-plist b/www/tinyproxy/pkg-plist
index d774bef63f4f..4a8d4114fe72 100644
--- a/www/tinyproxy/pkg-plist
+++ b/www/tinyproxy/pkg-plist
@@ -1 +1,3 @@
sbin/tinyproxy
+etc/tinyproxy/tinyproxy.conf.sample
+@dirrm etc/tinyproxy