aboutsummaryrefslogtreecommitdiff
path: root/www/tntnet
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2014-01-27 21:50:45 +0000
committerJuergen Lock <nox@FreeBSD.org>2014-01-27 21:50:45 +0000
commitfaee3db96b3cb8f57f7412eed0155d351f87cb6f (patch)
tree8351d210f3587775168cc51033a60caee60a0d85 /www/tntnet
parent4ab70118ac2789110cacf92f1a74ea47d7c6ed98 (diff)
downloadports-faee3db96b3cb8f57f7412eed0155d351f87cb6f.tar.gz
ports-faee3db96b3cb8f57f7412eed0155d351f87cb6f.zip
Notes
Diffstat (limited to 'www/tntnet')
-rw-r--r--www/tntnet/Makefile23
-rw-r--r--www/tntnet/distinfo4
-rw-r--r--www/tntnet/files/patch-etc118
-rw-r--r--www/tntnet/files/patch-libcxx14
-rw-r--r--www/tntnet/pkg-plist34
5 files changed, 61 insertions, 132 deletions
diff --git a/www/tntnet/Makefile b/www/tntnet/Makefile
index c826243a6479..54f31d9214e9 100644
--- a/www/tntnet/Makefile
+++ b/www/tntnet/Makefile
@@ -2,18 +2,17 @@
# $FreeBSD$
PORTNAME= tntnet
-PORTVERSION= 2.1
-PORTREVISION= 1
+PORTVERSION= 2.2.1
CATEGORIES= www devel
MASTER_SITES= http://www.tntnet.org/download/
MAINTAINER= nox@FreeBSD.org
COMMENT= Webapplicationserver for C++
-LIB_DEPENDS= cxxtools:${PORTSDIR}/devel/cxxtools
+LIB_DEPENDS= libcxxtools.so:${PORTSDIR}/devel/cxxtools
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
-USES= iconv
+USES= iconv pkgconfig pathfix
USE_CSTD= gnu89
PATCH_STRIP= -p1
GNU_CONFIGURE= yes
@@ -29,26 +28,10 @@ LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --with-ssl=openssl
.endif
-MAN1= ecppc.1 ecppl.1 ecppll.1 tntnet-config.1
-MAN7= ecpp.7 tntnet.conf.7 tntnet.properties.7
-MAN8= tntnet.8
-
USERS= www
GROUPS= www
-NO_STAGE= yes
post-configure:
${REINPLACE_CMD} 's/^\(#define[[:space:]]*HAVE_SENDFILE[[:space:]]*\).*/\1\0/' ${WRKSRC}/framework/common/config.h
-post-install:
- @if [ ! -f ${ETCDIR}/tntnet.conf ]; then \
- ${CP} -p ${ETCDIR}/tntnet.conf.sample ${ETCDIR}/tntnet.conf ; \
- fi
- @if [ ! -f ${ETCDIR}/mime.conf ]; then \
- ${CP} -p ${ETCDIR}/mime.conf.sample ${ETCDIR}/mime.conf ; \
- fi
- @if [ ! -f ${ETCDIR}/tntnet.properties ]; then \
- ${CP} -p ${ETCDIR}/tntnet.properties.sample ${ETCDIR}/tntnet.properties ; \
- fi
-
.include <bsd.port.mk>
diff --git a/www/tntnet/distinfo b/www/tntnet/distinfo
index b4fa1d2ed0ee..3ac65cc59da1 100644
--- a/www/tntnet/distinfo
+++ b/www/tntnet/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tntnet-2.1.tar.gz) = 8623275f78e532a16f73a8b49b79a84fbf5eea314c22e8a7f7b8d50b3d081ab6
-SIZE (tntnet-2.1.tar.gz) = 1705181
+SHA256 (tntnet-2.2.1.tar.gz) = c83170d08ef04c5868051e1c28c74b9562fe71e9e8263828e755ad5bd3547521
+SIZE (tntnet-2.2.1.tar.gz) = 1127500
diff --git a/www/tntnet/files/patch-etc b/www/tntnet/files/patch-etc
index 8e9d92f3debe..47c32eab4faf 100644
--- a/www/tntnet/files/patch-etc
+++ b/www/tntnet/files/patch-etc
@@ -1,37 +1,22 @@
--- a/etc/Makefile.am
+++ b/etc/Makefile.am
-@@ -1,31 +1,36 @@
- nobase_dist_noinst_DATA = \
- tntnet/tntnet.conf.in \
-- init.d/tntnet.in
-+ init.d/tntnet.in \
-+ tntnet/mime.conf
+@@ -3,19 +3,20 @@ nobase_dist_noinst_DATA = \
+ init.d/tntnet.in
nobase_sysconf_DATA = \
-- tntnet/tntnet.conf \
+- tntnet/tntnet.xml \
- init.d/tntnet
-+ tntnet/tntnet.conf.sample \
++ tntnet/tntnet.xml.sample \
+ tntnet/tntnet
- nobase_dist_sysconf_DATA = \
-- tntnet/mime.conf
-+ tntnet/mime.conf.sample
-
- nobase_nodist_sysconf_DATA = \
-- tntnet/tntnet.properties
-+ tntnet/tntnet.properties.sample
-+
-+tntnet/mime.conf.sample: tntnet/mime.conf
-+ cp tntnet/mime.conf $@
-
--tntnet/tntnet.conf: tntnet/tntnet.conf.in
-+tntnet/tntnet.conf.sample: tntnet/tntnet.conf.in
+-tntnet/tntnet.xml: tntnet/tntnet.xml.in
++tntnet/tntnet.xml.sample: tntnet/tntnet.xml.in
sed -e 's,@libdir\@,@libdir@,g;' \
-e 's,@pkglibdir\@,@pkglibdir@,g;' \
-e 's,@sysconfdir\@,@sysconfdir@,g;' \
-e 's,@localstatedir\@,@localstatedir@,g;' \
-- -e 's,@datadir\@,@datadir@,g;' <tntnet/tntnet.conf.in >tntnet/tntnet.conf
-+ -e 's,@datadir\@,@datadir@,g;' <tntnet/tntnet.conf.in >tntnet/tntnet.conf.sample
+- -e 's,@datadir\@,@datadir@,g;' <tntnet/tntnet.xml.in >tntnet/tntnet.xml
++ -e 's,@datadir\@,@datadir@,g;' <tntnet/tntnet.xml.in >tntnet/tntnet.xml.sample
-init.d/tntnet: init.d/tntnet.in
+tntnet/tntnet: init.d/tntnet.in
@@ -42,52 +27,31 @@
- -e 's,@datadir\@,@datadir@,g;' <init.d/tntnet.in >init.d/tntnet
+ -e 's/^function //;' \
+ -e 's,@datadir\@,@datadir@,g;' <init.d/tntnet.in >tntnet/tntnet
-
--tntnet/tntnet.properties:
-+tntnet/tntnet.properties.sample:
- ../tntnet-config --properties tntnet | \
- sed -e 's,^#file=tntnet.log,file=@localstatedir@/log/tntnet/tntnet.log,' >$@
--- a/etc/Makefile.in
+++ b/etc/Makefile.in
-@@ -206,17 +206,18 @@ top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
- nobase_dist_noinst_DATA = \
- tntnet/tntnet.conf.in \
-- init.d/tntnet.in
-+ init.d/tntnet.in \
-+ tntnet/mime.conf
+@@ -246,8 +246,8 @@ nobase_dist_noinst_DATA = \
+ init.d/tntnet.in
nobase_sysconf_DATA = \
-- tntnet/tntnet.conf \
+- tntnet/tntnet.xml \
- init.d/tntnet
-+ tntnet/tntnet.conf.sample \
++ tntnet/tntnet.xml.sample \
+ tntnet/tntnet
- nobase_dist_sysconf_DATA = \
-- tntnet/mime.conf
-+ tntnet/mime.conf.sample
-
- nobase_nodist_sysconf_DATA = \
-- tntnet/tntnet.properties
-+ tntnet/tntnet.properties.sample
-
all: all-am
-@@ -483,21 +484,25 @@ uninstall-am: uninstall-nobase_dist_sysc
+@@ -470,19 +470,20 @@ uninstall-am: uninstall-nobase_sysconfDA
uninstall-nobase_sysconfDATA
--tntnet/tntnet.conf: tntnet/tntnet.conf.in
-+tntnet/mime.conf.sample: tntnet/mime.conf
-+ cp tntnet/mime.conf $@
-+
-+tntnet/tntnet.conf.sample: tntnet/tntnet.conf.in
+-tntnet/tntnet.xml: tntnet/tntnet.xml.in
++tntnet/tntnet.xml.sample: tntnet/tntnet.xml.in
sed -e 's,@libdir\@,@libdir@,g;' \
-e 's,@pkglibdir\@,@pkglibdir@,g;' \
-e 's,@sysconfdir\@,@sysconfdir@,g;' \
-e 's,@localstatedir\@,@localstatedir@,g;' \
-- -e 's,@datadir\@,@datadir@,g;' <tntnet/tntnet.conf.in >tntnet/tntnet.conf
-+ -e 's,@datadir\@,@datadir@,g;' <tntnet/tntnet.conf.in >tntnet/tntnet.conf.sample
+- -e 's,@datadir\@,@datadir@,g;' <tntnet/tntnet.xml.in >tntnet/tntnet.xml
++ -e 's,@datadir\@,@datadir@,g;' <tntnet/tntnet.xml.in >tntnet/tntnet.xml.sample
-init.d/tntnet: init.d/tntnet.in
+tntnet/tntnet: init.d/tntnet.in
@@ -99,29 +63,25 @@
+ -e 's/^function //;' \
+ -e 's,@datadir\@,@datadir@,g;' <init.d/tntnet.in >tntnet/tntnet
--tntnet/tntnet.properties:
-+tntnet/tntnet.properties.sample:
- ../tntnet-config --properties tntnet | \
- sed -e 's,^#file=tntnet.log,file=@localstatedir@/log/tntnet/tntnet.log,' >$@
-
---- a/etc/tntnet/tntnet.conf.in
-+++ b/etc/tntnet/tntnet.conf.in
-@@ -2,12 +2,15 @@
- #
-
- PropertyFile @sysconfdir@/tntnet/tntnet.properties
--Listen 0.0.0.0 80
-+#Listen 0.0.0.0 80
-+Listen 127.1 80
- #SslListen 0.0.0.0 443 @sysconfdir@/tntnet/tntnet.pem
-
- Daemon 1
--User www-data
--Group www-data
-+#User www-data
-+#Group www-data
-+User www
-+Group www
- CompPath @libdir@/tntnet
-
- # set some limit to prevent DoS-attacks
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+--- a/etc/tntnet/tntnet.xml.in
++++ b/etc/tntnet/tntnet.xml.in
+@@ -47,14 +47,14 @@
+
+ <listeners>
+ <listener>
+- <ip></ip>
++ <ip>127.0.0.1</ip>
+ <port>80</port>
+ </listener>
+ </listeners>
+
+ <daemon>1</daemon>
+- <user>www-data</user>
+- <group>www-data</group>
++ <user>www</user>
++ <group>www</group>
+ <pidFile>@localstatedir@/run/tntnet.pid</pidFile>
+ <documentRoot>/var/www</documentRoot>
+ <compPath>
diff --git a/www/tntnet/files/patch-libcxx b/www/tntnet/files/patch-libcxx
deleted file mode 100644
index 23720660b457..000000000000
--- a/www/tntnet/files/patch-libcxx
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/framework/common/tnt/multipart.h
-+++ b/framework/common/tnt/multipart.h
-@@ -75,7 +75,11 @@ namespace tnt
- : bodyBegin(), bodyEnd()
- { bodyBegin._C_iter = bodyEnd._C_iter = 0;}
- #else
-+#ifdef _LIBCPP_VERSION
-+ : bodyBegin(), bodyEnd()
-+#else
- : bodyBegin(0), bodyEnd(0)
-+#endif
- { }
- #endif
-
diff --git a/www/tntnet/pkg-plist b/www/tntnet/pkg-plist
index ce430f514ca2..d9c569d65bd9 100644
--- a/www/tntnet/pkg-plist
+++ b/www/tntnet/pkg-plist
@@ -4,15 +4,9 @@ bin/ecppll
bin/tntnet
bin/tntnet-config
%%ETCDIR%%/tntnet
-@unexec if cmp -s %D/etc/tntnet/mime.conf.sample %D/etc/tntnet/mime.conf; then rm -f %D/etc/tntnet/mime.conf; fi
-%%ETCDIR%%/mime.conf.sample
-@exec if [ ! -f %D/etc/tntnet/mime.conf ] ; then cp -p %D/%F %B/mime.conf; fi
-@unexec if cmp -s %D/etc/tntnet/tntnet.conf.sample %D/etc/tntnet/tntnet.conf; then rm -f %D/etc/tntnet/tntnet.conf; fi
-%%ETCDIR%%/tntnet.conf.sample
-@exec if [ ! -f %D/etc/tntnet/tntnet.conf ] ; then cp -p %D/%F %B/tntnet.conf; fi
-@unexec if cmp -s %D/etc/tntnet/tntnet.properties.sample %D/etc/tntnet/tntnet.properties; then rm -f %D/etc/tntnet/tntnet.properties; fi
-%%ETCDIR%%/tntnet.properties.sample
-@exec if [ ! -f %D/etc/tntnet/tntnet.properties ] ; then cp -p %D/%F %B/tntnet.properties; fi
+@unexec if cmp -s %D/%%ETCDIR%%/tntnet.xml.sample %D/%%ETCDIR%%/tntnet.xml; then rm -f %D/%%ETCDIR%%/tntnet.xml; fi
+%%ETCDIR%%/tntnet.xml.sample
+@exec if [ ! -f %D/%%ETCDIR%%/tntnet.xml ] ; then cp -p %D/%F %B/tntnet.xml; fi
include/tnt/applicationunlocker.h
include/tnt/backgroundworker.h
include/tnt/cmd.h
@@ -69,14 +63,10 @@ include/tnt/worker.h
include/tnt/zdata.h
lib/libtntnet.la
lib/libtntnet.so
-lib/libtntnet.so.10
-lib/libtntnet_cgi.a
-lib/libtntnet_cgi.la
-lib/libtntnet_cgi.so
-lib/libtntnet_cgi.so.10
+lib/libtntnet.so.12
lib/libtntnet_sdk.la
lib/libtntnet_sdk.so
-lib/libtntnet_sdk.so.10
+lib/libtntnet_sdk.so.12
lib/tntnet/alldemos.la
lib/tntnet/alldemos.so
lib/tntnet/alldemos.so.0
@@ -134,10 +124,20 @@ lib/tntnet/strings.so
lib/tntnet/strings.so.0
lib/tntnet/tntnet.la
lib/tntnet/tntnet.so
-lib/tntnet/tntnet.so.10
+lib/tntnet/tntnet.so.12
lib/tntnet/upload.la
lib/tntnet/upload.so
lib/tntnet/upload.so.0
+man/man1/ecppc.1.gz
+man/man1/ecppl.1.gz
+man/man1/ecppll.1.gz
+man/man1/tntnet-config.1.gz
+man/man7/ecpp.7.gz
+man/man7/tntnet.properties.7.gz
+man/man7/tntnet.xml.7.gz
+man/man8/tntnet.8.gz
+%%DATADIR%%/tntnet-conf2xml.pl
+@dirrm %%DATADIR%%
@dirrm lib/tntnet
@dirrm include/tnt
-@dirrm %%ETCDIR%%
+@dirrmtry %%ETCDIR%%