aboutsummaryrefslogtreecommitdiff
path: root/www/tomcat6/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-07-26 15:28:49 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-07-26 15:28:49 +0000
commitbd246897e7f8f1cb1146ae2cd1d7ae465fff2749 (patch)
treec858c2e165e739843e72d955af748ca4a1469ccc /www/tomcat6/Makefile
parentf554cfdb78c9ed47d66ee4ab93bea12efa45027e (diff)
downloadports-bd246897e7f8f1cb1146ae2cd1d7ae465fff2749.tar.gz
ports-bd246897e7f8f1cb1146ae2cd1d7ae465fff2749.zip
Notes
Diffstat (limited to 'www/tomcat6/Makefile')
-rw-r--r--www/tomcat6/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/tomcat6/Makefile b/www/tomcat6/Makefile
index c94b2602b717..9f6f17c10bfb 100644
--- a/www/tomcat6/Makefile
+++ b/www/tomcat6/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= jakarta-tomcat
-PORTVERSION= 5.0.25
+PORTVERSION= 5.0.27
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= tomcat-5/v${PORTVERSION}/bin
@@ -113,6 +113,10 @@ do-install:
@${MKDIR} ${LOG_DIR}
@${ECHO_CMD} " [ DONE ]"
+ @${ECHO_CMD} -n ">> Backing up configuration files..."
+ @${MV} ${APP_HOME}/conf ${APP_HOME}/conf.orig 2>/dev/null || true
+ @${ECHO_CMD} " [ DONE ]"
+
@${ECHO_CMD} -n ">> Copying files to destination directory..."
@${CP} -R ${WRKSRC}/* ${APP_HOME}
@${CP} ${WRKDIR}/server.xml ${APP_HOME}/conf/