aboutsummaryrefslogtreecommitdiff
path: root/www/tomcat6
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-10-26 08:19:05 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-10-26 08:19:05 +0000
commit3a0afc777d76c2596c68cae6aafa9f41a5af6146 (patch)
treeffc711871bd454cb53e2ff567b5c09298e70dafb /www/tomcat6
parentf1c24a1123ecbcb0ff5ac68c131bb380c4bed360 (diff)
downloadports-3a0afc777d76c2596c68cae6aafa9f41a5af6146.tar.gz
ports-3a0afc777d76c2596c68cae6aafa9f41a5af6146.zip
Notes
Diffstat (limited to 'www/tomcat6')
-rw-r--r--www/tomcat6/Makefile1
-rw-r--r--www/tomcat6/files/tomcat6.sh.in16
2 files changed, 13 insertions, 4 deletions
diff --git a/www/tomcat6/Makefile b/www/tomcat6/Makefile
index ba75deaf6e98..de252a991457 100644
--- a/www/tomcat6/Makefile
+++ b/www/tomcat6/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tomcat
PORTVERSION= 6.0.29
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tomcat/tomcat-6/v${PORTVERSION}/bin
diff --git a/www/tomcat6/files/tomcat6.sh.in b/www/tomcat6/files/tomcat6.sh.in
index 42bf6c29fc62..ac8c9e588eea 100644
--- a/www/tomcat6/files/tomcat6.sh.in
+++ b/www/tomcat6/files/tomcat6.sh.in
@@ -140,19 +140,27 @@ tomcat_stop() {
tomcat_status() {
rc_pid=$(tomcat_check_pidfile $pidfile)
- if [ -z "$rc_pid" ]; then
- [ -n "$rc_fast" ] && return 0
- echo "${name} not running? (check $pidfile)."
+ if [ -n "$rc_pid" ]; then
+ echo "${name} is running as pid $rc_pid."
+ else
+ echo "${name} is not running."
return 1
fi
}
tomcat_poll() {
+ rc_pid=$(tomcat_check_pidfile $pidfile)
+
+ _prefix=
while (true) ; do
- rc_pid=$(tomcat_check_pidfile $pidfile)
[ -z "$rc_pid" ] && break
+ echo -n ${_prefix:-"Waiting for PIDS: "}$rc_pid
+ _prefix=", "
sleep 2
done
+ if [ -n "$_prefix" ]; then
+ echo "."
+ fi
}
tomcat_check_pidfile() {