aboutsummaryrefslogtreecommitdiff
path: root/www/trac-customfieldadmin
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-12 16:16:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-12 16:16:17 +0000
commit5ebdfa296c411d4e6eb4e825db2a436eed0bbe52 (patch)
tree634a9be7db0d8af4faa3879d99b5e7bef8c924d5 /www/trac-customfieldadmin
parent1d9987bccde89142f342845e0d876da79ac11e5c (diff)
downloadports-5ebdfa296c411d4e6eb4e825db2a436eed0bbe52.tar.gz
ports-5ebdfa296c411d4e6eb4e825db2a436eed0bbe52.zip
Notes
Diffstat (limited to 'www/trac-customfieldadmin')
-rw-r--r--www/trac-customfieldadmin/Makefile34
-rw-r--r--www/trac-customfieldadmin/distinfo3
-rw-r--r--www/trac-customfieldadmin/pkg-descr8
-rw-r--r--www/trac-customfieldadmin/pkg-message9
-rw-r--r--www/trac-customfieldadmin/pkg-plist1
5 files changed, 55 insertions, 0 deletions
diff --git a/www/trac-customfieldadmin/Makefile b/www/trac-customfieldadmin/Makefile
new file mode 100644
index 000000000000..78327e8a0475
--- /dev/null
+++ b/www/trac-customfieldadmin/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: trac-customfieldadmin
+# Date created: Jan 11 2008
+# Whom: Greg Larkin <glarkin@sourcehosting.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= customfieldadmin
+PORTVERSION= 0.1
+CATEGORIES= www devel python
+MASTER_SITES= http://www.sourcehosting.net/freebsd/distfiles/
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+
+MAINTAINER= glarkin@sourcehosting.net
+COMMENT= Web interface to administer Trac ticket custom fields
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac \
+ ${PYTHON_SITELIBDIR}/TracWebAdmin-0.1.2dev-py${_PYTHON_VERSION}.egg:${PORTSDIR}/www/trac-webadmin
+
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin/0.10
+NO_BUILD= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHONVERSION=${_PYTHON_VERSION}
+PYDISTUTILS_NOEGGINFO= yes
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/trac-customfieldadmin/distinfo b/www/trac-customfieldadmin/distinfo
new file mode 100644
index 000000000000..24f5abf1c889
--- /dev/null
+++ b/www/trac-customfieldadmin/distinfo
@@ -0,0 +1,3 @@
+MD5 (customfieldadminplugin-0.1.zip) = c7bb8d3e2591fb0e7a3690c4450341bf
+SHA256 (customfieldadminplugin-0.1.zip) = 32b584c685de70df4b12be4256f0b88d17b72974fd11472751be1a2701f630a4
+SIZE (customfieldadminplugin-0.1.zip) = 13678
diff --git a/www/trac-customfieldadmin/pkg-descr b/www/trac-customfieldadmin/pkg-descr
new file mode 100644
index 000000000000..b4d4ca22529e
--- /dev/null
+++ b/www/trac-customfieldadmin/pkg-descr
@@ -0,0 +1,8 @@
+This plugin is a Web Admin panel for administrating custom fields -
+adding, modifying and deleting them without editing the trac.ini file
+directly.
+
+This plugin is a cooperation between CodeResort.com and Optaros.com,
+and is made freely available under a BSD license.
+
+WWW: http://trac-hacks.org/wiki/CustomFieldAdminPlugin
diff --git a/www/trac-customfieldadmin/pkg-message b/www/trac-customfieldadmin/pkg-message
new file mode 100644
index 000000000000..4046ca5d72d6
--- /dev/null
+++ b/www/trac-customfieldadmin/pkg-message
@@ -0,0 +1,9 @@
+**************************************************
+To complete the installation, please add:
+
+[components]
+customfieldadmin.* = enabled
+
+to your trac.ini to enable the ticket custom field
+administrator.
+**************************************************
diff --git a/www/trac-customfieldadmin/pkg-plist b/www/trac-customfieldadmin/pkg-plist
new file mode 100644
index 000000000000..b149cde24183
--- /dev/null
+++ b/www/trac-customfieldadmin/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/TracCustomFieldAdmin-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg